• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 314
  • Last Modified:

Can my wireless notebook connect to my desktop?

Hey, I have a home desktop that connects to a linksys router, which connects to a cable modem.  The linksys router also connects to an intel "wireless gateway", which works fine; when I bring my work laptop home it connects to the wireless access point and I can browse the internet wirelessly at home.  i.e.:

Laptop  <-->   Intel wireless gateway  <--> Linksys router <--> cable modem
                                                                  ^
Desktop   <----------------------------------------|

Both desktop and laptop can browse the web fine.  

What I'd like to do now is basically have the laptop and the desktop be able to "ping" each other (for a couple of reasons, primarily I'm trying to VNC my desktop from my laptop).  When I look at the Intel WG setup, it seems to have an IP of 192.0.2.1 (which is the factory default), and it seems to be issuing an IP address of 192.0.2.2 to my laptop.  The linksys seems to be at 192.168.1.1 (also default) and seems to have issued my desktop an IP address of 192.168.1.102.

(Actually, looking at the DHCP table of my linksys router, it has also issued my wirelss gateway an IP address of 192.168.1.101.  So is my intel WG using both 192.0.2.1 AND 192.168.2.1??)

Anyway, I can't ping the desktop from the laptop.  I was wondering how I can change my configuration to be able to do this.  I'm guessing the problem is that they are on two subnets, 192.0.2.x and 192.168.0.x.  So I went through the setup wizard on the Intel WG to use the IP address 192.168.1.3, and to NOT function as a DHCP server, hoping my laptop would pick up an IP address from the linksys through the WG, and everybody would be on the same subnet.  That doesn't seem to work; now my laptop can't get to the internet wirelessly.

So I'm sort of out of my depth here... can anyone educate me on this stuff, and/or have any ideas what I'm doing wrong?






router might be 192.168.1.1
0
riceman0
Asked:
riceman0
  • 4
  • 4
  • 2
  • +5
1 Solution
 
riceman0Author Commented:

A little more info/clarification... looking at my Intel WG setup screen (after futzing a little), I see that:

the WAN(10M) IP Address:         192.168.1.101
the LAN(10/100M) IP Address:         192.0.2.1

192.0.2.1 is the address that my wirelessly-connected laptop sees as a "Default gateway", and 192.168.1.101 is the address that my linksys router reports in its DHCP table as having issued to the Intel WG.  My desktop is still at 192.168.1.102.

Is it possible to make it so that laptop and desktop are on the same subnet?  So that I can ping between the two?
0
 
cyrusunccCommented:
change the wireless router's address to 192.168.1.2 and turn off dhcp

this way the laptop will get its ip address from the linksys router and they'll be on the same subnet.

This is that you need in order for those devices to ping each other.
0
 
cyrusunccCommented:
whoops, forgot to mention the wireless access point needs to have the linksys's ip address 192.168.1.1 as the gateway
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
snerkelCommented:
You could setup your wireless router (assuming it has a LAN port) like this http://www.tech24.arce.co.uk/rap.htm

If connecting from our laptop to desktop using VNC you should be able to just use the IP address of your desktop even with your existing setup.

ps 192.0.2.x is a weird IP address for your WAP
0
 
CKWTCommented:
the way you could this to work is not changing the IP of the WG, but forward IP's from one router to the other...
The concept works this way:

ip route 192.0.2.0 255.255.255.0 192.168.1.101
         (Net to reach)(subnet)        (Device where that net is behind)

like this

                                         Linksis (this device should have the Routing Rule configured on it)
                                       /           \
  (WAN-192.168.1.101) Intel WG      PC(192.168.1.102)
    LAN- 192.0.2.1           /
                                   /
           (192.0.2.2)    Laptop        

So like this Your 192.168.1.x network will reach 192.0.2.x network...

Any more help just post back.
0
 
masnrockCommented:
On the Intel unit, you could shut off anything related to NAT or DHCP. You really want it to act like an access point for your network. (The NAT being performed by the Intel unit is what's causing your problems with communicating between wired and wireless as you have it now)

I also agree with the comment on giving the Intel unit itself a static IP address.

What would've by far been the simplest thing to do would've been to have a wireless router replace both devices, then you know everything's cool. However, we're giving suggestions based on what you have since it is very much possible to do what you're aiming to do.
0
 
CKWTCommented:
the real simpliest way is to try to enable bridging on your wireless gateway. just like masnrock said. No NAT.

My comment before is in case your device is only 1 way possible as a router. and fail safe
0
 
riceman0Author Commented:
* A Wireless Access Point Only
The device communicates with wireless clients only.

* A Gateway Only         
The device functions as a gateway. The gateway function provides a network interface from wired clients to the Internet.

 * A Wireless Access Point and Gateway
The device communicates with wireless clients and functions as a gateway. The gateway function provides a network interface from wired and wireless clients to the Internet.

as advised trying the bridging thing, trying to "dumb down" the intel WG, assume I want the second of the above 3 options.  Will proceed on that assumption, let you guys know...
0
 
riceman0Author Commented:

Oops, meant the FIRST, not the second.
0
 
riceman0Author Commented:

When I make it a wireless point only, it indicates that this will turn off DHCP (as masnrock suggested).  But whenever I do that, it seems like my laptop can't get to it wirelessly.  I guess the linksys is supposed to be serving my laptop an IP address *through* the intel device, right?  But that doesn't seem to be happening.  Will keep futzing...
0
 
Justin MaloneCommented:
wow alot of remarks here, i havvent read them all but if you get any address from the WG then you have a problem. the WG needs to be bridged and you should be getting an address from the linksys. the problem is your cable modem is giveing your linksys router a public address and then your linksys is useing that public address with 2 services called NAT and DHCP to divide it and make it useable for more than one computer. NAT is a type of 1-1 mapping that maps the MAC address of your pc in order to send information. because of this NAT can only be used once. if you try to use NAT on a signal that is allreddy useing NAT routeing stops. so to continue with what i was saying the linksys is useing NAT and DHCP to distribute ip address then your WG is also useing NAT and DHCP to distribute ip addresses..

options.
Bridge your WG ... (in other words turn off DHCP and NAT and either choose a bridge option or simply plug the linksys into a switchport on the WG)

i was going to give another option but in the process of typeing it i realized that it wouldnt work lol. :)
0
 
jli168Commented:
Your Wireless router is getting an IP address from your Linksys router. That is fine. You should be able to ping your desktop from your laptop fine. One thing you have to check is your windows firewall if they are on Winxp. Make sure they are allow to pass thru or it must be turn off.

0
 
Bill_FleuryCommented:
msnrock was the closest to being correct, the only other possibility is that you would need to plug your linksys into the LAN port on the Intel WAP after setting it as an access point only.
0
 
snerkelCommented:
>> msnrock was the closest to being correct, the only other possibility is that you would need to plug your linksys into the LAN port on the Intel WAP after setting it as an access point only.

If you check my link that explains how to convert a wireless router to what is effectively a wireless AP, this is similar to the info posted by masnrock only in greater detail.
0
 
snerkelCommented:
This surrely goes against convention as I gave the same answer prior to the answer you have force accepted!!!
0
 
snerkelCommented:
Any news on this as it clearly is not in accordance with experts-exchange rules on awarding points.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 2
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now