IIS 5.1 and Delphi 7 - "The specified module could not be found."

I am using default folders for everything.

I created a script in Delphi 7 and placed the resulting DLL in:
C:\Inetpub\Scripts

Also, any tips on how to load and unload the modules so I don't have to restart my computer would be helpful once I get this working...


This is the HTML code I used...

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
  <HEAD>
    <TITLE> Project Test 1 </TITLE>
  </HEAD>
  <BODY>

  <FORM METHOD="post" ACTION="http://localhost:81/scripts/Project1.dll">
    Name:
      <input type="text" name="NAME_FIELD"><br>
    SurName:
      <input type="text" name="SURNAME_FIELD"><br>

    <input type="submit" name="Submit" value="Submit"><br> <input type="reset" name="reset" value="Reset"> </FORM>

  </BODY>
</HTML>


unit test1;

interface

uses
  SysUtils, Classes, HTTPApp;

type
  TWebModule1 = class(TWebModule)
    procedure WebModule1WebActionItem1Action(Sender: TObject;
      Request: TWebRequest; Response: TWebResponse; var Handled: Boolean);
  private
    { Private declarations }
  public
    { Public declarations }
  end;

var
  WebModule1: TWebModule1;

implementation

{$R *.dfm}

procedure TWebModule1.WebModule1WebActionItem1Action(Sender: TObject;
  Request: TWebRequest; Response: TWebResponse; var Handled: Boolean);
begin
  Response.Content := 'Hello';
end;

end.
werehamster-Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ewildeCommented:
it might be a prmissions problem. go to IIS Directory Security and change the account used for anonymous access to the guest account.

Goodluck,
ewilde.
geobulCommented:
Hi,

Prhaps you have to enable executables to be launched by IIS also. As far as I remember the default was 'scripts only'. Open your IIS administrative console, select the web site's properties, go to 'Home Directory' tab and change 'Execute Permissions' to 'Scripts and Executables'.

Regards, Geo
dygjCommented:
Unloading your module:
rigth click on the scripts folder in IS5 and select properties. Click the unload button.

Permission execute (and scripts),
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

werehamster-Author Commented:
ewilde: I do not have a guest account on this computer.  It is set to my main account, IUSR_WEREHAMSTER, which has full administrative rights.  I've tried it with guest and administrator with no luck.  Administrator did give a different error because it did not have a password.

geobul: I have it already set to "Scripts and Executables".

I've basically already tried all the basics I could think of.  Need to think out of the box for this one.  :)
Imthiyaz_phCommented:
Plz check whether the default property of that action "WebActionItem1" is set to true, since you havnt specified any additional path after the dll name (in POST method).
werehamster-Author Commented:
Imthiyaz_ph: I've tried it both ways; with a path and using a default.  Still no good.

I've recently used DEPENDS.EXE to see if it was missing any dependencies.  Really didn't help much.  I guess my next step is to see if I can find some other DLL to try to see if it's IIS or delphi.
Imthiyaz_phCommented:
i think you have put the dll in the wrong folder. What i used to do was create a "scripts" folder under "wwwroot" folder, assign the necessary permissions and put the dll inside that folder.

Even in your case, the path in the post method is referring to a folder inside the wwwroot.

regards
Imthiyaz
Imthiyaz_phCommented:
Also check the following answer, its says to unregister and register the system dlls:

http://www.experts-exchange.com/Programming/Programming_Languages/Dot_Net/ASP_DOT_NET/Q_21462035.html
Imthiyaz_phCommented:
i m sorry, i think i hv made a mistake regarding the scripts folder. I used to work with multiple sites, so i had to create script folder for each site. And also by default, iis creates a virtual directory for the scripts folder.
werehamster-Author Commented:
I figured it out.  Scripting services was not installed.  4 days of headaches by a simple windows component install that apparently wasn't installed by default.
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.