[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 608
  • Last Modified:

Can open some internet sites - but not others

Neither Google nor Yahoo work, but there's a lot of other sites I can go to...   This makes it hard to find answers on the net - no search engine...

I went to Microsoft to try to download some updates etc, and got this:
    Security Alert:  Your current security settings do not allow this file to be downloaded.

I deleted all cookies and temporary internet files, set internet security to the lowest setting, turned off microsoft firewall, turned off McAfee firewall - and spent all day trying to figure this out.

My Dell came with SP2 installed, so if it's a problem with XP, I'd have to reinstall it I suppose.

Sometimes when I click on a link, another window opens but there's nothing in the address box, and no page loads.

If I have to reinstall XP, at least the system is working well enough now that maybe I could burn to CD a bunch of stuff on my hard drive before doing so.

It doesn't look good - but it's been worse.

Thanks!

0
pilk00
Asked:
pilk00
  • 5
  • 4
  • 4
  • +6
1 Solution
 
SheharyaarSaahilCommented:
has the problem just started or its like this since you have purchased this system?
also, have you tried another browser yet, just to figure out if the problem is with the system or with IE?
all other users of the system face the same issue or just your account?
0
 
venom96737Commented:
sounds like you have adaware spyware or a virus check your system out to see if you can come up with anything.  You could also post a hjt log and I can have a look.
0
 
rsivanandanCommented:
First may be try to repair your IE install ?

http://support.microsoft.com/?kbid=318378

http://www.theeldergeek.com/repair_ie6.htm

try these.

Cheers,
Rajesh
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
nobusCommented:
i suggest running ALL these, - updated :

     adaware :      http://www.lavasoftusa.com/
     Spybot :        http://www.download.com/3000-8022-10122137.html
http://housecall.trendmicro.com/                                                               online scan for trojans
http://www.spychecker.com/program/hijackthis.html                                   download
http://www.hijackthis.de/index.php?langselect=english                                check the log
http://www.microsoft.com/athome/security/spyware/software/default.mspx       Anti spyware
0
 
phototropicCommented:
It would be a good idea to check for the latest Java updates also.

Check it out here:

http://www.java.com/en/download/help/javaconsole.xml

Sometimes a problem with only having access to some sites but not others can be a simple matter of updating software.
0
 
willcompCommented:
If problem persists after malware removal, try using Firefox and see if you have the same problem.  If so, then browser is not the issue (Shehary recommended another browser also).

Firefox link - http://www.mozilla.com/

Although not normal symptoms of a winsock LSP problem, won't hurt to run this utility, especially if you had to remove malware.

Winsockfix link - http://www.tacktech.com/display.cfm?ttid=257

Also try pinging Yahoo from a command prompt.  Enter cmd in run box.  At prompt, type:  ping yahoo.com

Yahoo is one of the few sites that will return a ping from URL.  If ping is not successful, likely have a DNS problem.
0
 
pilk00Author Commented:
Thanks for the responses!

SheharyaarSaahil -  
       The problem just started yesterday
        I have not tried another browser - would you recommend one?
        I'm the only user of the machine

ADDITONAL INFO (1)-
I noticed a weird behavior yesterday when trying to install something called e-Blaster on my machine - wanted to see what kind of tools are used today by businesses to monitor employee internet activity.  When I clicked on "install", my system rebooted.  Problems ever since.  Maybe e-Blasteris for servers only(?)

ADDITONAL INFO (2)-
When I try to download something now - from MS or Java, I get "Cookies must be enabled to message you correctly.  Enable cookies and reload the page."

ADDITONAL INFO (3)-
I've been using PowerPoint a lot, and I kept seeing PowerPlugs by Crystal Graphics as PowerPoint opened.  I figured whatever this was it wasn't working, so I deleted it.  Had some trouble deleting a couple .dll's.  Maybe PP comes with PowerPlugs(?)

ADDITIONAL INFO (4)-
Still haven't found a way to use the "search" feature of IE - since problems began yesterday.  When I click Search from the IE toolbar, and then customize, another window opens but it's totally blank.

venom96737
        I did a full scan of my hard drive yesterday with McAfee - nothing found
        What's an "jht log"?

rsivanandan
        It seems to me that XP w/SP2 does not allow one to uninstall and re-install just IE.
        It might be easier if I had installed SP2 myself, but it came with the machine.

nobus:
        I can't open the lavasoftusa link.  I'll try some or all of these if other solutions don't work.

phototropic:
       See ADDITONAL INFO (2) above
0
 
phototropicCommented:
OK - click on Internet Explorer - Tools - Internet Options - Privacy. Click the "advanced" tab. Put a tick in the "override automatic cookie handling" box. Make sure that both First Party and Third Party cookies are enabled. OK your way out and try again to download a Java update.
0
 
SheharyaarSaahilCommented:
>>       The problem just started yesterday
        I have not tried another browser - would you recommend one?
        I'm the only user of the machine

1. Can we consider a System Restore?
2. Firefox
3. Try creating a new user account and try with that user, if the other user is running without this problem, we can try importing IE registries from the working user to the non-working user account
0
 
nobusCommented:
i can open the lavasoft link without problems. . .
0
 
samb39Commented:
This sounds like a browser hijacker to me.  I recommend you go to another machine and download Stinger, save it on a floppy, and run it on the problem machine.

Get stinger here:

http://vil.nai.com/vil/stinger/
0
 
pilk00Author Commented:
Thanks for the responses - I'm realizing I'm going to have to use another computer to download some things to figure this out - Firefox, Stinger, Winsock Fix, Java updates, etc...

phototropic-
    I checked the settings and they were already set at what you suggested.  
    The only one I changed was:  "Always allow session cookies", which was checked and I unchecked it.
    Still unable to download anything or use IE search.

SheharyaarSaahil-

     I did a system restore last night (Saturday night) to a restore point on Friday.  
     After that, I was able to use google etc, but then after moving some things around and deleting PowerPlugs, I was
         back where I started.  So I undid the restore, which didn't work - said "no change".  So I tried an earlier date with
         the same result - "no change".  Does system restore just affect the operating system?  I'd gladly use a much
         earlier date - as long as I don't lose a bunch of data, etc.
     I got to the Firefox page, but when I clicked on "Download", I got the message about "Your security settings do not
         allow this file to be downloaded.  I have a laptop from work I can use for the downloads - it's set up for dial-up,  
         but I haven't gotten it set up yet for high-speed cable.
     I will try your other suggestion - set up a new user.

nobus-
     I didn't mean your link was bad - I just wasn't able to use it.  
     Now I'm getting the page open, but when I click on "Download", another window opens with nothing in the
         address block & nothing on the page.

samb39-
     I will try that!  I think you might be right.  The other night I had Morpheus running for several hours.  Who knows  
         what crap someone might have left me.

willcomp-
     I will try the winsock fix once I get to another computer to download it and some other things.
0
 
venom96737Commented:
hey hjt=hijack this log it gathers up information from certain areas useful in discovering virus's and such and even if your virus scanner says its clean doesn't mean its clean.  I have worked on them many times that 4 scanners say it is clean as a whistle and never notice it until u start removing it manually and then it says oh wait thats a virus.
0
 
phototropicCommented:
Have we established whether or not this is a browser issue? Any way you can download Firefox or some other browser.

If the problem is confined to IE, try running System File Checker: type "sfc /scannow" (without the quotes) in the Run box. Have your XP CD handy.

Winsock fixes:

 http://www.snapfiles.com/get/winsockxpfix.html
www.cexx.org/lspfix.htm 

Have you tried a repair install of XP

www.michaelstevenstech.com/XPrepairinstall.htm 

Good luck
0
 
samb39Commented:
The fact that System Restore does not work strongly suggests that you are infected with a browser hijacker.  If you are, it will probably prevent spyware from running correctly, and it may even spoof the screens to make it look like scans, updates, etc. are running when they are not.  I would not trust what you see on that machine until you have downloaded stinger on a different machine and run it on the malfunctioning one.
0
 
willcompCommented:
The first thing I do is disable all startup items using msconfig.  Also recommend disabling System Restore if you are sure that malware is located on your PC.  Both can be done in safe mode.

Nobus gave you a good list of programs to download and run.  Notes on some:

I would run Spybot Search and Destroy first.  The Spybot home site (and perhaps download.com) has an executable file that updates definitions and engine.  Download and run the upadte file.  A definition file update for AdAware is available on download.com.  Extract it and copy defs.ref to Lavasoft\AdAware folder in Programs folder.

Both Spybot and AdAware will install and run in safe mode if necessary.  If run in safe mode, rerun in normal mode.

Hijack This (HJT) is a most useful tool in the hands of an experienced user.  If you are not certain about what items to delete, ask questions or post your HJT log to one of the web sites that specialize HJT log analysis.  I'll let someone else recommend one since I have no experience with them.  HJT also will run in safe mode.

If you are running Morpheus, you definitely have adware and spyware.  Possibly a number of other nasties as well.
0
 
nobusCommented:
if you are having problems, try running adaware and spybot in safe mode.
you can also download adaware and spybot on another PC, copy it to the bad one, and run it there. Don't forget to upgrade !
0
 
xpsavyCommented:
Hi pilk00

Reregister all the IE files

www.regsvr32.notlong.com 

download and run this file that will reregister all the IE files

All the best

Rupesh Krishna
0
 
pilk00Author Commented:
Thanks for all the suggestions.

I downloaded pretty much all of the suggested fixes & programs.  Will be trying some of your ideas tonight/tomorrow.
0
 
pilk00Author Commented:
Update:
I installed Firefox and it works - even for Google - I can see again!  Thanks to SheharyaarSaahil, the first to suggest trying a different browser, and to others who recognized that as the essential first step.

I installed Adaware which detected 5 critical items - all data miner tracking cookies, which I got rid of.

Then I installed Spybot which detected 7 problems - 3 involved WhenU.SaveNow, 1 for WhenU.Search.Desktoptoobar, 2 involved Windows security - antivirus and firewall, and finally GrokLoader.

Rebooted, opened IE, and still can't get into Google that way.

Any further advice (based on what I found today) before I try some of the other fixes?
0
 
willcompCommented:
Try Microsoft Windows Defender next.  It should reset IE for you.

http://www.microsoft.com/downloads/details.aspx?FamilyID=435bfce7-da2b-4a6a-afa4-f7f14e605a0d&DisplayLang=en

A note about Defender.  You must have a legit copy of XP with SP2 installed or W2K with a GDI update installed.

Also Winsockfix that I referenced earlier.  You probably don't have a sockets problem, but I'm not familar enough with LSPs to know if some will only affect IE and not other browsers.
0
 
SheharyaarSaahilCommented:
what about the new user account?
0
 
pilk00Author Commented:
willcomp - I ran it, but no change in IE
                same with winsockfix

SheharyaarSaahil - will try that one tomorrow

Thanks!  At least I have Firefox - back to normal more or less, but it bothers me that IE is messed up.

BTW, I'm starting to get a nasty alert about scvhost I think it's called - on startup.


0
 
SheharyaarSaahilCommented:
nobus gave you the link for Hijackthis download and analysation of its log..... download it, get its log and have it analysed on the website he has mentioned,
and post here the link....looks like you are having some nasties on your system :-?
0
 
willcompCommented:
svchost is a legitimate service that can be co-opted and used by malware.  Do not delete svchost, it is a required service.

Take Shehary's advice and try HJT next.  A good virus scan is also recommended.

The gold standard in adware/spyware removal is, in my opinion, Spy Sweeper.  They did have a 14 day trial version, but it apparently has been discontinued.  Mayn be worth purchasing if needed.  Link:

http://www.webroot.com/consumer/products/spysweeper/
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 5
  • 4
  • 4
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now