Complete novice needs help finishing pine installation due to problems with failed dependencies on Red Hat Fedora 4

Posted on 2006-04-16
Last Modified: 2013-12-15
I purchased a book called "Setting Up Lamp" and I am a complete novice to Linux. I managed to complete the first chapter, which is to get Linux installed and running, but I am  now completely stuck. The book asked me to download the pine editor by following this command:


The file downloaded perfectly. The book then asked me to use the following command to install the pine:

rpm -ivh pine.i386.rpm

But it failed and gave me the following output:

error: Failed dependencies: is needed by pine-4.58-2.i386 is needed by pine-4.58-2.i386 is needed by pine-4.58-2.i386 is needed by pine-4.58-2.i386

I know that there are other editiors but the book uses this one and I want to fix this problem. I've never dealt with dependencies before and I would really appreciate a step by step break down of what I can do to resolve this issue. I should also mention that I am running Red Hat Fedora 4 and I have selected and installed all of the correct packages that the book asks for during the Red Hat installation procces .  Lastly, the book is written for Fedora 2 but the installation for Fedora 4 seems to be exactly the same as whats described in the book, including the package selection. An exact step by step break down of what I should do would be greatly appreciated.
Question by:jerrykobes
    LVL 15

    Accepted Solution

    Install these two packages first to solve dependencies:


    The easiest way to do so would be:

    yum install openldap
    yum install openssl097a

    Note that you may already have these installed. After you install them, try Pine package from this page:

    The packages there are specifically built for FC4.

    Author Comment

    Thank you for your awnser, but I have a few last questions regarding your solution. How did you know that those were the two packages (is that what they were? packages?) that needed to be installed for those four dependencies? Where would I look in the future if I ran into the same problem with missing other dependencies? Lastly, what the hell are dependencies in "Windows" terms and why do I have to deal with them in the first place?
    LVL 15

    Expert Comment

    I ran

    rpm -q --whatprovides

    on my system. Another easy idea is just google, and you'll typically hit an RPM description that provides it.

    There really is no equivalent to RPM dependencies in Windows, and that's what makes RPM-based distros a lot more stable and modular than Windows. The files you were missing are "shared objects" (.so), they are roughly equivalent to Windows DLLs. If you ever heard the term "DLL hell", then the dependencies definitions is how a RPM-based Linux is solving this problem.

    Basically, every package has strictly defined set of things it depends on (i.e. requires to be present on a system for it to work) and a set of things it "provides" - they are either files contained in the package or capabilities. This way you are protected from the problems similar to those that happen in Windows due to DLL mismatch - when you overwrite or update system libraries with newer (or older) versions while installing something and it breaks other applications.

    yum is one of the tools that let you query dependence information for packages not yet installed, so in your case you could have done

    yum whatprovides

    for example. All in all, if you want to know more, here is the very detailed description of RedHat Package Manager (RPM):
    LVL 15

    Expert Comment

    As to why you had to deal with them - pine was removed from Fedora Core as of FC3 or so. Typically when you install a package you just do

    yum install <something>

    and yum solves all dependencies for you (i.e., if pine WAS in fc4, "yum install pine" would have taken care of installing all three RPMs). Because yum repositories don't have pine, you had to do some extra manual work in figuring out what needs to be installed to get your pine running.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
    The purpose of this article is to demonstrate how we can use conditional statements using Python.
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now