[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Windows 2000 pro workstations cannot see SBS 2003

Posted on 2006-04-16
9
Medium Priority
?
240 Views
Last Modified: 2010-04-19
I just setup, or tried to, an SBS 2003 server in a new environment. They were previously using a novell network accessing a DOS box. There were/are several Windows 2000 pro workstations in place. I joined them to the domain, which was successful, rebooted the machines, and appear to login to the domain.

I try to drill the network neighborhood and it shows the domain, but not the server. I know the server is accessible, because I can get to it from brand new XP installations on the same network and map drives.

I can ping the server through both IP and name from the command line.

What is keeping me from seeing the server in the network neighborhood tree under the domain?

Thannks
0
Comment
Question by:thefunnydad
  • 4
  • 4
8 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16466445
That's probably because you didn't follow the correct procedure to join the workstations to the domain.  You need to use SBS's method of http://<servername>/connectcomputer.  I often find that when people don't use this method they have also not used the Add-Computer wizard, and instead just added workstations to Active Directory manually -- usually in the wrong OU.

SBS has a default configuration for Active Directory and DNS that should not be modified or messed with unless you are very sure of what the consequences would be for doing so.

At this point, you need to do the following:

The following needs to be done with the client machine:
1.  Log in with THAT machine's LOCAL administrator account.
2.  Unjoin the domain into a WORKGROUP
3.  Change the name of the computer (this is REQUIRED)
4.  Delete or rename the following directory C:\Program Files\Microsoft Windows Small Business Server\Clients
5.  Ensure that the network settings are configured to "Obtain an IP address automatically"  - DHCP Enabled
6.  Reboot

Then on the server, from the Server Management Console:
1.  Remove the client computers if it still shows in the Client Computer screen on the Server Management Console
2.  Add the client with it's NEW name using the Add Computer wizard

Then, go back to the client machine and join the domain by opening Internet Explorer and navigating to http://servername/connectcomputer

You may want to review http://sbsurl.com/itpro for an overview of why these things matter with SBS.

Jeff
TechSoEasy
0
 

Author Comment

by:thefunnydad
ID: 16470385
Followed these instructions to the letter,  adds the computer to the domain. I can login to the computer using a domain login, Internet works, I can ping the server from the command line.

I try to either drill the network from an explorer view, or go to Tools Map Network drive and it says no domain controller available. XP machines are working fine.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16470457
Please post an IPCONFIG /ALL from both your server and the workstation.

Jeff
TechSoEasy
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:thefunnydad
ID: 16470539
SERVER:

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ZEUS
   Primary Dns Suffix  . . . . . . . : lmcarpetone.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lmcarpetone.local
                                       wp.comcast.net

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection #
2
   Physical Address. . . . . . . . . : 00-13-72-F6-03-EC
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.16.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : 192.168.16.2

Ethernet adapter Network Connection:

   Connection-specific DNS Suffix  . : wp.comcast.net
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-13-72-F6-03-EB
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IP Address. . . . . . . . . . . . : 10.1.10.174
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.1.10.1
   DHCP Server . . . . . . . . . . . : 10.1.10.1
   DNS Servers . . . . . . . . . . . : 192.168.16.2
   NetBIOS over Tcpip. . . . . . . . : Disabled
   Lease Obtained. . . . . . . . . . : Monday, April 17, 2006 9:39:37 AM
   Lease Expires . . . . . . . . . . : Monday, April 24, 2006 9:39:37 AM

C:\Documents and Settings\Administrator>


WORKSTATION:

Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\>ipconfig /all

Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : RentonA
        Primary DNS Suffix  . . . . . . . : lmcarpetone.local
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : lmcarpetone.local

Ethernet adapter Local Area Connection 5:

        Connection-specific DNS Suffix  . : lmcarpetone.local
        Description . . . . . . . . . . . : Linksys Wireless-G USB Network Adapt
er #3
        Physical Address. . . . . . . . . : 00-12-17-67-92-D1
        DHCP Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.16.14
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.16.2
        DHCP Server . . . . . . . . . . . : 192.168.16.2
        DNS Servers . . . . . . . . . . . : 192.168.16.2
        Primary WINS Server . . . . . . . : 192.168.16.2
        Lease Obtained. . . . . . . . . . : Monday, April 17, 2006 12:26:16 PM
        Lease Expires . . . . . . . . . . : Tuesday, April 25, 2006 12:26:16 PM

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Cable Disconnected
        Description . . . . . . . . . . . : Realtek RTL8139(A)-based PCI Fast Et
hernet Adapter
        Physical Address. . . . . . . . . : 00-0C-76-A4-20-57

C:\>



Thanks!
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 2000 total points
ID: 16470609
You should NOT have DHCP enabled on your external NIC.  You can manually configure that which will stop the wp.comcast.net from getting passed down to your server.  You don't want that to happen.

After changing that, rerun the CEICW (Configure Email and Internet Connection Wizard).

Also, disable or remove the extra NIC on the workstation.

Jeff
TechSoEasy
0
 

Author Comment

by:thefunnydad
ID: 16470747
Ok, so I need to disable DHCP on the external NIC, which is the one tied into wp.comcast.net.

I have tried disabling the other NIC cards on these W2K boxes, but that isn't making any difference. Is the whole mess related to the external NIC on the server or no?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16471072
Yes, it is... but generally you can't use the connectcomputer wizard when you have two NICs on a workstation... so I wonder how you got by that.

Jeff
TechSoEasy
0
 

Author Comment

by:thefunnydad
ID: 16471365
Dumb luck I imagine. I went into the properties of the 2nd NIC card on the server saw the DHCP enabled on the 2nd tab, selected it but did not get an option to remove it, the buttons remained disabled.

I had made a mistake in thinking the red X below those other adapters indicated disabled, they obviously do not. After manually disabling them, I am getting the workstations online now one by one.

0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The SBS 2011 release date (RTM) is supposed to be around Christmas, 2011.  This article is a compilation of my notes -- things I have learned first hand.  The items are in a rather random order, but I think this list covers most of what is new and d…
If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month17 days, 22 hours left to enroll

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question