?
Solved

PHPMYADMIN -- only works when in \wwwroot directory.

Posted on 2006-04-17
13
Medium Priority
?
1,025 Views
Last Modified: 2010-05-18
Alright, I have phpmyadmin 2.8.0.3 on a Server 2k3 machine with IIS installed.
The weird thing is... when I have the phpmyadmin files in the \wwwroot\phpmyadmin directory, it gives me a weird error.
Error ~ pa
th to languages is invalid ./lang/

HOWEVER when I have the phpmyadmin files in the \wwwroot\ directory, phpmyadmin works just fine.

Help me out here?
Answer will be accepted once phpmyadmin works for me in its directory.
0
Comment
Question by:Zlord1
13 Comments
 
LVL 9

Expert Comment

by:Rob_Jeffrey
ID: 16469771
I have the same setup with my server and have PHPMyAdmin working fine in a different directory.
Have you modified the $cfg['PmaAbsoluteUri'] in config.inc.php?
0
 

Author Comment

by:Zlord1
ID: 16469795
O.o
Huh?
Where is the config.inc.php? in the c:\php directory?
0
 
LVL 9

Expert Comment

by:Rob_Jeffrey
ID: 16469818
config.inc.php is in the root of the PHPMyAdmin folder.  It holds the settings for PHPMyAdmin.
You will have to edit this file to change the settings for your server such as the MySQL Server's name, the user anme and password, etc.
Hope this helps.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:Zlord1
ID: 16469832
Rob,

in the phpmyadmin\config.inc.php file I found no $cfg['PmaAbsolouteUri'], so I would assume that I didn't set it.
0
 
LVL 9

Expert Comment

by:Rob_Jeffrey
ID: 16469852
Okay.. let me look into the setting for version 2.8.0.3  I have 2.6.3.pl1

...
0
 
LVL 9

Accepted Solution

by:
Rob_Jeffrey earned 1000 total points
ID: 16470202
That was interesting.  I had a heck of a time installing the new version.
It comes with a neat little script that will allow you to choose your options like server name and such but it just would not work for me at all.

The default configuration file is located in the {phpadmin}/libraries/config.default.php
I copied this file to the base phpmyadmin folder {phpadmin} and changed the name to config.inc.php and made my changes directly.
I didn't have to set the $cfg['PmaAbsolouteUri'] variable this time around - all I had to change was the MySQL username and password - it works fine.
0
 
LVL 12

Expert Comment

by:str_kani
ID: 16470203
for me, it sounds like an incomplete download/foldeer. make sure you have all the files...

it may be there around line number 39,

$cfg['PmaAbsoluteUri'] = '';

0
 
LVL 29

Expert Comment

by:fibo
ID: 16470379
< < Error ~ path to languages is invalid ./lang/ >>
So it says it could not access the lang subdir which is under the phpmyadmin dir.
1 - chech that this subdir is indeed present in  \wwwroot\phpmyadmin\
2 - check which are the access rigths to this foldre, and that they are readable by all users

Any comment?
0
 

Author Comment

by:Zlord1
ID: 16471877
Flbo -- I'm going to set read rights to "everyone". See if that helps, even though I'm logged on as administrator.

Also, the \lang\ sub is indeed in the \wwwroot\phpmyadmin directory
0
 

Author Comment

by:Zlord1
ID: 16471915
New information
~~~~~~~~~

Upon giving the "everyone" group rights in the phpmyadmin sub, it began "working" kind of.

Once I logon to the phpmyadmin interface, it redirects to http://localhost/index.php?

Why is it redirecting to the root of localhost?
0
 
LVL 9

Expert Comment

by:Rob_Jeffrey
ID: 16471952
Just to let you know - being logged on as administrator won't matter since the web server is running under a different user, which may have different permissions.

(You just found this out - I was typing while you were writting the above)

Now you should look into using the other ptions in the config file such as the $cfg['PmaAbsoluteUri'] setting.

Do a quick search through it for the text 'localhost' to see if you can replace it with the proper .com name.
0
 

Author Comment

by:Zlord1
ID: 16472228
Alright Rob, I didn't use the $cfg['PmaAbsoluteUri'] setting, but I followed another piece of your advice.

By copying the config.default.php file from the /libraries/ directory and replacing config.inc.php with it I got everything working.

Thanks for all of your help in this matter!

~Ryan
0
 
LVL 9

Expert Comment

by:Rob_Jeffrey
ID: 16472254
No problem.
I had a heck of a time too, but it does seem better than the old version I was using.
Thanks for the points.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

3 proven steps to speed up Magento powered sites. The article focus is on optimizing time to first byte (TTFB), full page caching and configuring server for optimal performance.
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
The viewer will learn how to create a basic form using some HTML5 and PHP for later processing. Set up your basic HTML file. Open your form tag and set the method and action attributes.: (CODE) Set up your first few inputs one for the name and …
Suggested Courses
Course of the Month13 days, 10 hours left to enroll

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question