Asterisk --Record Incoming Calls

First things first:

Running Asterisk 2.8
SipuraSPA 3000

I’m trying to get inbound calls to record automatically. In AMP/ FreePBX, I set my wireless extension (EXT 204) to Automatically record all Inbound and Outbound calls. Well.. All outbound calls are recorded, but inbound calls are ignored, unless I do a *1 to manually activate recording.  

I can call To /from any “internal” extension, including the wireless, and inbound recording works perfectly.  So… Something’s messing up inbound recording when a call comes in from the outside world.   The only place I see this configured is in sip_additional.conf.  Here are the snippets that manage the SPA3000 and my Wireless extension.  Yeah, for testing purposes, I’ve set them all to ‘always’.  

[99]
username=99
type=friend
secret=1234
record_out=Always
record_in=Always
qualify=no
port=5062
nat=never
mailbox=99@device
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=no
callerid=PSTN <99>


[199]
username=199
type=friend
secret=1234
record_out=Always
record_in=Always
qualify=no
port=5061
nat=never
mailbox=199@device
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=no
callerid=PSTN <199>


[204]
username=204
type=friend
secret=1234
record_out=Always
record_in=Always
qualify=yes
port=5060
nat=yes
mailbox=204@device
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=no
callerid=Wireless <204>


[pstn]
username=asterisk
type=peer
secret=1234
port=5061
insecure=very
host=192.168.1.102
fromuser=asterisk
dtmfmode=rfc2833
context=from-internal
auth=md5

Everything looks pretty normal here, so why is Asterisk failing to automatically activate recording for calls coming from the outside world?  Something needs to be added somewhere, but where?

Would really appreciated the insight,

D.
dholingwAsked:
Who is Participating?
 
grbladesCommented:
I am nor familiar with that way of recording calls. Are you running asterisk@home?
There is no asterisk 2.8. version 1.2.7.1 is the latest.

Have a look at http://www.voip-info.org/wiki/view/MixMonitor
I would normally incorporate this into the dialplan.
Note though that the bug has only just been fixed so you will need the latest version of asterisk if you wish to use it.
0
 
dholingwAuthor Commented:
Yes, after many hours of searching, I finally ran into that and found a way to make it work quite nicely.  Yes, the @home settings still appear to have some problems with inbound calls, although the problem seems isolated to those coming from the outside world.  I suspect something is being skipped, but who knows…

Also created a little script to convert the wav files to MP3 each morning at 3:00 AM, then nuke the .wav files.  Although I did eventually solve the problem, I did ask for help and you did provide an excellent solution, so the points are yours.  

Yes, I’m running 1.2.6, but still find it confusing, as this is asterisk@home 2.8-beta.  So… Officially, FreePbx 2.8-beta, running on top of Asterisk 1.2.6.  Heh… I’ll try to refer to the official Asterisk version in future cases :)  


Many thanks Grblades,

Dave
0
 
grbladesCommented:
I imaging at 3am you wont have any calls so the extra cpu load by converting the files wont be an issue. However I would advise that you use the 'nice' command to lower the priority of the program you run to convert the files to mp3 format.
0
 
dholingwAuthor Commented:
You’re 100% right, but because it’s a dedicated box, and pretty steamy at that, plus it’s only my small handful of calls, I didn’t use it this time.  On any other host, I most certainly would though.  

Thanks again,

Dave  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.