• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 257
  • Last Modified:

Read-Only problem on D: drive!

So I am getting seriously frustrated with this read-only attribute on my server!

All of the folders are marked (with a grey-check mark) as read-only...all of the individual files are not read-only...and from what I read, it isn't "really read-only" or something stuid like that....however, some of my software will not work when the network folder is marked as read-only.  I tried Microsofts thing on adding the registry value to the Windows Explorer key...however, that didn't seem to work.

Can anyone help ASAP?  I need to get every sub-folder of D:\data to not be marked as read-only! (how hard can that be?!)
0
rustyrpage
Asked:
rustyrpage
  • 4
  • 3
  • 2
2 Solutions
 
NJComputerNetworksCommented:
Well, you could right click on your D:\ in windows explorer (on the serveR), click the security tab and allow the users or groups that you want to have CHANGE access.

or you could right click a subfolder name

i.e.

d:\data  <-- right click here and choose properties from the drop down box.  Click the security tab...add the security group that you want to give change access to...then click the advanced button...  and uncheck the INHERIT PERMISSIONS check box...

0
 
TheCleanerCommented:
It really isn't "read only", like has been said...

See here for full explanation:  http://support.microsoft.com/?id=326549

                        Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and
                        accessories, and other programs.

                        Note that some programs may not operate correctly with folders that have the System attribute set. To remove both the Read-only and System
                        attributes from the C:\Test folder, use the following command:

                                                        attrib -r -s c:\test


So for you, if you really have to change it, use the above attrib command on d:\data with the /D parameter as well, so that it processes all subfolders.
0
 
rustyrpageAuthor Commented:
As I said, I have several programs that CANNOT have the folder marked as read-only.  I know that it isn't really "Read only", however, half of my programs will not work under a folder with those properties.  I have read & tried everything in that article & it isn't working...I don't know what is going on here, but it is really killing me!

I have tried to do the attrib -r -s D:\data /d /s, it runs, but then everything is still marked Read Only...what is going on?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
rustyrpageAuthor Commented:
Okay, so, I feel stupid...I didn't realize that Microsoft changed the default share permission to read-only...and that was my problem
0
 
NJComputerNetworksCommented:
lol...  good that you got the problem solved....
0
 
rustyrpageAuthor Commented:
I feel stupid though!   I will split the points between you two since both of you were going the right direction with it.
0
 
TheCleanerCommented:
heh...good deal...
0
 
rustyrpageAuthor Commented:
The biggest deal is that someone actually answered the question in a timely fashion.
0
 
TheCleanerCommented:
We aim to please. :)
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now