• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 251
  • Last Modified:

Drop down menu is hidden by flash paper

I have a website with a drop down menu that gets hidden behind a flahpaper object when you try to navigate using the menu items. I've tried messing with the z-index but nothing seems to make the flash paper object go behind the drop down menu. Does anyone have any information on how to fix this, or have discovered a way to fix this problem?

You can see what I mean here: http://mldevel.com/2.1.1.php
0
jmar_click
Asked:
jmar_click
  • 2
  • 2
1 Solution
 
dbrittCommented:
The solution you are looking for is called an "IFRAME shim". Basically you place an IFRAME above the windowed object (e.g. - flash objects, select objects, etc) and then put the other thing you want to float above that and voila! You can't use the Z-index to put it above a windowed object, but IFRAMES can go above them and then you can use the Z-index to get above the IFRAME. A little weird, yes, but it works.

Here's where I've answered someone else with an example, enjoy!
     http://www.experts-exchange.com/Web/Web_Languages/JavaScript/Q_21616699.html
0
 
jmar_clickAuthor Commented:
I think I might have worder my question wrong. Its not a drop down compbo box that i'm having trouble with. Its a drop down HTML menu, (see website link to see what I mean). The problem is that when they hover over the menu and the drop down boxes come up, they show up underneath the flahs paper object, so they can't select any of the options under the flash paper.

I don't want to hide or unhide the flahs papger object if theres a solution that will not require me to hide it.
0
 
dbrittCommented:
I saw the situation when I viewed the link. It doesn't matter what object you're trying to put above it, you still need to use the shim. It uses an invisible IFRAME, so you don't lose visibility of the flash object (except of course the part that the menu covers). Give it a try.
0
 
marcparilloCommented:
I've experienced a similar problem before with Flash and HTML drop-down menus.   Along with setting the z-index, also try setting your flash content to "wmode=transparent."  That's worked for me in the past.  I've added the appropriate lines to your flash <object> and <embed> code below.  Hope that helps! -marc

      <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"   width="100%" height="100%">
  <param name="movie" value="FlashPaper/brochureRedlands.swf" />
  <param name="wmode" value="transparent" />
  <param name="quality" value="high" />
  <param name="width" value="100%" />
  <param name="height" value="100%" />
  <embed src="FlashPaper/brochureRedlands.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"  wmode="transparent" width="100%" height="100%"></embed>
</object>
0
 
jmar_clickAuthor Commented:
dbritt and marcparillo, thank you for your suggestions. I've been away for a while and dont have access to my computer so I can't implement your solutions until I get back.

marcparilo - i've tried setting the wmode to transparent before and it didn't work. But maybe I did something wrong and i'll try again with the code you supplied.

Thanks,
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now