Apache won't stop

Hi I recently installed Apache 1.3.34. The installation worked fine. When I type
hhtp://localhost it also shows me the default web page. But when i try to shutdown Apache using the folowing command
Apache -k shutdown it gives me the following message
Cannot read apache PID file c:/program files/apache group/apache/logs/httpd.pid

Would anyone know why it is giving this message and how can I shutdown Apache.

I also tried using ctrl C but if I go to the http://localhost, it still goes to the defualt page

Thanks
royalcyberAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

m1tk4Commented:
Does it shut down correctly when you stop the Apache service in Control Panel / Admin Tools / Services?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
royalcyberAuthor Commented:
yes it stopped the server now. but why it is not stopping it when I use the command
Apache -k shutdown

Thanks
0
m1tk4Commented:
try starting it again and see if this .pid file is created where it is looking for it (i.e. /program files/apache... etc.)
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

royalcyberAuthor Commented:
it gives the same message

it tries to read the file in the following directory

c:/program files/apache group/apache/logs/httpd.pid

0
m1tk4Commented:
Is the file there?
0
WelkinMazeCommented:
Hi,
Maybe because the apache is run as service the access to the httpd.pid file is blocked and it cannot be stopped this way. As far as I know this file holds the process id of the parent process.
0
NopiusCommented:
Try to edit httpd.conf file and to setup another directory for apache pid file (without spaces):
PidFile c:/httpd.pid

Also you may try to stop apache in CLI by using 'net stop':
net stop apache


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.