[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2126
  • Last Modified:

Configure Exchange 2003 to include POP3 mailbox access

Hi,

We are using Microsoft Exchange 2003 (part of SBS 2003) and mail is working fine when connecting from Outlook to the Exchange server.

We would like to ALSO be able to access mailboxes using a POP3 client. We do not want to stop our current mode of connecting just add the option to use POP3. This had been setup for us originally but has stopped working. Nobody is aware of anything having changed.

I've tried to Telnet in to port 110 and get the greeting but then told that the protocol is not supported when I enter the user.

Can someone step me through what I need to configure POP3 on Exchange? I am not an Exchange admin (although I used to manage Exchange 5.5 for a few years in the late 90s) so will need detailed steps please (not just a URL to somewhere else).

Thanks.
0
Kitsune
Asked:
Kitsune
  • 13
  • 11
1 Solution
 
Irwin SantosComputer Integration SpecialistCommented:
It's probably your POP3 protocol stop.

Go to the Exchange System Manager, then expand Administrative Groups till you get to PROTOCOLS, locate POP3, make sure that it is ON.  Just right click and select START
0
 
KitsuneAuthor Commented:
Hi irwinpks,

Under Exchange System Manager, I don't see Administrative Groups. I have the following...

Global Settings
Recipients
Servers
Connectors
Tools
Folders


This difference may be due to Small Business Server.
0
 
Irwin SantosComputer Integration SpecialistCommented:
SERVERS - (your SERVERNAME) - PROTOCOLS - POP3
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
KitsuneAuthor Commented:
Also, I just double-checked that the Microsoft Exchange POP3 service is running and not disabled. This is the one required, as far as I know.

There is another service - a POP3 connector service which is disabled, but this is for pulling mail FROM external POP3 mail servers and placing them into an Exchange mailbox. This is not what we want and I don't believe we require this service to be running.
0
 
KitsuneAuthor Commented:
> SERVERS - (your SERVERNAME) - PROTOCOLS - POP3

Got it. OK. This is already started (running).
0
 
KitsuneAuthor Commented:
I've just reread my last post and realised that my comment "Got it. OK." could be misunderstood. I have not fixed the problem. I was simply referring to irwinpks more detailed steps of finding the POP3 protocol section within Exchange System Manager.
0
 
Irwin SantosComputer Integration SpecialistCommented:
I think I'm missing information....

You currently have Outlook and are using the Exchange Configuration when you have create a new mail account on the client... correct?

Now you want to add a Pop3 mail account to the same client to access the mail on the same Exchange Server?
0
 
KitsuneAuthor Commented:
No. Not add a POP3 mail account. Merely access the existing mailbox (mail account) using a POP3 client. Webmail works fine but some of our staff require POP3 also.

The mail accounts do not want to delete the mail from the server and there is an option to leave the mail on the Exchange server I am sure (but can't recall where). They can then work their way through their numerous email offline when they are in areas with bad connectivity.

This setup (created before I joined the company by outside consultants) has been working fine up until recently. The server has not been restarted and the services appear to be running. Just seems that POP3 is not working. By going through the logical steps of what is required to setup POP3 for the existing Exchange mailboxes, I am not only able to fix the problem, but better support Exchange in future should something like this happen again.
0
 
KitsuneAuthor Commented:
When I Telnet to the Exchange server I get the following:

+OK Microsoft Exchange Server 2003 POP3 server version 6.5.6944.0 (AcmeServer.AcmeDomain.local) ready.

I've replaced the specifics of the server name and domain but you get the idea.

But when I try to login...

user john.doe
-ERR Protocol error.

or if I use the AD domain account
user johndoe
-ERR Clear text passwords have been disabled for this protocol.

Does this help?
0
 
Irwin SantosComputer Integration SpecialistCommented:
Ok...

If working before and nothing has changed, let alone be restarted, then let's look at the SERVICES in the Control Panel. did any MS Exchange service NOT start?
0
 
Irwin SantosComputer Integration SpecialistCommented:
make sure the EXCHANGE FEATURES TAB in AD for the user is configured for POP3 service.
0
 
KitsuneAuthor Commented:
There are five services for Microsoft Exchange started and some that are not (by choice). Before posting I had checked the three Exchange related tabs for several of the AD accounts to make sure that POP3 was configured correctly. POP3 is definitely enabled for those accounts and I would have been surprised otherwise as these were working before and have suddenly stopped.


I am beginning to suspect the culprit may be Computer Associates eTrust - an anti-virus, anti-spam server software. A very unfriendly and unhelpful package, it appears to be blocking things but is not giving me enough information (such as specific port access) or help in rectifying it. So I can't tell if it is blocking POP3 requests.
0
 
Irwin SantosComputer Integration SpecialistCommented:
any chance of turning that service off temporarily to test and see if that is the trouble?
0
 
KitsuneAuthor Commented:
I'm trying that now. :)
0
 
Irwin SantosComputer Integration SpecialistCommented:
ok.. i'm going to turn in for the evening.
0
 
KitsuneAuthor Commented:
I couldn't turn off the CA eTrust as it is stopping quite a lot of viruses and spam that is attempting to get in and we are dealing with production servers. Also, on closer inspection, the CA eTrust is only blocking things on port 80 (HTTP) and port 25 (SMTP). What we are dealing with is using port 110 which is ignored by CA eTrust.

This can be verified by using a Telnet session to access the Exchange server.

Also, I turned on the option which allows clear text passwords so I can test further with Telnet internally. Interestingly, I am getting an error authenticating even though I know what my username and password are. My guess is that the username may need to be in a particular format but I have tried several and am not getting though.

Any suggestions?

The Telnet session currently goes as follows:

+OK Microsoft Exchange Server 2003 POP3 server version 6.5.6944.0 (AcmeServer.AcmeDomain.local) ready.
user john.doe
-ERR Protocol error.
user john.doe
+OK
pass johnspassword
-ERR Logon failure: unknown user name or bad password.


I find it strange that I am seeing an ERR Protocol error on my first command but after that it behaves normally. I am testing just with my own user account for now and it definitely has POP3 enabled in Active Directory. If I can connect with Telnet then it should be no trouble getting things to work in Outlook for the other staff.
0
 
Irwin SantosComputer Integration SpecialistCommented:
\domain\john.doe

try that.
0
 
KitsuneAuthor Commented:
No. It gives an error if I try

user \domain\john.doe
-ERR Protocol error.

but without the leading backslash

user domain\john.doe
+OK
pass johnspassword
-ERR Logon failure: unknown user name or bad password.
0
 
Irwin SantosComputer Integration SpecialistCommented:
http://support.microsoft.com/kb/165186/en-us

password is case sensitive?
0
 
KitsuneAuthor Commented:
The password is being entered in the correct case. Also the problem is occurring for all our staff accounts. So it is not a password typo either. I feel very confident that the password is OK but am not so sure about the format of the user. Also, that initial ERR Protocol doesn't sit well with me. What is that and how do I get more information about it in order to fix it?
0
 
KitsuneAuthor Commented:
irwinpks,

I got in! That article you referred me to mention something I hadn't tried and that was using BOTH the domain account and the mailbox together with the domain. Sure enough it let me in. I will verify that this works with the real staff needing this overseas before closing this question and awarding you the points.
0
 
Irwin SantosComputer Integration SpecialistCommented:
cool!
0
 
KitsuneAuthor Commented:
As a further note to anybody who reads this question in the future, our issue was found to be authenticating with clear text works but authenticating with SPA doesn't. At some point SPA has stopped working but for now, by allowing clear text authentication our remote staff are able to login and get their mail.

The domain/domain_account/mailbox through telnet works fine which is why I awarded the points to that particular comment from irwinpks, as well as all of the help in arriving at a solution. Being able to test the connection from telnet is very handy. Thanks irwinpks for all your assistance.
0
 
Irwin SantosComputer Integration SpecialistCommented:
you're wlecome...thanks for the supplemental followup.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 13
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now