RWW ALMOST GOT IT

Okay

I'm getting closer with this RWW and Email thing.

I have installed my exchange server and I am able to connect to OWA via http://FQDN/exchange, it comes up with a prompt and bang I'm into OWA.

Now.

When I login into Remote web work Place, besides it coming up with a gazillion different logins, I'm having the most problems when I'm trying to access OWA from RWW. Once signed into RWW, there is an option that asks me if i want to open up OWA. After waiting for a little bit it comes up with " Page Cannot be displayed"

Any ideas?

FYI!
I did have problems with Remote Web Work Place in IIS before. under IIS>Web Sites>Default Web Site, I did not have a virutal directory called "REMOTE". I had to manually add the Virtual directory in there. Once I did this I was able to access  Remote Web Work Place. Maybe I'm missing other Virtual Directories that didn't get installed.

Anyway, don't know if that helps or not
dakeysAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
The fact that you manually created the Remote directory is the problem.  I'd suggest that you reinstall IIS again according to this KB:  http://support.microsoft.com/kb/887305

You do not want to have to manually reconfigure all the correct permissions, etc.

Jeff
TechSoEasy

0
dakeysAuthor Commented:
cool, I re-installed IIS according to the intructions and eveything seems to be working fine except the following:

When I sign onto remote web workplace I click on "Use Outlook Web Access", it just says loading.......
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Can you access OWA via http://servername/exchange locally?

Jeff
TechSoEasy
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

dakeysAuthor Commented:
I could log in locally and access the OWA through  http://servername/exchange,
I took it a step further and went to http://servername/remote, I signed on to RWW and then
clicked on Outlook web access, it came up with a OWA login screen, (I guess this is what I should be seeing when I trying this remotely.


Currently I could access OWA remotely if I access it directly (http://FQDN/Exchange)

Not sure if this matters or not, but my server name is different from my FQDN....
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
it makes no difference what your servername is.  Does this problem happen from ANY location you are trying to connect from?  Or just one?

Jeff
TechSoEasy
0
dakeysAuthor Commented:
I just tried it from my house and its says loading again. Only this time it didn't stay there for thaaaaat long, after about 15 seconds it went to "Action Cancelled" at the bottom of page there was an "error on page" that would flip between "DONE" and "Error on Page". I double clicked on it and I got the following error from Internet Explorer:



Error: Permission Denied
URL:http://FQDN/Remote/header.aspx

0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
dakeys,

You're going to need to follow the troubleshooting steps listed in this KB:  http://support.microsoft.com/kb/280823

Or review this KB to see if it applies:  http://support.microsoft.com/kb/910119

Jeff
TechSoEasy
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
One question... when you ran the Configure Email and Internet Connection Wizard, did you select OWA as being available?  If you aren't sure, you can rerun the wizard.

Jeff
TechSoEasy
0
dakeysAuthor Commented:
When I ran the Configure E-Mail and Internet Connection Wizard I did include OWA, either way, I could sign onto OWA, just not through RWW.

I'll take a look at the KB articles:

thanks
0
dakeysAuthor Commented:
My main problem now is not the "LOADING" this is not nearly taking as long as it was yesterday, After just a couple of seconds I get the "permission denied" error.

There has to be something with the permission rights on the "Remote" virtual directory in "IIS". Like I said above when I sign onto RWW remotely and click on OWA it comes up with that error saying that I don't have permission to Header.aspx, which is inside the remote virutal directory in IIS.

0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Yes, there must be... and if you follow the TROUBLESHOOTING link I provided above, you'll find out what it is.

Jeff
TechSoEasy
0
dakeysAuthor Commented:
about the troubleshooting guides that you mentioned above:

the 1st one is titled "Troubleshooting OWA when the contents frame displays "Loading"

My problem isn't when I access OWA through http://FQDN/exchange, this way I am able to login and I don't get anything that says Loading.

My problem is only through RWW. It goes into loading for a couple seconds then gives me the permission denied error. It continues to get stuck in "Header.aspx" which is in the "REMOTE" Virtual Directory in IIS.

Here are my "Remote" Property settings in IIS:

1st Tab=Virtual Directory
 Local Path: C:\Inetpub\Remote (I verified and this is their)
(here is what is checked On) Read, Write, Log Visits, Index this Resource

App Settings

App Name: Remote
Exec Perm:Scripts and Executables
App Pool: DefaultAppPool

3rd Tab: (Directory Security)

Auth and Access Control -->Edit -->Enable Anonymous is checked
Right below that is says "Auth Access"

1st box =Integrated Windwos Auth is checked
3rd box= Basic Auth is checked

def domain = domainname

back to main tab of (Directory Security)
IP address and domain name restrictions -->Edit -->Granted Access is chosen

back to main tab of (Directory security)
Secure Communications -->Edit -->only 1 thing chosen and that Ignore client Certificates

Either way I did read the whole 1st guide and everything I have in the ExchWeb properties is according to the article

The second guide is when you have a Front and backend. I have it all on a single server.

I read anyway and it doesn't seem to apply to my situation
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Okay, how about this one: http://support.microsoft.com/kb/327843

This would have been easy to find if you had entered "OWA 401 error troubleshooting" in the search box on the Microsoft.com KB site page that was linked.

Jeff
TechSoEasy
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
There's this one as well:  http://www.cgnet.com/Exchange/owa_ts.htm
0
dakeysAuthor Commented:
Thanks I will try tomorrow and let you know how it went.

just for thought though:

At the bottom of my page after I login to RWW and i click on Outlook web access, it says http://FQDN/Remote/Header.aspx and after a couple of minutes it give me the permission denied error.

Wouldn't my problem be in the Remote Virtual directory in IIS?

Or is there a setting in System Manager that control any portion of RWW?

Or does it need a special certificate to access it?

sorry if i'm asking to many questions, but I'm trying to give you as much information as possible

0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
No problem with the questions... and it does give a clue... the fact that you are accessing RWW with http and not https provides the clue.

Please try using https://FQDN/Remote and see if that solves your problem.  If it does, then you have manually altered the directory security settings of Remote or Exchange at some point.

All of this is usually configured with the Configure Email and Internet Connection Wizard, where you create your SSL certificate and designate which services will be active.

Additional configuration beyond that is not usually necessary.

You may have to, at this point, remove all local certificates from your server and make sure that they are removed from any remote machine you have used, and then rerun the CEICW again to re-configure.

Jeff
TechSoEasy
0
dakeysAuthor Commented:
Removed the certificate and re-ran the CEICW, It's weird though because when I run it, there is a part in the wizard that it asks whether or not to

Deny all users from access this web site
allow only the following web sites to be viewed (This is the option that has RWW,OWA,OMA etc....)
Allow all

If I just either the 2 or 3rd one, it asks me to enter in a certificate name or browse for a CA. The last option is to leave the web certificate the way it is, but this is greyed out b/c I dont have a Web Certificate.

the only way around this is if I choose the services that I want like (RWW and OWA) and then choose the deny option.
This seems to get it installed, but the only problem is OWA doesn't show up inside of RWW onthe left side where it normally says (Additional Links)......

How can I add this link back there.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
If you choose DENY, even if you've selected the services you want, they still won't work.  You are not understanding something very basic about this wizard..... you are RIGHT that you don't have a web certificate... which is why you need to use the FIRST area of the Server Certificate screen that says, "Create a new web server certificate"!

So when it asks for the name, PUT ONE IN THERE!  Use the FQDN that you are using to have users connect remotely, ie, server.companyname.com.

See http://sbsurl.com/ceicw for an example

Jeff
TechSoEasy

0
dakeysAuthor Commented:
Okay I have done all the above and it is still coming up with the loading for about 10-15sec and then give me the permission denied error.

at the same location:

 http://FQDN/Remote/Header.aspx

I have located the headers.aspx file and compared the security rights on it to other files in the same directory. They all look equal.

Do you have the default settings that are supposed to be on this remote folder?
Is the problem on the Remote virutal directory or on the Exchweb directory?
If I remove the Virtual directory such as Exchweb, Exchange and add them back
would that help?
Remember I could login locally on site and access this, its only remotely that I cannot.



0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Are you STILL using http instead of https???

Jeff
TechSoEasy
0
dakeysAuthor Commented:
Yes I'm still using the Http:, b/c I haven't purchased a SSL certificate.

I removed the require encryption so I know thats not the problem.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You don't need to purchase an SSL certificate!!  When you run the CEICW it will generate a self signed certificate!  You can't just remove the requirement for encryption.

How about trying it my way and see if that works...

RERUN the CEICW.  On the Certificate Screen, put your FQDN and finish it out.  See http://sbsurl.com/ceicw for an example.

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dakeysAuthor Commented:
Okay I will do that,

do i have to do anything in the certificate authority?
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
no
0
dakeysAuthor Commented:
Finally worked. I was able to remote into my client and check e-mail thanks alot
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Congrats!  I hope the lesson learned was to "read the manual"   :-)  

Jeff
TechSoEasy
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.