ora-01031 insufficient privilges

I took a cold backup  of a 9.2 instance from one server and untarred it onto a second.  When I try to log into sqlplus as sysdba, i get ora-01031 insufficient privileges.  The directory stucture is identical on the two servers.  I've tried orapwd with the same results. How do i get to log in to sqlplus as sysdba?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ivo StoykovCommented:
Hello xoxomos,

Did you restore password file as well?


xoxomosAuthor Commented:
Yes, it was in two .tar files.  One .tar contained software, the other data.
What OS is this on?

Check the permissions on the files, check the owner is correct.  

here is a link to point you to some possible solutions:

Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

when untar, use parameter -p to extract all protection information on files.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
xoxomosAuthor Commented:
It is on Solaris.  I just noticed, on the new server the owner and group for all the software is oracle/ oinstall.  On the old one it is oracle/dba.  Could that make a difference?
Absolutely.  Either remove and untar again as radjaZ suggested with thie -p option, or you can the group for all files recursively.

 $ chgrp -fR dba .

The command above changed the group for all files '.' recursively, with the force option.

Also, make sure that dba is defined as a group at the OS level and that oracle is in the dba group by default (not oinstall).
xoxomosAuthor Commented:
Just tried to chgrp -fR to make  the software oracle/dba.  Oracle is in the dba group, but i'm still getting the same error.
Did you do the command from above the ORACLE_HOME level?  And be sure to use the DOT '.' after the -fR.
xoxomosAuthor Commented:
I did it at the ORACLE_HOME level.
What happens when you do the following:

$ sqlplus /nolog

Are you getting an error message then or do you get into sqlplus?
To connect as sysdba, you have to be part of the dba group.  Are you getting the error message when you connect as sysdba in the oracle account?  If so, please have your system administrators change the default group of oracle to dba instead of oinstall (you need to do this anyway if you haven't already).  If you are getting the error as some other user, then they need to be added to the dba group.  

If these are not your issue, then it is probably to do with the tar process.  Did you shutdown the database, stop all processes including listener before getting the tar on the original system?  Make sure to extract the tar using the -p option.  Completely remove and re-extract using the -p option so that you get the files with the same permissions and group that they had when they were added to the tar.

Try these things and if none of them work.  I suggest that you actually install the Oracle binaries from installation CD.  Then clone the database itself (and move any apps as appropriate) from the source system.  

There are many options.  I tend to lean toward a clean installation of Oracle on new boxes.  You have more control on the whole environment and can be sure it is done properly.  It is up to you how much time you spend trying to get the tar move of Oracle binaries to work.  The suggestions above may be all you need.  But again, if not, then  I would recommend you do a clean install and then move the database and/or apps to the new server.
xoxomosAuthor Commented:
The command completed successfully
-bash-3.00$ $ORACLE_HOME/bin/sqlplus /NOLOG

SQL*Plus: Release - Production on Tue Apr 18 09:59:14 2006

Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.

SQL> connect sys /as sysdba
Enter password:
ORA-01031: insufficient privileges

xoxomosAuthor Commented:
I'm actually trying to upgrade from 9.2 to 10.2.  I did a clean install of the 10.2 server software only.  I'm trying to untar a backup of our 9.2 install in order to run the dbua  to upgrade that 9.2 to 10.2.
I suggest that you install the 10.2 on the server that has the 9.2 and upgrade it.  Then you move the database/app to the new server.  If you are trying to do the upgrade on another server and leave your original alone until complete or tested.  Then install 9.2, move database/app to new server, and upgrade there.  Please note that the database upgrade assistant will only work if there is absolutely no issue with your database.  You can certainly try it, but Oracle told us after trying to use that this little tidbit of information....  In which case a more traditional upgrade will be required.
xoxomosAuthor Commented:
Yes, that is the smart way, but there is a space issue on the 9.2 server, about 80GB is just wasted space.  May have to resort to import.
xoxomosAuthor Commented:
Well this turned out to be the way /someotherdir and /u01 was set up.  Oversight essentially.
I did get around that problem by vi'ing a sqlnet.ora file and putting 'NONE' in some authentication parameter.  At least i get in and startup the database, but sysdba had to have the correct password.
xoxomosAuthor Commented:
Now dbua requires running netca first.
my netca -silent command line returns a command for me to set DISPLAY?????
Network configuration Assistant is a GUI tool, so you need enter *nix box with XServer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.