Opta2000 and SQL Server named instances

I'm setting up a webserver connection to a SQL Server 2000 named instance. Normally we set this up without using named instances, just having one instance installed. Using this setup, everything always worked without a problem. Now we have to set this up at a company that only uses named instances. For some reason, we cannot make a connection to the database. We get the error:

java.net.UnknownHostException: <servername>

The connection string is:

String conn_STRING = "jdbc:inetdae7:<servername>/<named_instance>?database=test";

I've tried several things, like using backslashes between servername and instance name, and using a port number or IP-address.

<servername>\\<named_instance>
<servername>/<named_instance>:1433

We're using Opta2000.jar as jdbc-driver. This is not the latest driver. Any ideas what I could do or try?
LVL 1
grexxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fargoCommented:
make a ping to the hostname or the ip address to see if it is reachable
0
grexxAuthor Commented:
I've made a connection to the database using a udl-test-connection. The connection works. A ping works as well.
0
fargoCommented:
according to this..your syntax is correct
http://www.cc-group.de/products/jdbc/mssql/manual.asp#Syntax

may be it's a driver issue. May be you should get the latest driver and try.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
grexxAuthor Commented:
I've installed JTDS, and that seems to work. We have to test it a bit more, but it seems to do everything we need. And it's free!
0
grexxAuthor Commented:
I mailed to the support desk of Opta2000, and they mailed me a new version of the driver. I didn't use it in the end because I already solved it using jTDS, but I suppose that would have worked as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
JSP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.