Can't change system drive letter back to C:

Posted on 2006-04-18
Last Modified: 2008-01-09
In order to replace the main hard disk in our server, I transferred the content of my C: drive on our server to a mirrored partition on another drive and then broke the mirror.  Windows automatically assigned the mirrored partition the drive letter D:.  I removed the original C: drive and jumpered the replacement drive as the master and rebooted.  Since then, I've had nothing but trouble.  I finally got it to let me log in by using little registry tweaks across the network.  I've tried going into the "mounted devices" section of the registry and renamed the key from \DosDevices\D: to \DosDevices\C: several times, but the change doesn't survive a reboot.  I close regedit and re-open it and the change is still there.  I reboot the computer and it has changed it back to D:.  I'm running out of possibilities short of reinstallation, which I'm trying to avoid.  HELP!
Question by:hawthornedirect
    LVL 12

    Accepted Solution

    The MountedDevices registry key is the right place to change it according to this article, but it also mentions permissions:

    Note that the drive you use to break the mirror, changes drive letter. So if you right-click Disk0 (mirrored with Disk1) and break the mirror, then Disk1 keeps the drive letter assignments, and Disk0's letters are changed. If you right-click Disk1 and break the mirror then Disk0 keeps the drive letters.

    Or use Remove Mirror if uncertain; removing Disk0 removes all partitions while keeping Disk1 intact.

    Author Comment

    I wish it were that easy.  I've tried this before and, maddeningly, every time the system is rebooted it changes the mounted device \DosDevices\C: back to \DosDevices\D: again.
    LVL 12

    Expert Comment

    What happens if you try this in Safe mode?

    I've already succeeded in demolishing a VMware setup using the DosDevice method. It remembers the drive letters all right.
    LVL 21

    Assisted Solution

    Do what you already did with changing the DosDevices key

    Then open regedt32 navigate to the MountedDevices folder and RC, select permissions.  Check all the users that are listed and make the security read only (Specifically Administrators and SYSTEM).  This should prevent Windows from changing it back on a restart.

    Author Comment

    I have been setting the permissions back to read-only for all the listed users (administrators and creator owner) after renaming the DosDevice to C:.  I tried making the change in safe mode.  It still changes the key back to \DosDevices\D: after a restart.

    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Join & Write a Comment

    I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
    ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now