SMTP Inbound Timout Exchange 2003 - Small Business Server

Config is:

SBS2003, single nic, behind a LINKSYS BEFSR41 V4 router doing PPoE to Qwest DSL.  The linksys is behind a Cisco 678 in bridge mode.

Some email is not being received by my SBS2003 server.  It is from a few specific domains that I've identified so far.  Mac.com.  hotmail.com.  msn.com.   Not all the hotmail/msn is timing out, only from certain servers.  All of the mac.com is timing out.  

My server doesn't spit back an NDR of any kind, but eventually the sending server reports back to the sender that it can't deliver, a 4.4.7 code similar to:

Action: failed
Status: 4.4.7
Remote-MTA: DNS; mail.domain.org
Diagnostic-Code: SMTP; 451 4.4.1 reply: read error from mail.domain.org.

I've searched extensively via google for topics like this and have found several, but none with a consistent solution.  I've tried many of them already, including:

- Changing MTU settings from 1492 to 1400.
- Changing NIC from auto-detect to 100 MBps Full Duplex.
- Updating firmware on LINKSYS router
- Changing timeout on SMTP virt to 5 mins from 10.

SMTPSVC log snippet:

2006-04-18 16:05:08 64.147.173.68 outbound3.groundspring.org SMTPSVC1 SERVER 192.168.1.20 0 EHLO - +outbound3.groundspring.org 250 0 222 31 0 SMTP - - - -
2006-04-18 16:05:08 64.147.173.68 outbound3.groundspring.org SMTPSVC1 SERVER 192.168.1.20 0 MAIL - +FROM:<owner.86441.72106395.109380936107483811-user1_domain.org@en.groundspring.org> 250 0 119 117 0 SMTP - - - -
2006-04-18 16:05:08 64.147.173.68 outbound3.groundspring.org SMTPSVC1 SERVER 192.168.1.20 0 RCPT - +TO:<user1@domain.org> 250 0 47 44 0 SMTP - - - -
2006-04-18 16:06:14 17.250.248.181 smtpout.mac.com SMTPSVC1 SERVER 192.168.1.20 0 EHLO - +smtpout.mac.com 250 0 223 20 0 SMTP - - - -
2006-04-18 16:06:14 17.250.248.181 smtpout.mac.com SMTPSVC1 SERVER 192.168.1.20 0 MAIL - +From:<> 250 0 27 22 0 SMTP - - - -
2006-04-18 16:06:14 17.250.248.181 smtpout.mac.com SMTPSVC1 SERVER 192.168.1.20 0 RCPT - +To:<MailTest@domain.org> 250 0 43 40 0 SMTP - - - -
2006-04-18 16:09:34 64.147.173.68 outbound3.groundspring.org SMTPSVC1 SERVER 192.168.1.20 0 TIMEOUT - outbound3.groundspring.org 121 1152226112 84 4 266109 SMTP - - - -
2006-04-18 16:09:34 64.147.173.68 outbound3.groundspring.org SMTPSVC1 SERVER 192.168.1.20 0 QUIT - outbound3.groundspring.org 240 266250 84 4 266125 SMTP - - - -
2006-04-18 16:11:04 17.250.248.181 smtpout.mac.com SMTPSVC1 SERVER 192.168.1.20 0 TIMEOUT - smtpout.mac.com 121 3052993041 84 4 290438 SMTP - - - -
2006-04-18 16:11:04 17.250.248.181 smtpout.mac.com SMTPSVC1 SERVER 192.168.1.20 0 QUIT - smtpout.mac.com 240 290610 84 4 290438 SMTP - - - -

The existing DSL connection is slated to be replaced with a fractional T1 at the end of April so I'm not eager to start replacing lots of hardware.   I'm contemplating adding a secondary MX entry on a 2K server that I control to act as a relay.

Any ideas of how to solve the problem as it exists?
LVL 1
nummagumma2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
What have you got scanning the SMTP traffic?
Antivirus, antispam? Those are the common reasons for delivery failure.

Simon.
0
nummagumma2Author Commented:
SAV for MS Exchange.  SAV 10 on the server.  GFI Mail Essentials.

With every one of those services off the problem still happens.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

mcsa_2003Commented:
Hi,

please make sure port 25 open
and do you have ISA?anty spam protector?


Regards

0
SembeeCommented:
Disabling the product doesn't help if they are causing the problem. Due to the way that these products integrate in to the server, the only way to ensure they aren't interfering is to remove them.

Simon.
0
mcsa_2003Commented:
Hi,
Also, test your domain here:
www.dnsreport.com 
+
Do a netstat on the server and see if it is in fact listening on port 25 or break out port query:

http://support.microsoft.com/default.aspx?kbid=310298 

Regards





0
nummagumma2Author Commented:
Replacing the linksys router with a new one (the one I replaced had been in service 2 months) solved the problem.
0
nummagumma2Author Commented:
mcsa2003, your comments didn't appear to apply since the vast majority of mail was flowing just fine.
0
GranModCommented:
Closed, 500 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.