Cannot get link on Cisco 3650 with Gigabit Copper SFP's

We are using copprt SFP's, they *should* be 10/100/1000. No matter what we try to connect to one of these four SFP ports, we do not get link. I have tried mutliple devices, each with multiple cables and multiple speed and duplex settings, and the port stays in a "notconnect" state.

Our goal is to use this switch as the core, and uplink four cheap Dell PowerConnect switches to these Gigabit ports.

Cisco 3650, running 12.2(25).

and yes, we shut/no shu the port every time we re-attempt/reconnect

We also recieve max CPU errors when we plug in the SFP's when the switch is online, if we REMOVE an SFP while the switch is humming along, the switch crashes.

Thanks in advance,

pdx-3560# sh port interface GIgabitEthernet 0/1
Port Security              : Disabled
Port Status                : Secure-down
Violation Mode             : Shutdown
Aging Time                 : 0 mins
Aging Type                 : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses      : 1
Total MAC Addresses        : 0
Configured MAC Addresses   : 0
Sticky MAC Addresses       : 0
Last Source Address:Vlan   : 0000.0000.0000:0
Security Violation Count   : 0

GigabitEthernet0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 0016.c898.5e81 (bia 0016.c898.5e81)
  Description: Dell Switch 1
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
shaaadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rvthostCommented:
I had a similar issue.  What is that switchport mode set to on that SFP Gig port?  If not already, set to:

switchport mode dynamic desirable

Otherwise, are there any other customizations you have done?
0
shaaadAuthor Commented:
No luck. No, nothing else custom on the switch or port, but have tried many different configs.  I'm thinking it's hardware at this point, I'm not sure
how i can further troubleshoot this hunch.
0
rvthostCommented:
Buy another ;-)  

I assume from your original posting that you tried that SFP in a different GB port to rule out a physical port problem?  The only reason why I initially had a problem was because of the mode access setting on the 3560 and also the port setting on the switch that I was linking up to.  Once I matched those to dynamic, I got my link lights.  Sorry I can't be of more help, but good luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.