To log on.. you must have Terminal Server User Access

I am trying to set-up Terminal Services on a windows 2003 Server and am getting the following error:

To log on to this remote computer, you must have Terminal Server User Access permissions on this computer........


I am attempting to logon as Administrator, which is in the Remote Access User Group and the Permissions odf the terminal Services configuration.  From the Component Services I get this error:

The terminal server could not locate a license server. Confirm that all license servers on the network are registered in WINS/DNS, accepting network requests, and the Terminal Server Licensing Service is running.

I have installed a license server on the same machine.  I have not purchased any licenses but should still be able to log on for 120 days according to everything I've read.  Before giving any more money to MS, I was thinking about just rolling back to 2000.  Any comments or suggestions on doing this would also be appreciated.

Thanks
pjsulinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
are you using the W2k3 trial software?
0
Jay_Jay70Commented:
Hi pjsulin,

this also depends on if you installed remote or application server mode?

Cheers!
0
Netman66Commented:
Exactly.  By default Terminal Server is already running on 2003.  It's in Administrative mode by default.  You simply need to check the box on the Remote tab in Properties of My Computer to allow Remote Desktop.  By default, Administrators are the only one's that can connect this way.

If you setup TS in App mode, then remove it and go with the method above if all you want to do is Administer it remotely.

0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

pjsulinAuthor Commented:
No, as it turns out, since I have a MSDN subscription, that I have to call India in order to activate the License Server.  Real convenient.  Thanks for the support MS.
0
Netman66Commented:
That's correct.  You need to contact MS Clearing House if you are going to use this Terminal Server for running Applications.  There is no need to involve MS if you are only going to Admin the server.  You have 2 connection allowed to the server using TS for Admin purposes - no extra cost (it's included).

0
pjsulinAuthor Commented:
"By default Terminal Server is already running on 2003."

 Actually Terminal Server was not automatically installed.  I had to manually install it.

I don't think I have a choice of what mode I'm running it in either.  I'm running 2003 R2 Standard Edition and when I go to windows components and highlight Terminal Server I am unable to see the details, which I believe is where I am able to change the mode, nor was I given a choice when I installed.

So why would i not be able to select which mode I'm running in?  I'm assuming I'm in Application mode, which is a dumb name since it implies that I cannot run applications from administration mode which is completely false, and that in 120 days I'm going to be asked for CAL licensing.  

So I need to change modes but cannot do it through add/remove components?!?



0
Netman66Commented:
When you installed TS like you did, you installed it in Application mode.  You don't need this to admin the box.

You cannot run Applications from Admin mode - you can certainly run them when you are logged in because you are pretty much running the console.  This is not what is meant by TS in App mode.  

Remove Terminal Services the same way you installed it but uncheck the box.

When you reboot, go into Properties of My Computer, Remote tab and check the box for allow Remote Desktop - that's all you need to do.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.