USR 5641 MaxG router and MySQL 3306: Cannot forward port ...

I have a USR 5641 MaxG router and am trying to run some services behind it.
Currently, I have successfully opened 80,21,25,110,3389
Next I want to open MySQL port (3306) too, so I have put that in the router (TCP and UDP).
This doesn't work at all ...

Now next thing needs to be said too --> When I am forwarding my ports internally, I cannot connect from internal addresses to the webserver that is running internally.  For that I need to use a proxy server, so it is resolved by the proxy.

I also think that the problem lays somewhere in between the fact that I cannot reach my webserver internally and the fact that I guess that 3306 is not the only port that needs to be opened for MySQL

Someone advice ?
APEMAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
Got the right model #??

Here is port forwards link to common ports on your USR..but you have 5641...not 5461?
http://www.portforward.com/english/routers/port_forwarding/USRobotics/USR5461/USR5461index.htm

"I cannot connect from internal addresses to the webserver that is running internally."
You need to have DNS running what machine does that?
0
APEMAuthor Commented:
You are correct, it is 5461.  Sorry about that.

No, I do not have DNS running cause it is a WiFi router.  

More info:

Router: 10.16.2.1
Linux WebServer: 10.16.2.100
Laptop: 10.16.2.50

Currently port 80,21,25,110 and 3306 are forwarded to 10.16.2.100 (linux webserver)

Port 3306 is also configured to be forwarded to 10.16.2.100 (linux webserver) but that doesn't work.
0
Irwin SantosComputer Integration SpecialistCommented:
so you don't have DNS running but do you have a FQDN for your webserver?

if so, is port forward setup to point to that Linux box?

You need to setup HTTP request (this is the most IMPORTANT, confirm that this is running before you do any other port forwarding)
http://www.portforward.com/english/routers/port_forwarding/USRobotics/USR5461/HTTP.htm
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

APEMAuthor Commented:
Webserver is running through dynamic DNS service (dyndns.org) seen that I have a dynamic IP.

Port forward is setup to point to 10.16.2.100 (LINUX) so yes it is setup.

HTTP request is setup.
0
Irwin SantosComputer Integration SpecialistCommented:
what happens when you type in the URL of the webserver?
Can you provide that link or is it private?
0
APEMAuthor Commented:
From INTERNAL it gives the admin page of the router.  When I put on the proxy, it gives the webserver.
From EXTERNAL it gives the webserver.

0
Irwin SantosComputer Integration SpecialistCommented:
@APEM, please help me clarify what you want to do.

You DON'T want the proxy?  Is that correct?
0
APEMAuthor Commented:
No, what I want is to be able to make use of the MySQL Server on my webserver.
I guess there should be a problem with one of those two things:

1)  The port is not properly forwarded or 3306 is not the only port that needs to be forwarded
2)  Seen that I can not reach my webserver from internal without use of my ISP's proxy, I guess my webserver is not able to resolve the mysqlserver name ...
0
Irwin SantosComputer Integration SpecialistCommented:
0
APEMAuthor Commented:
I did that, yes.
0
Irwin SantosComputer Integration SpecialistCommented:
what happens if you refer to your mysqlserver as

http://www.yourwebserver.com:3306
??
0
APEMAuthor Commented:
(3.23.58XU]Sj<-hG, ÿBad handshake
0
Irwin SantosComputer Integration SpecialistCommented:
ok.. that is something.

Record your settings in your router.. download the latest firmware update for the USR.. re-enter the settings, then attempt the URL to 3306

I't 2:52am.. in Hawaii, and I'm turning in for the night.. shout out when you're done and I'll check my email 6-8 hours from now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
APEMAuthor Commented:
Problem is solved.  User in MySQL for localhost was wrong ...

But thanks to irwinpks for answering and you didn't give me the correct answer, but I'm still going to reward you for answering me :)

Thanks m8
0
Irwin SantosComputer Integration SpecialistCommented:
cool. thank you for the effort points!! :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.