Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

USB Pen Drive two partitions, one showing as cd-rom drive.

Posted on 2006-04-19
8
Medium Priority
?
8,830 Views
Last Modified: 2008-10-22
Hello there,

I've been given a 128MB pen drive that already had some files on it, I don't really want these files and would like to delete them, but there is a problem!

The pen drive appears to have two partitions, the first one containing the files appears in Windows as a cd-rom drive, and as such can't delete the files.

In Windows XP I can get the following properties: (G: being the CD-rom partition)
CBM1180A Flash Disk USB Device (G:)
CBM1180A Flash Disk UCB Device
-------Generic Volume (H:)
Properties of G: DVD/CD-Rom Drives (Standard CD-Rom Drives)

In Windows 98 I get the following:
USB CD-ROM
---CBM1180A Flash Disk F:
USB Disk
---CBM1180A Flash Disk G:

Is there any way I can delete this CD-Rom partition, and merge into one partition that I can use?
0
Comment
Question by:bealem
8 Comments
 
LVL 4

Expert Comment

by:RiceyRice
ID: 16490753
This sounds like an interestingly unique situation...
Do you have the make/model of the drive, or at least the manufacturer?

Have you tried any partition manager software like Partition Magic (or there is a good list of free apps here, Swissknife has been good to me)

http://www.thefreecountry.com/utilities/partitioneditors.shtml

Theoretically, you should be able to delete both and create one all-encompassing partition for your use. Take us through what you have tried so far.
0
 

Author Comment

by:bealem
ID: 16495763
Hi,

Yes, certainly an interesting one, and I wonder how it was done on the pen drive in the first place.

I don't know the make or model or manufaturer of the drive, all I can tell you it's small, silver with a green flashing LED.
I have since found out that it was picked up at a conference, and the files on it are related to it, marketing material I guess!

I've tried a few different partition managers last night, Paragon Partition Manager, Partition Magic, and a couple of older ones I found that work on Win98, PTS DiskEditor and one called beeblebrox!
But they all fail to see the cd-rom partition.  Also a lot of the partition managers work before Windows has loaded, so do not see the USB device at all!

I've just given Swissknife a go and it shows two USB Host Adapters for the pen drive, here is the info:
Selected Drive: USB Host Adapter 1 (CBM1180A Flash Disk)
Size(MB): -Not Applicable-
Drives: G:
Number of Partitions: -Not applicable-
Volume: MYCD_VOL(G:)
File System: CDFS
Media Type: CD ReadOnly

Selected Drive: USB Host Adapter 2 (CBM1180A Flash Disk)
Size(KB): 0
Drives: H:
Number of Partitions: 1
Volume: USB_KEY(H:)
File System: FAT 32
Media Type: Removeable

The first is the cd-rom partition, but it won't let me change anything, just says "Permission Denied..." in the "Partition and Quick Format" view


I think this is more out of curiosity than anything else now!
0
 
LVL 4

Expert Comment

by:RiceyRice
ID: 16496275
http://www.experts-exchange.com/Storage/Q_21727554.html

I wonder if you happened upon one of these very drives. If so, that uninstaller may just do the trick. If not, true to life this may be one of those bang your head against the wall of the mentality of overzealous manufacturers (which happens from time to time, most often resulting in nothing more than a headache for you!)

How much of the drive is off limits (of the 128)? I guess the bigger issue here is not wanting to leave whatever drivers this virtual CD drive on every PC you plug into. Who knows what trouble lurks around the corner with those things.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:bealem
ID: 16497717
Thanks for finding that other EE thread for me, but unfortunately the utility on there didn't work, I guess it's not a U3 drive, says "No U3 smart drive was found"

I have now found that it installs a bit of software that is run from the registry everytime the PC boots, and sits there waiting till you plug in the USB drive.

It's called WinDrives.exe and I have found (by using Sysinternals Process Explorer) that this is called "ChipsBank AutoRun Server 2005-03-10" but not having a great deal of luck find anything about this, apart from the chipsbank website does have to do with the CBM1180A controller.

It's about half of the 128MB that is used, thats what is more annoying than anything else I think!!
0
 
LVL 4

Accepted Solution

by:
RiceyRice earned 2000 total points
ID: 16499765
See if the program mentioned here will see the partitions for what they are...

http://www.everythingusb.com/forums/showthread.php?s=6a49edfbb83149eb2cef6f3c6f1d8fcd&threadid=5442&perpage=30&pagenumber=4


Out of curiosity, what company's load of rubbish is taking up the Read-Only section?
0
 
LVL 2

Expert Comment

by:adi_vladut
ID: 16532905
I have a fingerprint usb flash drive that "does" the same thing.
On the CD partition (arround 4 MB) there are some firmware files for dealing with the fingerprint and passwords.
Your flash may use some pasword protection software to protect the data on the other partition even if the software is not activated.
0
 

Author Comment

by:bealem
ID: 16584688
Hi,

Sorry for the late reply, been away for a bit.

A few of us have had a go in the office here, trying different things, but I'm thinking it's not really worth bothering with now!

It's only Local Government documents on it, not to get too excited about!

Cheers
Mike
0
 

Expert Comment

by:msabbir
ID: 22780415
I bought a 4GB Transcend USB pen drive.It was working properly. But now it shows as CD drive and the size is 2048 GB(??) in my PC, Dell Laptop and in my ACER Travelmate. Even i can not formate or open it. It shows that its write protected.....  Please let me know if you have any solution. Do not write to through it away.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When we purchase storage, we typically are advertised storage of 500GB, 1TB, 2TB and so on. However, when you actually install it into your computer, your 500GB HDD will actually show up as 465GB. Why? It has to do with the way people and computers…
Article by: evilrix
Looking for a way to avoid searching through large data sets for data that doesn't exist? A Bloom Filter might be what you need. This data structure is a probabilistic filter that allows you to avoid unnecessary searches when you know the data defin…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month20 days, 23 hours left to enroll

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question