Solaris W/S with Blank screen and no boot.

Posted on 2006-04-19
Last Modified: 2013-12-27
Dear Friends,

I have a problem at work and need help immediately.  I normally don't deal with Solarismachine, but now, I am ask to check out.  One of my Solaris W/S, the monitor screens went blank.  It does not reboot nor does it come to the OK prompt.  The screen is blank, the screen light is constantly blinking, CDROM light is constantly blinking and the system does not boot from the disk.

Diagnostic steps tried:

I took healthy disk from one other workstation and put it to the faulty workstation.  It didn’t give any results and problem still persisted.

In order to check the integrity of the hard disk of the faulty machine, I put the hard disc from the faulty machine and put it to other healthy machine. The disk is physically seen but gives the following errors:

Unable to repair the / filesystem.
Run fsck manually (fsck –F ufs /dev/rdisk/c0t0d0s0)

When I run the suggested command, it gave a couple of errors like:
Cannot read: BLK 23303072
The following sectors could not be read:

While Control-D pressed, it gave the following:
Mount: the state of /dev/dsk/c0t0d0s0 is not okay
And some other INIT errors.

Attempted different good monitors connected to the faulty W/S – no result.

Removed hard drive from faulty W/S and inserted known good hard drive into the faulty workstation – no boot, similar result.

Assumption is that that the BIOS might have some sort of problem, but that is my guess. What is the next step to repair this computer?  Please help.

Question by:samaddu
    LVL 29

    Expert Comment


    You posted in the Windows 98 TA when you should have posted here:

    Will ask for this question to be moved to the correct TA.

    LVL 14

    Expert Comment

    You may have gone forward too many steps.

    If you are not getting the ok prompt, it doesn't matter if the disk is bad or not, since the ok prompt comes from the obp on the mother board.

    Not getting an ok prompt can be caused by many things, and most of them are broken hardware.  

    Check the graphics adapter making sure it is properly seated.  Make sure that all other connections are properly seated.

    Are you sure that the box didn't boot?  If the graphics adapter is bad, the machine may still boot up and you may be able to get to it through the network via telnet or ssh.

    When you put the disk in another box, the first thing to to is run the format command (not to actually format the disk, but to determine the layout) in the format after you have sellected the proper disk, type par (partition) then pr (print) this will show you the disk layout.  

    It is very possible that you cannot fix the root (/) partition because it is not on slice 0 some folks put swap on 0 or use some other non-standard layout.

    If you post the model of the Sun box, we may be able to give you more trouble shooting tricks...

    LVL 38

    Accepted Solution

    You harddisk is faulty, and you box might have other problem as well.

    Find a monitor you know if works and plug it in the Sun box, and make
    sure that keyboard & mouse are plug in as well.

    power on the box, then type in: (need to do it fast!)

    <Stop> N
    to reset your NVRAM

    to see if you can get to the OBP (ok prompt).

    If not, you might have prolrm with the NVRAM chip or mainboard, or memory. open the box,  resit the memory chips and make sure all
    the cable are connect properly and try again.

    If you have the same model of the box, you can try to replace the NVRAM
    chip to see if it can help.

    Have a look at the hareware manual for your box in:

    to see how to replace the part, if you are not sure what to do, get some one with experience to do it for you. (or contact Sun).

    Author Comment

    Thank youi guys for the help.  Your suggestion lead me to the solution.  problem resolved.  RAM was the culprit.  Thnak you.

    LVL 14

    Expert Comment

    yuzh's answer is mostly correct, but I would not write off the hard drive until you preformed the test that I mentioned above.

    Featured Post

    Courses: Start Training Online With Pros, Today

    Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

    Join & Write a Comment

    Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap ( Version 1.2 2.      Jpcap( Version 0.6 Prerequisite: 1.      GCC …
    Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now