When I try to ftp a file from a windows machine to linux server, I get a critical transfer error.

I have successfully established communications (FTP and telnet/ssh)  between a windows workstation and two Linux mail servers.  The current mail server and the new mail server.  On the original mail server, I have tarred the mail folders.  I have then ftp it to the windows machine.  When I try to ftp the file (or any file) from the windows machine to the new mail server, I get a critical transfer error.  

I am unable to make an ftp connection to the new mail server as root, but as a user I can.

For a lot of reasons, I need to be able to go from Linux to Windows to Linux.

I am using Windows 2000.  The new mail server is running CentOs.

Your help is always appreciated.
CME-ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

m1tk4Commented:
>> I am unable to make an ftp connection to the new mail server as root, but as a user I can.

This is normal, root FTP logins are disabled by default.

Try passive FTP connections (PASV).
0
CME-ITAuthor Commented:
"How do I do that?" asked the newbie :(
0
CME-ITAuthor Commented:
I tried something different.  Originally, I wanted to put the file in /   That did not work.  What is working is to put the file in the /home/user directory and then change the permissions chmod .  At this time I can mv it to / so that I can untar it.

Is this what I am going to have to do, or is there a more straight forward way of doing it?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

pjedmondCommented:
Do you use ssh? Chances are that it is enabled by default on Centros

To transfer a specific file from your Centros system. At the command prompt on your windows system:

pscp.exe user@192.168.1.2:/home/user/filename.tgz .

pscp is part of the putty suite of programs for windows available from here:

http://www.chiark.greenend.org.uk/~sgtatham/putty/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjedmondCommented:
To transfer from your windows system to the linux box, from the MSDOS prompt:

pscp.exe filename.txt user@192.168.1.2:/home/user/

HTH:)
0
CME-ITAuthor Commented:
Yes I am using putty and you are correct, ssh is enabled by default on Centos.

Thank-you again.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.