• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 201
  • Last Modified:

Printers dissapeared on Windows 2003 server. HELP!

Here's the situation.  All the printers have vanished from my Windows 2003 server.
If someone is currently attached to the printer via their workstation, everything is OK, and they are able to print.
However when you go the Printers/Faxes window on the server, it is empty, and you cannot add a new printer to the workstation.
You cannot add a printer, or see print server properties on the server either.

I have restarted the Spooler service.  The service restarts fine, but the printers still are not there.
I am leary to reboot the server because I'm afraid that if I do, the people who are currently printing will no longer be able to.

There are no entries in the event log.

Any suggestions?
1 Solution
I have had that hapen to me where a re-boot brings them all back.  They are there, but not visible to the naked eye due to some odd glitsch.
achernobAuthor Commented:
Just rebooted the server.  Printers still not there.  Users are still able to print, however I am not able to access Print Server Properties or add/remove printers.

Users are still unable to map new printers.  Only users who currently have printers installed can print.
The good news is that the printers are still there.

1st, check your group policies -
Under the group policy, expand:
Computer Configuration>Administrative Templates>Printers
Make sure all entries are set to "not configured"

2nd, look for Registry Corruption:
This issue has happened sometimes because of an update, Group Policy or install gone bad.
There are registry settings that will control printers/faxes visibility, etc.  

Update and run an antivirus scan just in case.

When did this start - do you have a system backup from prior to that?
If so, restore the system state & it should be fine.

The sledgehammer approach is to reset registry defaults. - ouch.  Make sure you have a backup first.  I don't recommend it on a Domain Controller.
Here is a similar issue, and how to reset using secedit - http://www.experts-exchange.com/Operating_Systems/WinXP/Q_21773398.html

Try logging in as a different user & see if you have the same problem.

Let me know!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now