Wireless network - stop laptops from auto-connecting

Hello, I am trying to create a network wide policy to stop our laptops from auto-connecting to the wireless networks they encounter.

In windows, by default, when you connect to a new wireless network that network is placed in your "preferred network" list and is set to auto-connect when in range.

A user must then go into the configuration of this wireless network, go to advanced settings, click the properties button then the connection tab in order to remove the checkmark from "connect when this network is in range" in order to stop their laptop from auto-connecting when a network on their list is in range.

I would like to make every network on their list "On Demand". I have looked into using a GPO but there is no setting for making all or even specific networks "On Demand" using a GPO.

Any help would be appreciated.
AgrionAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

thernlundCommented:
There is a node for Wireless Network Policies in there, but you must be actually on the domain controller to see it.  It's under...

Computer Configuration/Windows Settings/Security Settings/Wireless Network (IEEE 802.11) Policies

Honestly I'm not sure this'll solve your problem because I haven't tried it.  But right off the top of my head you could try setting that policy up, then leaving the preferred networks lists blank and see what happens.


-T.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jay_Jay70Commented:
Hi Agrion,

agreed - but once a policy is enforced to use a wireless network, i am fairly certain that it locks the other networks out - specify a preffered network and make sure the tickbox under the settings in the GPO isnt ticked for auto connect to non preffered - see how you go with that

Cheers!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.