• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 448
  • Last Modified:

Red Hat 8 samba - NEEED HELP

I am trying to access some folders on my linux machine from my windows workstations.  I am running red hat 8, and I installed the newest version of Samba,  I am not sure if Samba is what I should be running.  I installed it to /usr/local/samba/bin/smbd  , I am using webmin to administor it.  I am unable to browse to the linux box and I am unsure if its because I shouldnt be using samba, if the linux firewall is blocking me or what... can someone please help me ?  I need it bad, I have been working on this for a while !
0
focusen
Asked:
focusen
  • 8
  • 6
  • 2
  • +1
1 Solution
 
focusenAuthor Commented:
Also is it possible I have samba too secure ?  how can I make it so anyone can view and edit a share.
0
 
pjedmondCommented:
On the linux box try:

smbclient -L 192.168.1.100

also try:

smbclient -L 127.0.0.1

Press return rather than entering a password, and you get a fairly good idea of what provided by the samba server.

 Example below:
-----------------8X-------------------------------------------
[pje@bigserverpje]# smbclient -L 192.168.1.100
Password:
Anonymous login successful
Domain=[MOUSE] OS=[Unix] Server=[Samba 3.0.2-6.3E]

        Sharename      Type      Comment
        ---------      ----      -------
        pje            Disk      MainBU
        software       Disk      MainBU
        IPC$           IPC       IPC Service (Samba Server)
        ADMIN$         IPC       IPC Service (Samba Server)
Anonymous login successful
Domain=[MOUSE] OS=[Unix] Server=[Samba 3.0.2-6.3E]

        Server               Comment
        ---------            -------
        BIGSERVER            Samba Server

        Workgroup            Master
        ---------            -------
        MOUSE                BIGSERVER
-----------------8X-------------------------------------------

HTH:)

0
 
pjedmondCommented:
For making the configuration for a Samba 2.x configuration, my solution here:

http://www.experts-exchange.com/Networking/Linux_Networking/Q_20440339.html

is fairly helpful.
0
Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

 
pjedmondCommented:
If you just need to get the files transferred asap, then look at this:

http://www.experts-exchange.com/Operating_Systems/Linux/Q_21819711.html

using scp to get the files over.

HTH:)
0
 
joolsCommented:
First things first...

Samba allows you to share folders (amongst other things) as if it were a windows system, if this is what you want it sounds like you've got the right software.


How did you install? Sounds like it was from source? Did the installation go OK?
If from source, why? The RPMs do a good enough job and unless you want anything specific then it would be easier to install from RPM.
Have you configured your smb.conf file properly/at all?
Does samba start? Try `service smb restart` when logged in as root.
Is your firewall running? Try `iptables -L` when logged in as root, you should get a load of rules displayed and it could be blocking samba.

Have you checked your logfiles? /var/log/messages and /var/log/samba/*

Some commands to try; (as root and ignore the quotes)

`smbclient -L //localhost` (may prompt for a password, press enter)
`testparm` (checks your smb.conf file)

Can you post a little more information, logfiles will help, what you've already tried (commands/webmin stuff) will also help.

J
0
 
focusenAuthor Commented:
Well I could not find the RPMs for samba, so I only found the source.  Shoot me a link to an rpm and I would be happy to try it.   But I just need to share out folders and I dont want it to prompt my users for un or pw and I want them to be able to browse. also I dont have smb I have smbd ... I am confused.. thanks so much everyone.. I need the help big time
0
 
focusenAuthor Commented:
[global]
      log file = /var/log/samba/%m.log
      smb passwd file = /etc/samba/smbpasswd
      load printers = no
      passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
      socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
      force group = admin
      domain master = yes
      null passwords = yes
      passwd program = /usr/bin/passwd %u
      wins support = true
      available = yes
      dns proxy = no
      netbios name = data0
      browseable = yes
      server string = File Sharing Server
      default = global
      workgroup = workgroup
      force user = admin
      os level = 20
      printcap name = /etc/printcap
      security = user

[GB]
      path = /usr/share/samba/GB
      writable = yes
      browseable = yes
      allow hosts = 10.1.1. 88.
      available = yes
      mangle case = yes
      public = yes
      guest only = yes

[General]
      browseable = yes
      writeable = yes
      mangle case = yes
      path = /usr/share/samba/General
      guest only = yes
      public = yes
      available = yes

[Mgt]
      path = /usr/share/samba/Mgt
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes

[Programs]
      path = /usr/share/samba/programs
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes

[Users]
      path = /usr/share/samba/Users
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes

[TNote]
      path = /usr/share/samba/TNote
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes

[backuplogs]
      path = /var/log/backuplogs
      writable = no
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes

[images]
      browseable = yes
      writeable = yes
      mangle case = yes
      path = /mnt/120gb/images
      force group = admin
      force user = admin
      guest only = yes
      public = yes
      available = yes

[Music]
      path = /mnt/120gb/Music
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes
      force user = admin
      force group = admin

[NoBackUp]
      path = /mnt/120gb/NoBackUp
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes
      force user = admin
      force group = admin

[SSShare]
      path = /usr/share/samba/SSSshare
      writable = yes
      browseable = yes
      allow hosts = 10.1.1.0
      available = yes
      mangle case = yes
      public = yes
      guest only = yes
        force user = admin
        force group = admin


[Roger]
      valid users = John
      writeable = yes
      guest only = no
      public = yes
      path = /home
      write list = Paul

Here is my .conf file.. I just want everyone to be able to access shares and browse to the server without being prompted with a pw
0
 
focusenAuthor Commented:
Any one ???
0
 
focusenAuthor Commented:
etc/init.d/smb  -  I do not have this file in this location wiht the new version of samab
0
 
focusenAuthor Commented:
PLEASE HELP !  
0
 
focusenAuthor Commented:
How do create a share that everyone can brose to .. wihtout prompting for a pw
0
 
joolsCommented:
rpmfind.net should give out the links for RH8, or it's on the CD is you have it available.

You may need to add the users in the smbpasswd file, check out smbpasswd and create userid's for users you want to have access, useradd is easy to use but if you want webmin will also do the trick.

I have this entry in my smb.conf file which gives everyone access, there are a lot of comments in the smb.conf file which are easy to understand, I'm not sure if webmin kills the comments though.

[tmp]
   comment = Temporary file space
   path = /tmp
   read only = no
   public = yes

I'm signing off now, back in a few hours, you may have made some more progress by then.

Cheers

Jules
0
 
pjedmondCommented:
Redhat RPM updates:

ftp://ftp.bylinux.net/pub/mirror/fedoralegacy/redhat/8.0/updates/i386/

Obviously check versions....but at least it should help you with getting things working.
0
 
pjedmondCommented:
A few little pointers that will help you make more sense of the above:

1.    Samba consists of NMB and SMB (it actually starts up 2 daemons).

2.    Traditionally, linux daemon processes (ones that provide a service and run in the background) have a binary that ends in a d (for daemon). The samba daemon is smbd. Services often have a client. If you wanted to connect to a share, then you could use smbclient. Together both form part of the samba package. Using the RPMS you need to install the samba-client package in order to install the samba-server as it requires certain common library files.

3.   smbclient -L //localhost         (as I detailed above will show you if your samba server is working)!

4.   If you install from the RPM, your life will be a lot easier, because all your files will be in a standard location, and it will be easier for people here to help you. Use the links provided to get appropriate RPMs, or install them from your installation CD.

HTH:)
0
 
pjedmondCommented:
Sorry - my mistake - you need to install samba-common first, and then the samba package (this one contains the server elements) and client packages. the client can be installed without the server.

Sorry for the mistake!

HTH:)
0
 
ircpamanagerCommented:
is this RH box on a domain or is it just two boxes(RH* and Windows). Is your workgroup really called "workgroup". Could you post your /etc/hosts file. Windows will have a hard time seeing RH8 if the hostname is not correct in /etc/hosts. Post back your results.
0
 
focusenAuthor Commented:
Re wrote the samba.conf and it worked!
0
 
ircpamanagerCommented:
thats great
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 6
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now