Setting umask for one directory

Hi!

I have set up Samba server to provide two shares for each Win clients:
1. The home directory of whoever is logged in
2. A common public directory that is visible for everybody

Everything works fine except that I want files in the public folder to be readable, writeable, and executeable for everybody regardless of who created the file. Now, because I have the umask set to 0022, files in the public folder is readable for everybody, but writeable only to its creator. Howvere, I wish not to change systemwide umask.

Is there a way to set an umask different from the system umask specially for our public folder only?
PappPAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunnycoderCommented:
Hi PappP,

> Is there a way to set an umask different from the system umask specially
> for our public folder only?
you can use setfacl


Cheers!
Sunnycoder
0
sunnycoderCommented:
setfacl -m
default:user::rwx,default:group::rwx,default:other:rwx,default:mask:rwx
<directory>

exact command copied from
http://www.sunmanagers.org/pipermail/summaries/2001-December/000547.html
0
m1tk4Commented:
In Samba, you can control this using "force group" and "create mask"/"directory mask" options.

Another way would be to do a chmod g+sw on public directory.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
m1tk4Commented:
oh, and "force create mode" (Samba)
0
PappPAuthor Commented:
Tanks for the responses!

I am really busy right now, but will try the suggestions today or tomorrow, and will award the points.

btw, setfacl is "command not found" on my system (Mandrake 10.1)

PappP
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.