Debugging a atl com dll

Hi Experts

I’ve been toying with ActiveX components in Visual studio 2005. I start with creating a ATL project and then adding and ‘ATL Simple Object’ Class and then adding a method like Test(). Debugging this method is very easy if I have created the project as an exe.

I just create a simple web page with some vbScript in it that uses CreateObject(“”) and that calls the method Test() on the object.

Press F5 in Visual Studio to start debugging and load the web page into IE. And any break points in Test() are hit.

However if I create the project as a dll, when I hit F5 to start debugging it asks me to choose a program that will call the component. I pick Internet Explorer and I get the following message:

Debugging information for ‘IEXPLORE.EXE’ cannot be found or does not match. No symbols loaded.

Can anyone tell me the best way of debugging this dll?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

You just simply IGNORE this silly error message about Internet Explorer and call up your HTML page. When the page loads the ActiveX object the dll gets accessed and Visual Studio will stop at your break point.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MattWMAuthor Commented:
Thanks for your response.

What you have said seems to be right. When I load the web page I can see activity in the status bar of Visual Studio. Something appears but it’s too fast to read. But my break point is being ignored and it has a little exclamation mark next to it saying ‘The break point will not currently be hit. No symbols loaded for this document.’ Looking around on the net, a lot of people seem to be having this problem but none of there solutions seem to work.

I am in debug mode and in project properties/linker/debugging ‘Generate Debug Info’ is set to Yes. I’ve also deleted the debug directory and re-built the project but still no luck.

Any Ideas?
I use Visual Studio 6.0 Enterprise Edition (we spend a LOT of money on that at the time) and I have not had this problem, sorry.
MattWMAuthor Commented:
Thanks for trying.
MattWMAuthor Commented:
I think this question can be Ignored, I've just tried the same process in Visual Studio Dot Net (2003) and it works fine. I’ve reinstalled 2005 on a new machine and it still doesn’t work. I think it must be a bug in Visual Studio 2005

Thanks for your input BigRat
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.