Outlook Mobile Access

I cannot get users to access theie outlook Mobile from their phone.  I've even tried testing from the web by typing 'https://SERVER/oma' it asks for username and password but then gives a page saying

' A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.'

I've double checked in Active Directory on the users and they OMA and OWA enabled.  I'm not sure if I've missed out on anything.

Please Help

Thanks

MBavisi


LVL 1
mbavisiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mbavisiAuthor Commented:
IThe System error was said on the computer whereas on the Mobiles it said Access Denied.

thnks
0
MikeeMiracleCommented:
I wonder if it's an issue with using SSL and if the browser on he phone is capable of SSL connections.  Might be worth trying it over a normal http connection.  I've not tried it with https but mine works fine over http.
0
mbavisiAuthor Commented:
When I try Http it says that The page must be viewed over a secure channel, so its definitely https.  I'm not quite sure how to take it off the secure connection.  If you could help that'll be great.

Thanks

mBAVISI
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SembeeCommented:
Browse to the OMA directory using regular Internet Explorer with friendly http error messages disabled. See what the error is.

You also need to remove the REQUIRE SSL setting on the /exchange, /oma and /Microsoft-Server-ActiveSync directory as they are incompatible. This doesn't stop you using SSL, just means that you cannot force SSL.
Easy way to force the users to use SSL is to block port 80 on the firewall.

Simon.
0
mbavisiAuthor Commented:
Hi Simon,

Thanks for the quick response.  I've managed to take off SSL.  Now when I use http I get the same error message saying

'  A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator'

On the phone it still says Access Denied.

MBavisi
0
SembeeCommented:
Check the authentication and application pool settings.

Authentication

/exchange: Integrated and Basic ONLY.
/exchweb: Anonymous ONLY.
/exadmin: Integrated ONLY.
/OMA: Basic ONLY.
/Microsoft-Server-ActiveSync: Integrated and Basic ONLY.

Application Pool:

/exchange - ExchangeApplicationPool*
/exchweb - ExchangeApplicationPool*
/exadmin - ExchangeApplicationPool*
/public  - ExchangeApplicationPool*
/oma - ExchangeMobileBrowseApplicationPool
/Exchange-Server-ActiveSync - ExchangeApplicationPool

* will probably show ExchangeApplicationPool but greyed out.

Simon.
0
mbavisiAuthor Commented:
Hello Simon,

This has been checked and is exactly how it is displayed above.

Any other suggestions?

Thanks
Adeel
0
SembeeCommented:
In ESM, Global Settings, Mobile Settings, ensure that every box is enabled.
Make sure that you are using the correct version of asp.net - 1.1 and not version 2.0 - that is checked, confirmed in IIS Manager.

Simon.
0
mbavisiAuthor Commented:
Hi Simon,

I only have three options.  Internet Message Formats, Message Delivery,  Mobile Services.  In Mobile Services it is empty.  When I click new,  Mobile Carrier it asks me for a name and smtp domain.  I don't which Smtp domain I should put in there.

0
SembeeCommented:
It should be empty.
Right click on Mobile Services in the left column and choose Properties. That will give you the options you need.
Ignore the Mobile Carrier stuff - that is for AUTD which is old technology.

Simon.
0
mbavisiAuthor Commented:
Hi Simon,

I've noticed that 'Enable Outlook Mobile Access' was not ticked so I have done that.  But I still can't access it via the weband this time the Mobile phone says Page cannot be found.  With Regards to checking the version of ASP.NET how do I check that in IIS manager.

thanks

Mbavisi
0
SembeeCommented:
On the Properties of the web site and the virtual folders is a tab "asp.net". That lists the version in use. If there is multiple versions installed then you may have a choice. Exchange uses 1.1.

Simon.
0
mbavisiAuthor Commented:
Simon,

The ASP.NET version is 1.1 and I still have the same issues.
0
SembeeCommented:
Anything in the event viewer around the time of the attempted login?

What happens when you browse tot he OMA virtual directory with Internet Explorer on your desktop with "Show Friendly HTTP Error Message" turned off?

Simon.
0
mbavisiAuthor Commented:
Simon,

Sorry I didn't turned that off.  Could you tell me how to do that.

Thanks  
0
SembeeCommented:
Internet Explorer, Tools, Internet Options, Advanced. Buried in there somewhere.

Simon
0
mbavisiAuthor Commented:
I've taken off the "Show Friendly HTTP Error Message", this time it asks for username and password but still displays the same thing after that

"A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator"

0
SembeeCommented:
Is there anything in the server's event viewer at the time you attempt that? Authentication or permission error?

Simon.
0
mbavisiAuthor Commented:
There is an error regarding MSExcahngeOMA.  Event ID is 1503

An unknown error occurred while processing the current request:
Message: Index was out of range.  Must be non-negative and less than the size of the collection.
Parameter name: startIndex
Source: mscorlib
Stack trace:
   at System.Globalization.CompareInfo.IndexOfString(Void* pSortingTable, Int32 win32LCID, String source, String value, Int32 startIndex, Int32 count, Int32 options)
   at System.Globalization.CompareInfo.IndexOf(String source, String value, Int32 startIndex)
   at Microsoft.Exchange.OMA.Preferencing.AdUserObject.get_globalWirelessEnable()
   at Microsoft.Exchange.OMA.Preferencing.AdUserObject.get_UserIsWirelesslyEnabled()
   at Microsoft.Exchange.OMA.Preferencing.OmaUserInfo.get_UserIsWirelesslyEnabled()
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
   at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
   at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
   at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
   at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

0
SembeeCommented:
I have been pointed at one possible cause to this.
It isn't a very nice fix though.

The cause is active directory corruption, specifically that the HomeMTA attribute is set incorrectly (wrong server, old server etc).

You need to use ADSIEDIT.msc to look at the user account and see whether this value is set correctly, and if not, correct.
You may want to look at another account to see how the value should be set. I have a reference server that I use for checking.

Now, you have seen the warnings for registry editing (which everyone ignores). Take those, multiple by 100 and that is how serious the warning about using adsiedit.msc is. It is the heart of the active directory and one false move can kill your AD. There is no undo -you would have to go back to the last backup of your domain.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.