• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 580
  • Last Modified:

How to allow smtp relay to one specific external address

Domino 6.5 server.  When internet email comes in for one user I need it to forward to an external email address.  I found some code that will allow me to do this and it works fine when internal Notes users send email to this user.  Howerver, I have SMTP controls turned on to prevent relaying.  External email is not being forwarded to this user.  If I add a specific external domain in the field  - Allow messages only from the following Internet addresses to be sent to the Internet - It works as expected.  

My question is, how can I tell Domino that if an external email comes in for this one user, that it's ok to relay to the users external address.
0
timbratton
Asked:
timbratton
  • 3
  • 3
  • 2
1 Solution
 
Sjef BosmanGroupware ConsultantCommented:
You don't need "code" to forward mail: just create a Rule from the user's mail database. Relaying through a rule might not trigger the relay trap. But I'm not sure...
0
 
timbrattonAuthor Commented:
This doesn't work becuase when the mail is forwarded, it is being sent from the external domain which I am not allowing to relay.
0
 
Sjef BosmanGroupware ConsultantCommented:
Don't understand... PersonA sends a mail to PersonB(at)yourdomain.com. The mail is correctly received in the mail database of PersonB. Then a rule is executed, forwarding this mail to PersonB(at)mail-isp.com. I assume that forwarded mail isn't considered to be a relayed mail?

What's the code you found, and how did you implement it? Did you try with a rule and without the code?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
brwwigginsCommented:
The forwarding rule doesn't count as relayed mail. However there is an option in the server config document to not allow "Send copy to" rules so you might want to check and make sure that they are not being blocked.
0
 
timbrattonAuthor Commented:
Yes, you understand what I am trying to do. I realize that the issue is not with my code or mail rule but with smtp.

I currently have some entries in the field  "Allow messages only from the following Internet addresses to be sent to the Internet" for a few domains that I allow to relay.  

Let's assume that I have a mail rule in Person B's mailbox that says WHEN to IS personB(at)mydomain.com THEN send full copy to PersonB(at)mail-isp.com.  Internal mail from my domain gets fowarded fine, but any message from an external domain is denied by the SMTP rule.

In my Server Configuration document, under SMTP Outbound Controls, if I leave "Allow messages only from the following Internet addresses to be sent to the Internet" and "Deny messages from the following Internet addresses to be sent to the Internet" fields blank, mail from PersonA comes into PersonB's mailbox, the rule executes and mail is forwarded to PersonB(at)mail-isp.com as expected.  This also turns my server into an open relay.

What I want to tell Domino is:  If an external email comes in for PersonB(at)mydomain.com, send that message to PersonB(at)mail-isp.com and allow the external domain to relay mail only to this email address.
0
 
brwwigginsCommented:
Relay restrictions are really enforced on inbound SMTP connections. That way you don't have to deal with the junk entering your system, you just block it from coming in. That's why you see all the blacklist and other configurations on the inbound SMTP tab. Leaving the outbound field blank will not mean you are an open relay if your inbound connections are secured.

And the rule would mimick person B sending to personb@mail-isp.com. If the person can send a notes message to personB@mail-isp.com then the forwarding rule should work. I will try to test this but I'm almost positive it would work that way
0
 
Sjef BosmanGroupware ConsultantCommented:
As brwwiggins says, there is an option you can disable/enable in the Configuraion document. See Router/SMTP, Restrictions and Controls, Delivery Controls, and look for the line with User rules mail forwarding. Is that setting Enabled?
0
 
timbrattonAuthor Commented:
Leaving the outbound field blank solved my problem.  Thanks for explaining it in a way I can understand.  The Lotus documentation and all references I have found on the web were very confusing.  
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now