PC slow as a turtle during CD/DVD ripping. Why??

Hello, I just installed 2 optical drives on my new desktop.  Both of them are DVD burners and I connected both of them on the second IDE controller on my motherboard.  One of them is set to "master" and the other as "slave" on the jumpers.
Whenever, I copy/rip CDs or DVDs, my computer seems to be running so slowly.  Even slower than my old Pentium 2 laptop!  The ripping speed from my DVD burner gets less than 14kb/sec.  I'm wondering, why is that?  Could there be something conflicting?  I know that ripping and copying disks are sometimes CPU intensive, but like I said, it's running much slower than my old laptop in comparison.  

My system specs: Windows XP Pro, Athlon 64 3500+, nVidia nForce4 motherboard (A8N-SLI SE), 1.5GB RAM, DVD burners at 16X DVD write/read speed.    

If anyone could give me some possible solutions and reasons why this is happening, I'd really appreciate it!  Thank you. :)
webmonkey8Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gary CaseRetiredCommented:
Sounds like your drives are working in PIO mode.

First, go to Device Manager and expand your IDE/ATA/ATAPI controller line; then for each IDE channel (Primary and Secondary) do a right-click, Properties and look on the Advanced Settings tab.   See if the "Transfer Mode" is set to "DMA if Available" ==> if not, change it to that.

Then look at the "Current Transfer Mode" and see if it's PIO or UDMA-x (x will probably be a 2).
If it's PIO, that's your problem.  In that case, do the following:

Load RegEdit (Start - Run - Regedit)

Go to the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Under each key, delete all occurences of the following values:

     MasterIdDataChecksum
     SlaveIdDataChecksum

Now reboot your system and all should be well.
0
Gary CaseRetiredCommented:
... by the way, ripping and burning discs is not very CPU intensive at all -- UNLESS you're operating in PIO mode.
0
rindiCommented:
If you are using both optical drives at the same time you will have very slow access, as only one device on the same ide channel can be accessed at the same time...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

LRDSCommented:
Check the DVD for scratches etc...
0
webmonkey8Author Commented:
Thanks for all of your responses.

garycase - I did go into the Device Manager and saw if the transfer mode is set to DMA.  It is set to "Ultra DMA 2 - Ultra33" for both optical drives.  However, there is an "Ultra DMA 4 - Ultra66".  Should I change it to that for a faster speed?  Would it be compatible?
I also couldn't find what you referred to as, "Current Transfer Mode".  Where can I find that?
0
Gary CaseRetiredCommented:
On the Advanced Settings tab for each of the IDE channels there should be three lines for each of the two devices:  "Device Type", "Transfer Mode", and "Current Transfer Mode"

If yours is displaying differently, I'm not sure why.  In that case, just do the registry modification I suggested above -- this is a "harmless" change ==> it simply forces redetection of the transfer capabilities of your devices, and may resolve this issue for you.

Another simple test:   (do this and post the results)

     Burn a DVD and while it's burning load Task Manager (Ctrl-Alt-Del) and click on the performance tab.   Look at the CPU usage and post the general range of what you're seeing.
0
webmonkey8Author Commented:
Here are a couple of screenshots I took of what I see in my "controller" properties.  As you can see, there isn't a "Current Transfer Mode".  

http://www.geocities.jp/ypfcm209/01.jpg

Also, I did a check on the registry and found this:

http://www.geocities.jp/ypfcm209/02.jpg

There's only one instance.  Do I need to delete this?
0
Gary CaseRetiredCommented:
Okay, if you right-click on My Computer;  select Properties;  then click on the Hardware tab; then select Device Manager; then click the "+" next to IDE ATA/ATAPI Controllers; what does the list look like after that??   ... and exactly which item did you select to get the 1st image above?

The 2nd image above doesn't look correct.   It looks like a value string (in the right pane of RegEdit); but you should navigate to the key in the left pane -- and then look in the right pane for the MasterIDDataCheckSum & SlaveIDDataCheckSum elements (which you need to delete).

When you run RegEdit, collapse everything (click on "-" signs) until you see only the highest level display (HKEY_CLASSES_ROOT, HKEY_CURRENT_USER, HKEY_LOCAL_MACHINE, HKEY_USERS, and HKEY_CURRENT_CONFIG).   Then click the plus sign by HKEY_LOCAL_MACHINE, then by SYSTEM, then by CurrentControlSet, then by Control, then by Class ==> and finally by {4D36E96A-E325-...}

UNDER that you should see the 0000, 0001, etc. ==> is this what you did??

0
webmonkey8Author Commented:
garycase - here are some more screenshots to show you.

To answer your first question as to what I see when I look at the ATA/ATAPI Controllers:

http://www.geocities.jp/ypfcm209/04.jpg

Also, here's another screenshot to show you that ULTRA DMA is available, but I'm not sure if I should choose it.  Would it be damaging to my system if I chose "Ultra DMA 4 - Ultra66"?
http://www.geocities.jp/ypfcm209/05.jpg

Here is the registry screenshot.
http://www.geocities.jp/ypfcm209/03.jpg
So you're saying just delete all those folders, such as, "0000", "0001", etc.?
0
aba3000Commented:
I have the same controler than you (nforce4). I was reading in net, and appear that this drive support this operation mode (udma mode 4). Make sure that you was using a 80 way cable. And try just leaving one optical drive in the flat cable. Set they to master and plug in the end of flat cable. Test and say to us what happen (or don't happen...).
0
Gary CaseRetiredCommented:
No, you don't delete the folders 0000, 0001, etc.   SELECT those folders -- one at a time -- and IF they contain values named MasterIDDataCheckSum or SlaveIDDataCheckSum (or both) delete THOSE.

That will force redetection of the transfer modes.

It does not appear that you really require this -- but it won't hurt.   There's no reason to change the modes in the nForce parameters in Device Manager -- the registry modifcation will force the system to use the best possible transfer mode.

Note sure if it will help here -- but it certainly won't hurt.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.