The Jet VBA file (VBAJet.dll for 16-bit versions, or VBAJet32.dll for 32-bit versions) failed to initialize when called

I have one user who is having problems with the DAO jet engine. It gives the exact same error message that MS has an article about. I follow that steps and it did not fix it. I try running the MDAC and jet35 sp and that did not fix it either.

We are using DAO 3.51 Object Library for MS Access database and the application was written in VB6. I know that the installer and the program are ok because we have thousand of users who does not have this problem.

Article.
http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q196/0/57.ASP&NoWebContent=1

LVL 5
lunchbyteAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

leclairmCommented:
Have you tried manually registering Expsrv.dll on the target computer??  Perhaps the installation didn't properly register it.

regsvr32 C:\WINDOWS\system32\Expsrv.dll
lunchbyteAuthor Commented:
Yes. It says expsrv.dll was loaded, but the DllRegisterServer entry point was not found. This file can not be registered.
leclairmCommented:
Okay that's correct as this is not a com object, so it can't be registered.  The version of MDAC you installed is < 2.6??
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

lunchbyteAuthor Commented:
Yes, it is 2.6
lunchbyteAuthor Commented:
wait you said < 2.6 are you saying that I should be using 2.5 or less? I used 2.6.
leclairmCommented:
2.6 and above don't include jet components.  Not sure if this is related to your problem, but it might be worth looking into.

http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q271908
lunchbyteAuthor Commented:

Thanks. I will let you know how it goes but it could be on Monday because the user may not be available today to try this.


Anthony PerkinsCommented:
Unfortunately, since you are still using DAO, MDAC is not going to help you very much.
leonstrykerCommented:
Which version of Access are you using?
lunchbyteAuthor Commented:
97 and I am using DAO 3.51.
Anthony PerkinsCommented:
>>I know that the installer and the program are ok because we have thousand of users who does not have this problem. <<
I would objectively revisit this concept.  I strongly suspect you have a setup problem and I will go out on a limb and say that you suspect the same otherwise you would not have attempted to follow the MS KB article which clearly states: "The error occurs with your original setup program because it does not include Expsrv.dll in the dependency information."  That is an installation problem, regardless of how you want to paint it.

The fact that is you have "thousand of users who does not have this problem." is immaterial.  You have been just lucky.
lunchbyteAuthor Commented:


>> 
The fact that is you have "thousand of users who does not have this problem." is immaterial.  You have been just lucky.

Lucky my ass!!!!!

There are lists of files that I have to install and I got them all. The rest of the dependences files should be preinstalled by the OS so I know something is wrong with this particular computer. In fact, the user installed it on the laptop and it works just not on the desktop computer. This is a place where you suppose to help other folks not come up with that kind of smirk answer. Pathetic!!!!! 95 dollar a year for this.
leclairmCommented:
Here's a link to the jet 3.5 service pack 3.

http://www.microsoft.com/downloads/details.aspx?FamilyID=7e82ef88-52ec-4a8f-8bb2-8b06d6cb668d&DisplayLang=en

There's also a link on the bottom of the page for mdac 2.5, which also has the jet components not included with 2.6 and greater.

Hope this helps!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Anthony PerkinsCommented:
>>Pathetic!!!!! 95 dollar a year for this.<<
Humility does not cost you anything here.

Good luck with your endeavors and keep us posted as to the solution you found.
lunchbyteAuthor Commented:
Reinstalling the OS fixed it. Points given to leclairm for trying so thanks.
leclairmCommented:
Well glad you fixed it and thanks for the points.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic Classic

From novice to tech pro — start learning today.