Access OWA 2003 from the internet using Linux firewall

Hi

If someone could help me with the following issue it would be greatly appreciated
I have setup a SBS 2003 machine standard install
OWA installed by default
I have a linux firewall and I have registered the external IP of the Firewall as the my webmail.domain.com IP.
On the firewall I have forwarded the following ports to my SBS server
80 / 88 / 443 / 691 / 389 / 3268 / 3268
If I am missing some or if some are not needed please let me know.

So if there is something I am missing please let me know as it is important that I get this issue resolve asap and it is currently not working

All help is welcome and will be appreciated

Thanks
mailnoviceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

marine7275Commented:
the default address to access owa out of the box is:

external----- https://mail.domainname.com/exchange
internal-----https://servername/exchange
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mad_JasperCommented:
0
ImmediateActionCommented:
What kind of error message do you see on the clients IE?
*You might want to turn off "Show Firendly HTTP Error Messages"
Tools menu --> Internet Options --> Advanced

1. Is the Windows Firewall turned off in the Services?

2. Can people access a basic html page on your web server without having to go through any Exchange kafuffle?

3. Can the client computer telnet to one / all of your webserver ports via a domain name?(Windows) Start menu --> cmd --> run --> telnet www.yourwebaddress.com 80

4. Marines example has SSL links in it, so it probably is not a caching problem. but..  I have seen issue getting to / past the initial logon page, 401 errors. Turn off the proxy on the client for the sake of testing, or make a caching rule on the proxy not to cache urls containing.

e.g.

mail.domainname.com/exchange
servername/exchange

5. You might also want to check how IE is set to prompt for credentials.
Tools menu --> Internet Options --> Secrurity --> Custom Button --> Scroll to the bottom of list and check settings.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.