100% CPU Utilization in Win2000 & XP

Posted on 2006-04-21
Last Modified: 2008-02-01
Good Day
I have read all the potential and tried the applicable ones before posting a question.

I have a HP Pavilion laptop.  The hard drive failed physically and was replaced.  First install was Windows XP-SP2.  It was very slow with 100% utilization of CPU, by svchost and/or System process.  Not believing that I had a real problem, I formatted out and installed Win2000 which I had run for two years before the hard drive issue.

I   ran the sysinternal process explorer an I am seeing more of the problem, but not enough to solve it.

Interrupts DPCs and System are all consuming ~33%  varies somewhat but the net result is 100 % utilization, making the machine very slow.  I am noticing on my work machine, that the Interrupts are not going much higher that 2%.  So I am fairly sure that one of the problems, is whatever is causing the (as high as ) 48% Interrupt count on this machine.

It has been virus scanned with a CA antivirus tool and scanned for adware with ad-aware

As part of the investigation, I needed to upgrade IE 5 to IE 6.  I downloaded and installed.  When I go Help> About, IE still says that it is IE 5, in the graphic portion of this window, but shows the version as 6.00??  I added this part, in case it sheds any light on this weirdness

Question by:Shanidar
    LVL 10

    Assisted Solution

    With a laptop this is a little harder to troubleshoot. I had a client recently where one of their pieces of hardware (modem) was causing high CPU utilization in the same way you're describing. Since you can't remove devices from your motherboard, I would suggest going into BIOS and disabling any peripheral devices to see if this fixes the problem. SInce you did a reinstall and the problem still occurs, it's most likely hardware related.
    LVL 4

    Expert Comment

    sfc /scannow

    this insure your system files are intact and in its original format
    LVL 1

    Author Comment

    Victor, are you familar with Process Explorer?  It is showing what seems to be a very high amount of interrupt activity.  I have seen a number of articles by people who used pstat, pview, and process explorer to pin an error all the way down to one corrupt file.  
    Do you know if there is a way to show what interrupts are causing all of the interrupt traffic?  'Cause if you do, that would point directly at the culprit device.

    I will be on the problem machine by about 1800 CDT
    LVL 10

    Expert Comment

    Unfortunately, no. I was looking for a utility for days and unless you want to spend hundreds on a low level interrupt monitor (that plugs into your mb) it's guess-and-check.
    LVL 3

    Expert Comment

    I had a similar problem where svchost was taking 100% processor utilization. Using the Process Explorer I found out that a service called Power Manager is causing this problem. After a lot of investigation I discovered that this is caused by a virus called Hidrag.a (sometimes also called Jeefo). I found a free removal tool called vcleaner on the site When I ran the tool it cleaned all infected files and the problem disappeared.
    LVL 1

    Expert Comment

    I would recommend a second opinion on the virus scan as well.
    Norton, Mcafee, and all the others have online virus scanners available for free:

    Usually, SVChost at 100% is the sign of a virus, however, since you formatted and it still appeared, is there a second partition that you aren't formatting? Also, check your manufacturer's site for updated drivers for your devices.
    LVL 44

    Expert Comment

    There is NO NORMAL system process that will peg the CPU utilization to 100% for any time.
    If you are getting this for more than 20 seconds, you either have a virus or a trojan infection.
    They are trying to get to the internet to install viruses/malware/spyware.  So you first go to the online site, and when that deactivate the main virus, you install McAfee antivirus.

    If you find no virus, and CPU still at 100% you have a serious system problem, maybe bad device.
    LVL 69

    Expert Comment

    Hi Shanidar couple of things .
    Have you run a windows update?
    This may update your system.
    did you connect to the internet before all your protection was installed?
    Which windows are you running?
    I would say you have to  Flash the bios and make sure it has the latest upgrade.

     get a good torch, and check out the capacitors on your mainboard, look for any swollen and split on top.
    These can be replaced, and re-soldered with new ones, problem is if there any swollen all will of that size will
     have to be replaced. This is not an expensive operation.
    But it may explain the high cpu. And other problems.

    How long if ever since the thermal jel under the processor been checked?
     heat can effect everything.

    I suggest a memory test. Not hard to do.

    Open your task manager at the top open VIEW then select columns>add Vurtual memory size, now when you look at your processes you can see which is hogging the most of your virutal memory or paged files.

    What have you set the page file size to it should be 1/5 the ram/

    Did you delete the partition before installing the windows? BTW which windows are you running 2000 or xp?
    How old is your psu if this send inconsistant power can also cause all kinds of high cpu usage  crashes lockups.

    What video card do you on board.

    how to download internet explorer 6 sp1 (full setup)

    Internet Explorer Tips
    LVL 15

    Accepted Solution

    Ok to get this straight your HD failed so you had it replaced by someone.  To rule out the obvious it cant be a virus cant be spyware it cant even involve the OS at all because you switched OS's so there is no way that is the factor.  So there are two things that come to my mind when looking at this case look for the x factor what has changed since it was running great and that is the HD.  One thing that could be wrong with the HD is drivers could be the wrong drivers causing the system to lock.  Another thing that could be going on is the HD is plugged in with the wrong kind of cable or pushing data to fast not compatible with the bios and a whole list of things.  The thing to look at is the HD that is the x factor that is what has changed and that is what is most likly causing all the fuss with the OS.
    LVL 1

    Author Comment

    I installed the HDD myself.  I am a qualified technicia with 17 years in this business, from IBM and Honeywell mainframes, DecVaxes, Alphas, and other mini frame systems, with the last 10 years in PCs.
    I went from a 40Gb 4200 spin to a 100 gb 5400 spin.  I dodn't want to increase the spin too much, because of potential heat concerns.

    In the XP scenario, I formatted and re partitioned the drive, to install.  I installed and patched it to SP2

    In the 2000 Scenario, formatted, and installed, then patched it to SP4

    The HDD controller is identifed by the Stystem as an Ali M5229.  I was of the same mind as the comment above, the only change having been the HDD.  The Ali site does not have drivers, at least not that I can find.

    I had intended to dig into this last PM, but I am in colombia, and beer drinking is part of the culture.  Well, in order to show respect for the culture here, "I had to go along to get along"  that's my story and I'm sticking to it.

    I have at different points disabled every device up to(from the bottom up) to the HDD.  I expect that the system will stop responding if I try to disable the the IDE controller.  But that is what I am going to try next.  

    Thanks for all the ideas so far...  I will post the results of the next tests when I complete them....
    LVL 1

    Author Comment

    I was following the two best comments above, about removing peripherals to see what happens, and focusing on the HDD.

    I didn't mention it, but a couple of times during the install, during the first start up, the system would fail, reporting some missing file.  The second thing I didn't mention is that the machine was unable to complete a restart.  It had to be powered off manually, and then powered on.  This, of course, points to hardware.

    What Solved It:

    I went and removed the Ali M5229 IDE controller, and restarted as the system instructed.  No Go.  On Startup, the system refound the device had the sme problem the whole time.  I changed the driver to the MS "Standard Dual Channel IDE Controller" and rebooted as instructed.
    System came up with a 5% CPU utilization.  I wanted to test it, so I changed it back to the original driver and rebooted.  Well, it rebooted normally, so that was a good sign, but when the system came up, I still had around 5% CPU utilization.

    Best guess is a corrupt driver/bad read from the install media, and only changing the driver actually forced the system to go overwrite the corrupt copy with a new copy.

    Points to the two folks who were the most help, and Thanks to EVERYONE who participated to try to help.

    Peace Out

    Featured Post

    How to improve team productivity

    Quip adds documents, spreadsheets, and tasklists to your Slack experience
    - Elevate ideas to Quip docs
    - Share Quip docs in Slack
    - Get notified of changes to your docs
    - Available on iOS/Android/Desktop/Web
    - Online/Offline

    Join & Write a Comment

    Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
    I don't know if many of you have made the great mistake of using the Cisco Thin Client model with the management software VXC. If you have then you are probably more then familiar with the incredibly clunky interface, the numerous work arounds, and …
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now