Shares

Im running windows XP pro sp1 computers that are not on a DOMAIN. How can i disable all shares, even the ones that are created by default.
kissmecatAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetExpertCommented:
Open command line, type in
services.msc
Double click, switch Server service to Manual (or Disabled) and Stop it.
0
Craig_200XCommented:
To delete a share, follow these steps:

1. In Control Panel, double-click Administrative Tools, and then double-click Computer Management.
2. Expand Shared Folders, and then click Shares..
3. In the Shared Folder column, right-click the share that you want to delete, click Stop sharing, and then click OK.

http://support.microsoft.com/?kbid=314984
0
nexissteveCommented:
The most simplest way is to enable simple file sharing on XP.

Open Explorer
Go to Tools then Folder options.
Click on the view TAB
Scroll down to the very bottom and check the box to use simple file sharing.

This will disable all shares including administrative i.e c$

Cheers

S
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

samb39Commented:
I am very confused by the last comment.  You can share folders and printers with Simple File Sharing -- it does not disable it.

To disable sharing, I would go to Local Area Connection Properties and uncheck "File and Printer Sharing for Microsoft Networks"

0
nexissteveCommented:
Try it Samb39, turn on simple file sharing and try to log on to an administrative share.

0
isd503Commented:
Be careful about deleting administrative shares.  If you control the local Administrator account and local Administrators and Power Users groups, then you do not have to worry about users accessing these shares.

Also, consider elevating the machines to SP-2 unless you have some reason you cannot do this?
0
Craig_200XCommented:
Nexissteve - I tryed you solution, and it didnt do anything. my shares were still there.
0
nexissteveCommented:
Simple file sharing should force you to connect as guest.

Did you reboot the system after turning the setting on.?
0
samb39Commented:
I can understand that Simple File Sharing might stop the Administrative shares, but the requirement was to:

"disable all shares, even the ones that are created by default"

0
nexissteveCommented:
Ok,

I have tested this on my test environment and it does disable ALL shares!!!!!!!!!!!!!!

If you turn on simple file sharing the only account allowed to connect will be guest.

This will in effect stop ALL shares working.

I do not know what you guys are testing on, but the test system I am using is windows XP SP2 and I am almost 100% certain that SP1 behaviour is the same.

so try this: turn on simple file sharing
then open a CMD shell on machines that have been connected to the machine your testing on. do a net use /del *

Then try and access ANY share that was available previously.

I am pretty damn sure all you will be prompted for is a guest login. Which if your guest account is disabled will get you nowhere.

Cheers

Steve
0
kissmecatAuthor Commented:
I tried NetExpert  (disabling the service) & Craig_200X way and disabled each share but it warned me that when my computer restarts the shares we be enabled again. I want to permentaly disable it. If there should ever be a need to enable it I can in the future, but for all intesive purposes I want all of them disabled.

nexissteve I am currently using simple file sharing as my option. When I preformed NetExpert or Craig_200X option I still had shares listed (while still being on simple file sharing)

samb39 - I have also unchecked the "File and Printer Sharing for Microsoft Networks" and still found the shares listed in Computer management/Share

0
kissmecatAuthor Commented:
isnt there anything else, or did i do something wrong....???
0
NetExpertCommented:
When you disable and stop the server service, REMOTELY nothing can access any shares - whatever you mean - for sure. The shares (??) maybe listed, but if you try to access it you'll receive error (try clicking things in Computer Management/Share). I'm confident that the server service alone is sufficient to turn off remote file sharing.

Certainly you (admin account) and system account still have full access locally, for the system to work. If you want to disable sharing files between local account, it's the Simple File Sharing option, but I guess you are talking about sharing resources over a network.
0
isd503Commented:
Try this, but you need to be very careful about editing the registry.  I suggest you backup your registry before you apply this hack:

http://www.petri.co.il/disable_administrative_shares.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kissmecatAuthor Commented:
This works Thanks you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.