RPC over HTTP not working on 1 out of 2 Exchange 2003 Front End Servers

Posted on 2006-04-21
Last Modified: 2008-02-01
Hello All,

This one's driving me crazy. Here's my situation:

I've got a single Exchange 2003 Enterprise Edition SP2 Back-end server and 2 Exchange 2003 Enterprise Edition SP2 Front-end servers. None of the Exchange servers are Domain Controllers. I have 3 separate Windows 2003 SP1 Standard Edition Domain controllers, and a single Windows 2000 DC. 2 of the 2003 DC's are Global Catalog servers, as well as the 2000 DC. All 3 Exchange servers have been configured correctly in Exchange System Manager for RPC over HTTP. The two front end servers have been configured identically, yet RPC/HTTP only works on one of them. I've checked and re-checked the appropriate registry entries, certificates and have uninstalled/reinstalled RPC/HTTP on the box that doesn't work to no avail. Both of the front-end servers have the exact same ValidPorts value in the HKLM\Software\Microsoft\Rpc\RpcProxy key. IIS is configured identically on both front end boxes.

Am I missing something somewhere? Is there a limitation with RPC/HTTP that only allows one front-end server?

Any help will be greatly appreciated!


Question by:jbaker151
    LVL 104

    Expert Comment

    With Exchange 2003 SP1 and higher you don't configure the registry entries. All you need to do is change the settings in the GUI. There is no restriction on the number of frontends so I don't think that is the problem.

    What does rpcdiag say when you try to connect?


    Author Comment

    When I use rpcdiag it shows repeated Directory and Referral attempts, and then it eventually dies out and I get an "Exchange Server Unavailable" error. Are there any logfiles anywhere that would give some more detail to this?

    As far as the registry settings go, I have configured them on both front ends, and one of them works, so do you really think this causing the problem? I can certainly try getting rid of them, but I don't want to break the one that's working - though since we're not in production with these servers I guess it doesn't really matter whether I break it or not. Should I just delete the RpcProxy keys?

    Thanks Simon,


    Author Comment

    quick clarification...I don't mean to delete the RpcProxy keys, but to revert the ValidPorts value back to the default.
    LVL 104

    Accepted Solution

    As you are on FE/BE you don't need to set the registry.

    Therefore set all machines to "not part of an Exchange managed RPC-HTTP Topology" in ESM.
    That will flush out the settings.
    Then set them back to as appropriate.


    Author Comment

    Thanks Simon, that did the trick!

    I really appreciate the help.


    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Set OWA language and time zone in Exchange for individuals, all users or per database.
    "Migrate" an SMTP relay receive connector to a new server using info from an old server.
    In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
    To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

    732 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now