Cannot get Mysql work on Redhat Enterprise 4

Posted on 2006-04-21
Last Modified: 2008-03-03
Hi experts,

I am running Rehdat enterprise 4 linux and Mysql MySQL-server5.0.19-0
i get the following with
# mysqladmin ping
mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists!

and when try to start the mysql server
# /etc/init.d/mysql restart
MySQL manager or server PID file could not be found!       [FAILED]
Starting MySQLCouldn't find MySQL manager or server        [FAILED]

it looks like mysql is not running on my server
# ps -ef | grep mysql
root      4177  3931  0 16:21 pts/1    00:00:00 grep mysql

/var/lib/mysql/mysql.sock actually does not exists on my system.

i would appreciate any help on this issue


Question by:cakirfatih
    LVL 15

    Expert Comment

    did you remove mysql 4 before installing 5.0.19?

    What was your ./configure line when you were building it?
    LVL 3

    Expert Comment

    Yes, more info needed.  How did you install and configure Mysql?

    You might find it useful to do "locate mysql.sock" to make sure it hasn't been created in a different location from what's in your my.cnf file.  

    Also, have you looked at the my.cnf file at all and made sure that it has what you need?

    Author Comment

    yes i did remove mysql 4 before installing 5.0.19
    i used the rpm packages from the mysql website , so i did not have to use ./configure command.

    i have installed these packages from the mysql website

               MySQL-client-standard 5.0.19-0.rhel3       
               MySQL-server-standard 5.0.19-0.rhel3       
               MySQL-shared-compat 5.0.19-0.rhel3
               MySQL-shared-standard 5.0.19-0.rhel3

    after this i did not make any configurations because i cannot get it worked.

    also here is the copy of my.cnf file
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).

    LVL 15

    Expert Comment

    I would strongly suggest you to use


    instead of MySQL's RPM. You can get this one from RHN, it's a part of  Red Hat Web Application Stack 1.0 Beta.


    Author Comment

    how should i go with a clean uninstall of the current version of Mysql and then
    install the version you mention.

    i don't wana do it my way, which is using webmin.
    is there any other you can recomend.

    LVL 15

    Expert Comment

    rpm -e MySQL-client-standard MySQL-server-standard MySQL-shared-compat MySQL-shared-standard

    from the command line. This will leave behind some backups of my.cnf and maybe other files, when you run this command it'll tell you something like

    my.cnf.backup saved as a backup...

    delete all these files manually, then you should be good to go to install the new one. If you see any other output while you are removing the RPMs, post it here.

    Author Comment

    i get this message

    ]# rpm -e MySQL-client-standard MySQL-server-standard MySQL-share d-compat MySQL-shared-standard
    error: Failed dependencies:
   is needed by (installed) MyODBC-2.50.39-21.RHEL4.1. i386
   is needed by (installed) cyrus-sasl-sql-2.1.19-5.EL 4.i386
   is needed by (installed) dovecot-0.99.11-2.EL4.1.i3 86

    i also have a subscription to redhat network for tech support, i could not find the mysql-5.0.18-4.el4s1.1.i386 there
    how can i get this version?
    i could not find it on rpmfinder website as well

    LVL 15

    Accepted Solution

    ok, add those rpms to the list you are removing:

    rpm -e MySQL......  MyODBC cyrus-sasl-sql dovecot

    If you need them you can reinstall them later once you install the new MySQL.

    To get it from RHN, log in into RHN, (, click "Channels" in the red main menu bar, one of the channels listed is named:

     Red Hat Web Application Stack 1.0 Beta (for ES v. 4 x86)

    Click that,  in the small menu where it says Details - Errata - Packages click Packages, they should be on the first page.

    Author Comment

    that worked,
    thanks for your help
    LVL 15

    Expert Comment

    you're welcome, thanks for the points ;)

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    A lot of articles have been written on splitting mysqldump and grabbing the required tables. A long while back, when Shlomi ( had suggested a “sed” way, I actually shell …
    Both Easy and Powerful How easy is PHP? (  Very easy.  It has been described as "a programming language even my grandmother can use." How powerful is PHP?  http://en.wikiped…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now