XP SP2: How to Turn Off the Data Execution Prevention feature (DEP)

Is there a way to disable it globally (registry, OU, policy) instead of using the exception list for executables ?
LVL 2
CassavatechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

war1Commented:
Greetings, Cassavatech !

http://www.tech-recipes.com/windows_tips566.html

1. Click Start
2. Select Control Panel
3. Select System
4. Click the Advanced tab
5. In the Performance region select Settings
6. Click the Data Execute tab in the dialog box that opens
7. Select Turn on DEP for all programs and services except for those I select
8. Click Add.
9. The open dialog box will open. Browse and select your application.
10. Click Open
11. Click Apply
12. Click Ok
13. Reboot


Best wishes!
0
LeeTutorretiredCommented:
War1, that is the "using the exception list for executables" method which he does not want.

The below article is all about DEP, and the url will take you to a section where it explains how to turn off DEP for the entire computer.  Apparently this must be done for each computer; the article doesn't describe any policies, etc.:


http://www.microsoft.com/technet/security/prodtech/windowsxp/depcnfxp.mspx#ETJAC
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CassavatechAuthor Commented:
Hi LeeTutor ,

thanks a lot .. that worked .. as usuall :)
0
MereteCommented:
Are you using a nvidia card or having game crashes?

If you want to disable it global, edit boot.ini and
 change the  /noexecute policy level to always off.     /NoExecute=AlwaysOff


Not all of it works on all processes.

To see the limitations of DEP look at this MS artical
http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2mempr.mspx
0
MereteCommented:
lol ok . Done deal.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.