Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

OMA and Activesync logon / authentication Error

Posted on 2006-04-22
13
Medium Priority
?
625 Views
Last Modified: 2008-02-01
Hi,
 
I have and Exchange 2003 with SP2 installed on windows 2003 SP1. I have configured the server for RPC-HTTP, web access and also for mobile access. The RPC-HTTP and web access works fine. But I am having trouble to get the OMA and active sync to work.

Configuration Details

-      The website is installed in a directory named “OWA Web Site” with SSL enabled, authentication methods for the website is “Integrated windows authentication” and “Digest authentication”
-      I have a certificate server installed and this certificate is imported on this exchange server.
-      Since I have single server, I have followed the MSKB article http://support.microsoft.com/default.aspx?kbid=817379 

To start, if I internally log on to my server as https://servername/oma it comes up with the username and password dialog box. Once I enter the Domain\username and password it comes up with a message as “A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator” .I have triple checked for the access rights in exchange for mobile access and also this user has administrative rights.

Windows 2003 comes up with an event ID 1503 with the following details,

An unknown error occurred while processing the current request:
Message: The remote server returned an error: (400) Bad Request.
Source: Microsoft.Exchange.OMA.ExchangeDataProvider
Stack trace:
   at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
   at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface


Please help, Many Thanks in advance,

Abileel
0
Comment
Question by:abileel
  • 5
  • 5
11 Comments
 
LVL 7

Expert Comment

by:MontyV
ID: 16518649
Hello Abileel

Here is a Microsoft article that should help -->  http://support.microsoft.com/?kbid=898131

If you are still having problems please let me know what device your are trying to connect with.

- Monty

0
 
LVL 104

Expert Comment

by:Sembee
ID: 16519309
Single server takes some tricks to get the server to work correctly.

Test OMA using Internet Explorer with show friendly http messages turned off. This will show you what the real error message is.
However the most common reasons for OMA/EAS failures are
- application pool
- authentication settings
- certificate problems.

If the certificate isn't trusted by the device, then it will fail. You either have to install the certificate or the root certificate in to device for it to work. Having the certificate on the server is not enough.
If the certificate is a purchased certificate, then you should get the root certificate for that purchased certificate from the certificate supplier and import that to the device.

Application pool and authentication settings I have listed on my web site here:
http://www.amset.info/exchange/mobile-eastrouble.asp

Simon.
0
 
LVL 4

Author Comment

by:abileel
ID: 16522513
Thank you for your response

Monty,

  I had tried this article long ago, but am not sure if this is the issue.

Simon,

  Following your procedure, checked with the application pool and authentication settings, no luck. I have a certificate server and the certificate is imported into the root certificate of my computer and as the first step, I am trying to log onto the OMA with https://servername/OMA which again comes up with the same error message. ( the install cerficate screen does not come up when I am trying to access the oma site as the root certificate is installed )

Error Message:
https://servername/oma/(1rkydgqbj25voy3ogzm22gj3)/oma.aspx and error “A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator”

I have also tried using my smart phone 2 with the latest bios update. Performing an EAS the following error message comes up.

Error message “ Synchronization failed because of a server error. Try again. Error code : HTTP_503”

Hope you would have some other steps to try.

Many Thanks once again

Libi
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 104

Expert Comment

by:Sembee
ID: 16524425
First to note is that OMA error messages are cached. You have to acknowledge the message otherwise every time that you cannot, you will find that it doesn't load - instead it throws up that error message.
When you get that message, if you clear everything after the first /oma (ie the random text), and then press the button to load the page, does OMA load correctly?

On the phones, unless the certificate is imported then you will not get access.

503 errors are server errors, so that is where you need to concentrate your efforts.

Is Forms Based Authentication enabled on this server?

Simon.
0
 
LVL 4

Author Comment

by:abileel
ID: 16534861

Simon,

  As you have suggested I have cleared all cache and in IE once, I type https://servername/oma it comes up with the error, I cleared all text after the first oma (including the random text) and tried to load the page. The same error comes up with a different set of random number in the address bar.

The forms based authentication is enabled with compression set as High

Hope I we can fix this

Thanks,

Libi
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16538097
FBA breaks OMA/EAS.
Have you attempted to circumvent that?
If so, which method?

Mine?: http://www.amset.info/exchange/mobile-omafba.asp
or Microsoft's?: http://support.microsoft.com/default.aspx?kbid=817379

Simon.

0
 
LVL 4

Author Comment

by:abileel
ID: 16551439
Thanks again Simon,

   I have tried the MSKB article http://support.microsoft.com/default.aspx?kbid=817379, step by step, which still does not solve my issue. I have also changed the windows to accept both, Kerberos and NTLM authentication. No go yet.

Thanks again
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16553736
You may have to set the OWA virtual folders, as with all the playing around there is no way of knowing what settings are where. http://support.microsoft.com/default.aspx?kbid=883380

Simon.
0
 
LVL 4

Author Comment

by:abileel
ID: 16560162
Simon,

  This is a live server and the webaccess which works fine is being used by many users. Following the article step by step is going to completly reset the entire configuration.

  Is there any other alternative that will not affect the web users? else I will have to replicate the entire issue on a test server and then try the above mentioned methord.

  Please let me know if there can be any other alternative methord.

Many Thanks,
0
 
LVL 104

Accepted Solution

by:
Sembee earned 2000 total points
ID: 16565145
The only other way that MIGHT work would be to pull the configuration off another server - a test machine for example, using an XML file. However part of the fix is that it flushes out the metabase configuration for those folders, which you don't see.

I have been through this a number of times, including on my home production and test systems and have had to resort to the reset most of the time. I have probably managed to get it to work other times by fiddling around, but don't ask me what I did as I couldn't tell you.

Simon.
0
 
LVL 4

Author Comment

by:abileel
ID: 16567946
Ok then,

Please give me couple of days I will replicate the same on a test server and let you know the result

Thanks,
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question