Retrieval of Foreign characters from Oracle DB

Team,

I am trying to retrieve the foreign characters (especially Japanese) from Oracle Database using SQL*Plus or the 3rd party tool called PL/SQL Developer (equivalent to Toad) and bring this into a Text file;

OR using the OLE DB Provider for Oracle via SQL Server 2000.  

In both cases, I am seeing some junk characters.

Initially, it was giving inverted question marks.

Upon change the Registry Editor for Oracle to say AMERICAN_AMERICA.UTF8 (from West. English Code page 8859), it started giving only the junk characters.

What should I do to get the actual Japanese characters.  Any help or suggestions would be very much appreciated.  Again, it is NOT only Japanese, this DB contains mainly English and Japanese.  Both should come in one retrieval (Query).

Thanks,
Vp
jsramsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jsramsAuthor Commented:
Team,

BTW, I forgot to say this to you folks.

I also set the system env. variable to NLS_LANG = AMERICAN_AMERICA.UTF8

Even if I set this, I get only the junk characters.

Appreciate if you could have any suggestions for me please.

Thanks, Vp
0
actonwangCommented:
The display on your client tool may also depend on your character set setting on your OS itself. Does your OS diplay Japanese?
0
jsramsAuthor Commented:
First of all thank you very much for your reply.  I am waiting for such responses.  

The Win2K O/S properly shows in the Internet Explorer with the file that has the actual Japanese characters.   No issues.  This means the O/S has the plugins.  But, when I opened it up in Notepad it just says "box" character.  

Where should I check to see the O/S has the correct settings.

Also, I tried with various settings at the o/S level and nothing helped.  Either it shows the junk characters or

Any help would be much appreciated.

It shows either characters like "þþþþ 4 þþþþ 4F " when I set my OS Env. Variable to WEPC850 (OR)
inverted question marks for no variable settings or West. English or WE8MSWIN1252 (OR)
question marks for US8PC437 (Active COde page 437) or US7ASCII (OR)
junk characters like "市谷台町 4 大鷹ビル 4F" for American_America.UTF8 (OR)
some other junk like "ƒ‚ƒWƒ…[ƒ‹ƒrƒWƒlƒXƒ†ƒjƒbƒg"  when using JA16SJIS

That's my problem.  

My registry editor is set to American_America.UTF8 for NLS_LANG

Thanks in adavnce for all your help and appreciate if you could let me know, if I can do something to make your life easier to answer.

Br, Vp
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jsramsAuthor Commented:
First of all thank you very much for your reply.  I am waiting for such responses.  

The Win2K O/S properly shows in the Internet Explorer with the file that has the actual Japanese characters.   No issues.  This means the O/S has the plugins.  But, when I opened it up in Notepad it just says "box" character.  

Where should I check to see the O/S has the correct settings.

Also, I tried with various settings at the o/S level and nothing helped.  Either it shows the junk characters or

Any help would be much appreciated.

It shows either characters like "þþþþ 4 þþþþ 4F " when I set my OS Env. Variable to WEPC850 (OR)
inverted question marks for no variable settings or West. English or WE8MSWIN1252 (OR)
question marks for US8PC437 (Active COde page 437) or US7ASCII (OR)
junk characters like "市谷台町 4 大鷹ビル 4F" for American_America.UTF8 (OR)
some other junk like "ƒ‚ƒWƒ…[ƒ‹ƒrƒWƒlƒXƒ†ƒjƒbƒg"  when using JA16SJIS

That's my problem.  

My registry editor is set to American_America.UTF8 for NLS_LANG

Thanks in adavnce for all your help and appreciate if you could let me know, if I can do something to make your life easier to answer.

For the past couple of days, I don't think we are getting the answer right.    Any help / suggestions woul be very much appreciated.  Thanks in advance.  Appreciate if you could treat this very urgent.  TIA, VP


Br, Vp
0
actonwangCommented:
hi,

      Explorer can set encoding for specific regardless of your OS language settings. In other words, plugins are only limited to explorer itself and doesn't neccessary mean you can see Japnese character in other programs (not at all).
      That being said, in order to see japnese characters, either:
      1. Your client tool support encoding as explorer does.
or   2. Your OS language setting supports it. For windows, you use "control panel" --> "Reginal and Lanuage Options" to see it.

Acton
0
actonwangCommented:
Do a simple test here actually? Change the page encoding to UTF-8 then you will see some japanese characters in your previous post before " ...for American_America.UTF8 (OR)".

IT is there , isn;t it? You just need to have a UTF8 enabled viewer to see them. Probably not PL/SQL developer if it doesn't support UT
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.