• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 329
  • Last Modified:

Need help setting up a VPN between Symantec 5200 and PIX 500

I am trying to setup a VPN between a Symantec 5200 and a Cisco PIX 501. I have configured the Symantec according to their knowledgebase article:

http://service1.symantec.com/SUPPORT/ent-gate.nsf/docid/2002022514174154?Open&src=&docid=2002121711565354&nsf=ent-gate.nsf&view=3fcd5fb2fcae709e88256bc1005cd7c9&dtype=&prod=&ver=&osv=&osv_lvl=&seg=

I configured the PIX using the Cisco PIX device manager 3.0, but I cannot get the VPN to connect. If anyone could guide me through the setup on the PIX it would be greatly appreciated.
0
daxatviyu
Asked:
daxatviyu
  • 2
  • 2
1 Solution
 
stressedout2004Commented:
Can you post a sanitized config of your PIX so we could check for any misconfiguration? If you are using the PDM, you can get the running config by going to File>show running-config in new window which will open up a new page with the PIX config.

0
 
daxatviyuAuthor Commented:
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password AZkV.aeID4iUGvj0 encrypted
passwd AZkV.aeID4iUGvj0 encrypted
hostname pixfirewall
domain-name americare.secureserver.net
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 69.15.242.179 HQ
access-list outside_access_in permit tcp any any eq ftp-data
access-list outside_access_in permit tcp any any eq ftp
access-list outside_access_in permit tcp any any eq ssh
access-list outside_access_in permit tcp any any eq 42
access-list outside_access_in permit udp any any eq nameserver
access-list outside_access_in permit tcp any any eq domain
access-list outside_access_in permit udp any any eq domain
access-list outside_access_in permit tcp any any eq www
access-list outside_access_in permit tcp any any eq pop3
access-list outside_access_in permit tcp any any eq https
access-list outside_access_in permit tcp any any eq 465
access-list outside_access_in permit tcp any any eq 587
access-list outside_access_in permit tcp any any eq 995
access-list outside_access_in permit tcp any any eq 993
access-list outside_access_in permit tcp any any eq 3389
access-list outside_access_in permit tcp any any eq 8443
access-list outside_access_in permit tcp any any eq 9999
access-list outside_access_in permit tcp any any eq 2086
access-list outside_access_in permit tcp any any eq 2087
access-list outside_access_in permit tcp any any eq 2082
access-list outside_access_in permit tcp any any eq 2083
access-list outside_access_in permit tcp any any eq 2096
access-list outside_access_in permit tcp any any eq 2095
access-list outside_access_in deny tcp any any eq telnet
access-list outside_access_in deny tcp any any eq smtp
access-list outside_access_in deny tcp any any eq imap4
access-list outside_access_in deny tcp any any eq 1433
access-list outside_access_in deny tcp any any eq 3306
access-list outside_access_in deny tcp any any eq 9080
access-list outside_access_in deny tcp any any eq 9090
access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit icmp any any source-quench
access-list outside_access_in permit icmp any any unreachable
access-list outside_access_in permit icmp any any time-exceeded
access-list outside_access_in permit tcp any eq ftp host 68.178.242.159
access-list outside_cryptomap_10 deny ip 10.10.10.0 255.255.255.0 68.178.242.0 255.255.255.0
access-list inside_nat0_outbound permit ip 10.10.10.0 255.255.255.0 interface outside
access-list inside_nat0_outbound permit ip 10.10.10.0 255.255.255.0 68.178.242.0 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 68.178.242.171 255.255.255.0
ip address inside 10.10.10.254 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
pdm location 68.178.242.159 255.255.255.255 outside
pdm location 10.10.10.1 255.255.255.255 inside
pdm location 10.10.10.0 255.255.255.0 inside
pdm location HQ 255.255.255.255 outside
pdm history enable
arp timeout 14400
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 0 10.10.10.0 255.255.255.0 0 0
static (outside,inside) 10.10.10.1 68.178.242.159 netmask 255.255.255.255 0 0
static (inside,outside) 68.178.242.159 10.10.10.1 netmask 255.255.255.255 0 0
static (inside,outside) 10.10.10.254 10.10.10.254 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 68.178.242.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 10.10.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 10 ipsec-isakmp
crypto map outside_map 10 match address outside_cryptomap_10
crypto map outside_map 10 set peer HQ
crypto map outside_map 10 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp enable inside
isakmp key ******** address HQ netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
management-access outside
console timeout 0
username viyu password WRn79EfnkU2UjBzk encrypted privilege 15
terminal width 80
Cryptochecksum:d037af62156df25d28998729a2cc77e6
: end
[OK]

0
 
stressedout2004Commented:
The following lines on the configuration  needs to be look at and changed.

access-list outside_cryptomap_10 deny ip 10.10.10.0 255.255.255.0 68.178.242.0 255.255.255.0
access-list inside_nat0_outbound permit ip 10.10.10.0 255.255.255.0 68.178.242.0 255.255.255.0

The 68.178.242.0/24 on the access-list above refers to the PIX outside network. This should refer to the network
on the Symantec 5200 that you want to access over VPN. And outside_cryptomap_10 should be "permit" and not "deny"

If the network on the Symantec is 192.168.1.0/24 for instance, then it should like these:

access-list outside_cryptomap_10 permit ip 10.10.10.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound permit ip 10.10.10.0 255.255.255.0 192.168.1.0 255.255.255.0

Also the following access-list does not make sense. They won't be doing anything. So I would recommend that
you delete the line from your config.

access-list inside_nat0_outbound permit ip 10.10.10.0 255.255.255.0 interface outside

The configuration of both Symantec 5200 and PIX should exactly be mirrored for the VPN to work.

0
 
daxatviyuAuthor Commented:
Thanks. That got me on the right track. The VPN is working now.


Here is what I added to the config:

access-list inside_nat0_outbound permit ip 10.10.10.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list 101 permit ip 10.10.10.0 255.255.255.0 192.168.1.0 255.255.255.0
crypto map outside_map 10 ipsec-isakmp
crypto map outside_map 10 match address 101
crypto map outside_map 10 set peer 69.15.246.58
crypto map outside_map 10 set transform-set ESP-3DES-MD5
crypto map outside_map 10 set security-association lifetime seconds 28800 kilobytes 2100000
isakmp key ***presharedsecret*** address 69.15.246.58 netmask 255.255.255.255
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now