I cannot delete a directory whose name consists of non-latin characters

Dear Experts,
I have some junk directories on my Pocket PC where the name of the directory cannot be displayed properly.  The characters appear as squares.  I think they are East Asian characters.  The directory contains no files.  When I try to delete it I get an error that says: "problem deleting the file .....".

I have also tried deleting it with Resco Explorer also without success.
Best Wishes,


Philip T.
LVL 1
PTRUSCOTTAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mikal613Commented:
then you cant delete it :(
0
Mikal613Commented:
or try this

http://www.freewareppc.com/utilities/safemodeforpocketpc.shtml

maybe theres an exe holding those folders.

MAKE A BACKUP BEFORE YOU TRY THIS!!
0
sakuya_suCommented:
yeah that happens, yiy cabt delete them on the PPC, you have to either Sync it with a computer, then delete it from there(you should see the ppc listed as a Mobile device in my computer),.

Or, if the file is on a SD card or something, get a card reader, delete it from there.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

sakuya_suCommented:
woah what was i typing lol

change "yiy cabt" to "you cant" please lol
0
PTRUSCOTTAuthor Commented:
Unfortunately I tried this and I run into the same problem.  Even trying to delete the directory from my laptop computer I get an error message saying that file names cannot contain characters such as "<" or ">" and it does not do the deletion.  I get the same error message when I attempt to rename the directory.
-Philip
0
sakuya_suCommented:
consider formatting the card? or if you know what language the characters are in, get a OS that has that language.

alternatively, try using a Linux OS to see if you can delete off that.

also.. if you know how to access Dos console, does Dos see those files? if it does then try deleting it from DOS?
0
PTRUSCOTTAuthor Commented:
If I format the card I assume that I lose all the data on the card and have to re-install everying?
0
sakuya_suCommented:
yeah, that is the case
0
clippershipCommented:
Presumably you've tried renaming the directories, etc. (Press Alt and Click on the icon) after which a delete may work. I wonder can you make a shortcut and examine the path?

Finally, back up the good apps, remove primary power and the backup batttery and press the hard reset button for a minute or two. Then (sigh) restore away!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphone Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.