?
Solved

ADPrep runs ok but adding w2k3 server to 2000 domain shows still not updated.

Posted on 2006-04-23
3
Medium Priority
?
262 Views
Last Modified: 2010-04-18
I'm updating a 2000 network.  There were two 2000 servers, one TS, one DC/Exch/SQL.  I replaced the TS with new, scrubbed and loaded the old TS server with 2003 and want to promote it so I have two dc's before I pull exchange and do an inplace upgrade on the third.  I ran adprep on the domain with all three switches, '/forestprep' '/domainprep' and '/domainprep /gpprep'.  All three ran successfully.  I'm now trying to dcpromo the reloaded server but am getting an error message that I need to 'run adprep, the forest is not compatable'.  I rebooted all three machines to make sure they sync policies and domain information.  I tried to re-run adprep but got an error saying it already ran.

Help!!!!  I can't find any info on this at M$ or google,  all similar problems show different dcpromo error messages.

Jim
0
Comment
Question by:jrtall
  • 2
3 Comments
 
LVL 48

Accepted Solution

by:
Jay_Jay70 earned 2000 total points
ID: 16521008
Hi jrtall,

with windows 2003 R2 (release 2) you will need to run the adprep tools from the second cd supplied in the 2 cd set!

\CMPNENTS\R2\ADPREP

you can also download here
http://www.microsoft.com/downloads/details.aspx?familyid=5B73CF03-84DD-480F-98F9-526EC09E9BA8&displaylang=en

this boosts the schema up to cope with R2 functionality

Cheers!
0
 
LVL 1

Author Comment

by:jrtall
ID: 16521549
You hit the nail on the head!

It makes me sick to think of the time I wasted because they couldn't document that right... the old adprep is in the i386 folder on disk 1, the folder right where I'd expect to find it based on it's location in earlier versions...  Bill's going to get a personal note from me on that one!

Thanks for the quick assistance!!!!

Jim
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16521847
dont worry man, a lot of people are going through the same problems

cheers
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question