RAID5 ARRAY MISSING!  Server Crash!! Adaptec 2130S-3x 74GB Seagate SCSI

Posted on 2006-04-23
Last Modified: 2012-06-27
I have a SBS03 server running on an Intel MB, DUAL 3.2GHz XEON, 3x Seagate 74GB U320 SCSI HDD, Adaptec 2130S with RAID5.
On Friday I was notified the server screen said "Insert boot media" AAAAAHHHH!!!

Upon restarting the server the Adaptec Card said: "There are missing members in the Array"
Yet there was no information about what member or why. No failed disk message.

I hit ctrl+h to enter the config utility, A message appeared stating there was a change made and I could either except or reject. I rejected. Went to manage arrays, message appeared "no array present". I checked the create array option and my 3 HDD were there. I stated an attempt to create an array, I hit space to select each drive, hit enter to create array, message said: "no disks availabe".

It seams I could initilize the drives, but I DID NOT do that. I checked around to see if there was some other way to identify the issue, tring to find it there was a failed HDD or what. I could find no such information. i restarted the server, same error: "There are missing members in the Array". i entered the config utility, this time I hit "accept" on the message stating there was a change made.

Went to manage arrays, same thing: "no array present", tried to create an array, same thing: "no disks available".
Restared again, got a new error, that the adaptec kernel could not start. At that point I assumed there was an issue with the 2130S card. I flashed the firmware from version 7348 to 8832.

Upon restarting I got a new message: that disk 0:2 was no available. I went into the config utillity, no arrays present, when I went to create an array the HDD's all showed 25MB of space. When I selected the 3 disks and hit enter the RAID creatoin screen appeared. It looked like I could then create the RAID5 array, but the total disk space shaed as being 75GB. very weired. At this point I stopped.

I am hoping I did not lose my array, I dont know if I have a controller card issue or a HDD issue, I dont know if when I flashed the 2130S I lost my array and all hopes of getting my data back????????? I hope not.  So any ideas, what can I try? Tommorow morning I have a company dependent (as usal) upon this server being up and running. (at the moment my MX records are being FWD, so I am losing all my emails)


7348   8832
Question by:Natetech
    LVL 30

    Expert Comment

    by:Duncan Meyers
    It sounds like a controller card issue - but it is possible that the controller has "scribbled" all over  the array structures - in which case you'll need to reach for your backups.

    I'd replace the Adaptec controller if I were you. If that doesn't fix the issues, then it is possible that you may have a bad SCSI hotswap backplane (assuming that you have one) or a bad cable or SCSI terminator. It is also possible that you havew a bad disc, but it is unlikely.

    You'll need to make a call on how much time you spend trying to fix the problem versus restoring from a backup and getting the system running again.

    As a last resort you could also try: RAID Reconstructor or GetDataBack from

    Author Comment

    Well I have reached for the tapes. That in of itself opens another whole can of worms. I have veritas running on a exabyte VXA-2 external drive. I setup a 80GB SATA drive, loaded SBS03, insalled the LSI SCSI card, tape drive, veritas. Attepted to inventory friday and thursday tape, bith show as being bad. I was having dificulty with wed tape and I made a serious error, re-labeled the tape. I just found out that that erases the data on the tape. I inventory wed tape and the catalog, attampt to restore and there is no data present. The last backup is 3 weeks old. At which I am about to goto the comapny office to get the 3 week old tape and try it anyway.

    Yesterday I tried the RAID Reconstructor, I had high hopes upon booting to Bart PE. however I have not been able to get the RAID Reconstructor to see any of my 3 RAID drives. I have attempted to F6 the SCSI RAID Adaptec 2130S drivers upon startup of bart but I still cannot see my drives. I can see my 200GB SATA drive that I was going to use to recover to.

    I have an SE7520BD2V MBB / SC5300BRP Case. I do have a SCSI backplate, I am using 3 out of the 6 hot swapable bays.

    I think I must be missing something on the RAID reconstructor, any ideas on why I might not be able to see my drives?
    Do I have to have them connected to the adaptec 2130S card to attapted to recover the RAID since this is the card that had the RAID???
    any other ideas on the RAID Reconstructor?

    Thankx in advance for any help!!
    LVL 30

    Expert Comment

    by:Duncan Meyers
    IIRC, the Adaptec card has two options: SCSI and RAID. Reset the option to SCSI and reboot - but **make sure** that the discs are removed before you reboot - earlier Adaptec RAID controllers would scribble on the discs when the change was made, destroying the data on the discs if the were running at the time of the change. It is a perfectly safe operation if you pull the discs, reset the BIOS option, reboot, then reinsert the discs after the Adaptec BIOS has completed its startup sequence.

    You should then be able to read the discs as individual discs. Having said that, the controller sounds pretty sick. You really need to look into replacing it before you get too much further.

    Author Comment

    I am tring that now.

    I just built this server 4 months ago. I execpt the fact that the controller card may be sik and I would love if that were the issue, then I could replace it and rest asured that the issue ot not repeet itself any time soon. However I am not sure that the issue is the card, how can I verify this?

    Is there some utiliy to verify the card's state? or health? Can I just RMA the thing to adaptec in hopes they agree its bad?
     I really just want to know what the issue is so as to avoid a repeet of this whole situation.

    Author Comment

    Well I have not found any way to set the adaptec 2130S to SCSI only from RAID. The Array Configuration Utiliity is very limited. I have attempted to connect the 3x SCSI drives into the onboard LSI SCSI controller and boot Bart, I get an error like the bart OS is currupt. If I remove the drives Bart PE boots fine. Does anyone know if bart PE is picky about LSI SCSI controllers? is there something special im missing?
    LVL 17

    Expert Comment

    LVL 44

    Expert Comment

    WIth a raid 5, you should always have that 4th disk handy for hot swap, in the event of a disk failure. But I agree with meyersd, this sounds more like a controller problem, else you would get a disk message.  

    You have probably gone so far now that you are at the point of recovering the data, or scrapping the drives via reformat.  Normally, putting the drives into a different RAID controller will not only NOT work, it usually trashes the data on the drives, unless the RAID controller chip is the same as on the original card.

    I third the suggestiions of getdataback, but when you go to, look at their raid reconstructor utility, this might just save your neck, it is very adept at RAID 5 detect, so I would start there.  Good luck.
    LVL 30

    Accepted Solution

    >attempted to connect the 3x SCSI drives into the onboard LSI SCSI controller
    That sounds like either bad termination (likely) or possibly a bad drive...

    FWIW - AMI (now LSI) MegaRAID controllers are pretty good at handling discs written on other RAID controllers. They'll handle Adaptec and Mylex RAID sets without an issue (although I doubt that its supported :-) ), and Adaptec RAID controllers will read an LSI created array, but goes a bit silly if you try to write to it.
    LVL 1

    Expert Comment

    Most likely the controller has failed, so it is neither reasonable nor practical to attempt to read the disks with that very controller.

    If you have a spare controller (same model not required; RAID not required; any kind of SCSI controller will do), possibly (and preferrably) on the other machine.
    1. Label the disks and cables as you can recreate the original configuration if required.
    2. Move the disks to the spare SCSI controller.
    3. Run RAID Reconstructor.

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Join & Write a Comment

    Suggested Solutions

    Sometimes the best way to deal with an infected computer is to boot from external media and run your tools from there.  The reason you may wish to do this really depends on the infection.  Some malware is so recalcitrant that no matter what you do i…
    Lets start to have a small explanation what is VAAI(vStorage API for Array Integration ) and what are the benefits using it. VAAI is an API framework in VMware that enable some Storage tasks. It first presented in ESXi 4.1, but only after 5.x sup…
    This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
    This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now