lastest wxp sp2 does not return hostname

Hello network experts

I've noticed that in some of the latest wxp sp2 instalations wxp does not return "hostname" when being ping from other computer.

lets say computer A is pinging (with ipscan computer B (with wxp sp2)

I enabled the "allow incoming eco" checkbox on the firewall section to respond to ping.
but i get no hostname.

I have some wxp sp2 boxes so when trying to view them in ipscan, i get "N/A" instead of hostname

that only happens with those boxes, it works fine with wxp, wxp sp1, w98, w2k3

if I completely disable the firewall I get the hostname again.

i need that firewall enabled, what else can I change to get the hostname while pinging xpsp2 boxes?

thanks in advance!!!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hi HTorres,

why would you bother with windows firewall? it is nothing but bad news

icmp echo has nothing to do with name resolution. If you eanble it in firewall, it is only going to allow echo responses.

If you do not have DNS, most likely you were getting hostnames via NetBios Resolution or Client for Microsoft Network. Try opening the following ports and see if it works.

(UDP) ports from 135 through 139 and Transmission Control Protocol (TCP) ports from 135 through 139.

Direct-hosted SMB traffic without a network basic input/output system (NetBIOS): port 445 (TCP and UPD).

Also, read the following EE before opening those ports

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HTorresAuthor Commented:
thanks Jay_Jay70 what are you using for firewall?

Thanks naveedb,
I know ICMP has nothing to do with that, I just mentioned because it is the first thing people has been telling me about, (so i can ping xp sp2 boxes)

let me open those ports and I'll let you know.

thanks in advance.

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

for myself at home i simply use the firewall on whatever router i have at the time..... usually just standard port blocking and requests etc

i disable windows firewall on every machine i configure becoz for home and office networking it is insanely frustrating and as far as i am concerned a complete waste of time

there are a couple of freeware firewalls around but for home i dont bother - just my opinion and experience so far

at work i sit behind a big nokia firewall which is big money and overkill unless you have a lot of users
HTorresAuthor Commented:
I just enabled simple file sharing, and the firewall opened ports
tcp 139 tcp 445 udp 137 udp 138... and that did it.

im taking naveedb's comment as answer
HTorresAuthor Commented:
Thanks naveedb
You are very welcome. I am assuming this firewall is not protecting a direct connection to the internet, if it is be carefull. If it behind a router or internal network, then you should be fine.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.