Read Only Files & Folders on a Win 2000 Server

I have a Windows 2000 Server that crashed. I was able to recover data from a mirrored drive. I copied the data from the mirrored drive to a new hard disk on the server.

When accessing the data from a Windows XP client, all the files/folders are READ ONLY. If I copy the files to the local client, I have Full Control. If I copy them back to the server in a different location, the files and folders are read only.

When looking at the file attributes on the Windows 2000 Server, the READ ONLY checkbox IS NOT checked. It's only checked when browsing to a network share from the Windows XP client. So, I'm thinking it's a permissions issue, but I can't figure out how to make the files available with FULL CONTROL for the XP client.

The XP machine and the Windows 2000 Server had the same Admin user account and password name. They're part of a workgroup, not a domain.

Anyone have any suggestions to try to provide the XP client with Full Control of these files and folders?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

It looks like we are dealing with 2 different sets of permissions: Share permissions and File/Folder permissions.

From the share, be sure it is configured for full control for the users that should have that access, as well as the local file permissions full control and see if that helps.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
brownmetalsAuthor Commented:
HI Gary.

Thanks for the tip. I've already configured NTFS and Share permissions for FULL CONTROL for the Everyone Group, Admin Group, and any user that would sign on to the Win XP client machine. I'm thinking that for some reason, the Windows 2000 Server is not recognizing users that sign on to the client machine. It's a member server, so is there any other place that I should be looking to see why a user cannot gain access to shared resources on the Windows 2000 Server?

brownmetalsAuthor Commented:
Just some more feedback on this situation. I logged onto the Windows 2000 Server as the administrator. This is the server that the shares reside on. I created a test file from the XP client and saved it to one of the network shares. The filename saved, but none of the content saved because I can't seem to get write permissions from the XP client to the share.

However, the interesting thing is that I cannot delete this file while logged on as an Administrator on the server. On the server, I should be able to delete that file. I've tried using the ATTRIB command from DOS to remove any READ, ARCHIVE, or SYSTEM attributes. Trying to delete the file produces this error: "Cannot delete filname. There is a sharing violation."

Any ideas?

Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

That is strange.  Try this ...

From the Windows 2000 server, right-click on My Computer -> Manage
Expand "Shared Folders" and select "Open Files"

See if your test file is shown as open by the XP client.  If so, force a disconnect and then see if you can delete it locally.
brownmetalsAuthor Commented:
Sorry it's taken me so long to get back to this.

I've ditched the Windows 2000 server all together. I moved the RAID1 array and controller from the Windows 2000 server to my client machine (Windows XP). Now, I'm going to share it for other computers on the network (peer-to-peer) setup.

The two computers I'm testing this with (my XP machine and a laptop) are still having problems with pemissions via the SHARED FOLDERS. Here's what I've done:

1) Each computer has a computer name and is part of the same Workgroup
2) The username used to logon to the laptop has been added as a user on the Windows XP desktop machine. Each of the shares has NTFS and Share permissions that allow this user account to access those files
3) Firewall settings have been altered to allow communication between the two machines.

When I browse from the laptop to the desktop, I can see the shared folders, but I'm denied access to the contents of the shared folders.

Any other suggestions to help get this working? I'm going to research it while this question stays open. I'm sure it's a small thing I'm just overlooking.

Thank you,

brownmetalsAuthor Commented:
Got it!

For some reason, the username I was using on the laptop and the desktop were not in sync. I created a new user account on each of the machines with the same password and that solved the issue.

Thanks to everyone for their input. Even though suggetions did solve the original issue, the context of the question changed as hardwre was changed in and out on my end. I'm happy to award you some points for your input.

Thank you,

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.