Choppy DVD playback

I have a HP 512C machine that I have recently upgraded.  It is a 1.7 Ghz machine that now has 768 mb RAM, onboard video.  Every time I play a DVD in a newly installed DVD burner, the video is choppy.  If I minimize the visual part of the DVD playback, the audio comes through smooth.  What are some possible fixes for this problem????

Thanks,
Kendal
gvector1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Irwin SantosComputer Integration SpecialistCommented:
drop the screen resolution to 1024 x 768
have you updated your video drivers?

latest directx?
http://www.microsoft.com/windows/directx/default.mspx

latest DVD program update?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gary CaseRetiredCommented:
Sounds like the DVD drive may have reverted to PIO mode transfers.

If so, this will fix it:  (this is a harmless registry edit -- the deleted values will be reset by Windows at next boot)

Load RegEdit (Start - Run - Regedit)

Go to the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Under each key, delete all occurences of the following values:

     MasterIdDataChecksum
     SlaveIdDataChecksum

Now reboot your system and see if the problem disappears.


You can check the current transfer mode in Device Manager if you want -- expand your IDE ATA/ATAPI controller line; and for each IDE channel (Primary & Secondary) do a right-click, Properties, and look on the Advanced Settings tab to see what the "Transfer Mode" is set to (should be "DMA if Available") and what the "Current Transfer Mode" is (you can't change it, but you can see what it is).   In any event, I'd do the forced redetect I noted above (the registry modification).
0
gvector1Author Commented:
I'm sorry I lost track of the post.  It was the video driver needing updating.
0
Irwin SantosComputer Integration SpecialistCommented:
Cool. thank you gvector1!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.