Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 871
  • Last Modified:

Intermittent RDP connection problem via Cisco VPN

I'm setting up a VPN for communications between my HQ and branch offices, as depicted below:


HQ                                                                                        
------                                                                                      
ABC Server --- Cisco PIX 515E ----Cisco Router 2600  
(in dmz)                                            |
                                                        |
                                                   Internet
                                                        |
                                                        |
                                                     ADSL Router ---- Cisco PIX 501 ----- Local LAN
                                                                                             
                                                                                      Branch Office
                                                                                      ------------------

IP address:
----------------
ABC Server - 192.168.118.2/255.255.255.248
Cisco PIX 515E dmz - 192.168.118.1/255.255.255.248
Cisco PIX 515E Outside - 202.188.15.130

Cisco PIX 501 Outside - 10.0.0.3
Cisco PIX 501 Inside - 192.168.0.200
Local LAn PCs - 192.168.0.0/255.255.255.0

The client PCs in branch office's local LAN need to access ABC Server at HQ, via remote desktop at port 3389.  The tunnel seems successfully created.  However, I have an intermittent connection problem with the RDP, which sometimes successful but sometimes failed.  

Whenever the RDP connection fails, I would reset the VPN session by typing 'vpnclient disconnect' at the PIX 501 of branch office.  Soon after performing this, the RDP flows smoothly.  Any ideas?  The following is the config of the PIX firewall at both ends:

HQ's PIX 515E (VPN Server):
-------------------------------------
PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security80
enable password faggj4pos6hfdg encrypted
passwd apgoj43h8gerpge encrypted
hostname FW
domain-name xxx.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
no fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
access-list acl_outside permit tcp any host 210.22.121.190 eq 3389
access-list 101 permit ip 192.168.118.0 255.255.255.248 192.168.138.0 255.255.255.0
access-list 101 permit ip 192.168.118.0 255.255.255.248 192.168.0.0 255.255.255.0
pager lines 24
logging timestamp
logging trap errors
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 202.188.15.130 255.255.255.248
ip address inside 192.168.128.200 255.255.255.0
ip address dmz 192.168.118.1 255.255.255.248
ip audit info action alarm
ip audit attack action alarm
ip local pool xxxpool 192.168.138.1-192.168.138.100
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address dmz
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 192.168.128.0 255.255.255.0 0 0
nat (dmz) 0 access-list 101
static (dmz,outside) 210.22.121.190 192.168.118.2 netmask 255.255.255.255 0 0
access-group acl_outside in interface outside
access-group acl_inside in interface inside
access-group acl_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 202.188.15.129 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set xxx esp-3des esp-md5-hmac
crypto dynamic-map xxxdynmap 10 set transform-set xxx
crypto map xxxmap 10 ipsec-isakmp dynamic xxxdynmap
crypto map xxxmap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup xxx-rdp address-pool xxxpool
vpngroup xxx-rdp split-tunnel 101
vpngroup xxx-rdp idle-time 1800
vpngroup xxx-rdp password ********
telnet timeout 1
console timeout 0
terminal width 80
Cryptochecksum:dd1b887775a40e6c27b14d9d64fd561d
: end


Branch office's PIX 501:
-----------------------------
fw# sh run
: Saved
:
PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password Wvwd/2Aaz/ZSI2Ea encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname fw
domain-name xxxbranch.com
fixup protocol dns maximum-length 512
fixup protocol domain 53
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
no fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
no fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl_inside permit tcp 192.168.0.0 255.255.255.0 any eq 3389
pager lines 24
logging monitor debugging
logging buffered debugging
logging trap debugging
logging history debugging
mtu outside 1500
mtu inside 1500
ip address outside 10.0.0.3 255.255.255.0
ip address inside 192.168.0.200 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
access-group acl_inside in interface inside
route outside 0.0.0.0 0.0.0.0 10.0.0.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
console timeout 0
vpnclient server 202.188.15.130
vpnclient mode network-extension-mode
vpnclient vpngroup xxx-rdp password ********
vpnclient enable
terminal width 80
Cryptochecksum:9c424b680bb549aa2ebfbb5df7dc5156
: end


I have also open the following ports at the HQ's router:

IKE       (UDP/500)
NAT-T  (UDP/4500)
ESP      (protocol 50)

Any ideas?  Any incorrect configuration at the PIXs?  Thanks in advance.
0
hoggiee
Asked:
hoggiee
  • 2
  • 2
1 Solution
 
hoggieeAuthor Commented:
And not to be left out, here is the debug message (Branch Office PIX):

fw# sh isakmp sa
Total     : 1
Embryonic : 0
        dst                         src           state           pending       created
   202.188.15.130         10.0.0.3      QM_IDLE                0               3


fw# debug crypto isakmp
ISAKMP (0): sending NOTIFY message 36136 protocol 1
crypto_isakmp_process_block:src:202.188.15.130, dest:10.0.0.3 spt:500 dpt:500
ISAKMP (0): processing NOTIFY payload 36137 protocol 1
        spi 0, message ID = 1285738313
ISAMKP (0): received DPD_R_U_THERE_ACK from peer 202.188.15.130
return status is IKMP_NO_ERR_NO_TRANS


and when I start a RDP connection, the PIX at branch office shows the following:

fw(config)# IPSEC(key_engine): got a queue event...
IPSEC(spi_response): getting spi 0x9f20987c(2669713532) for SA
        from   202.188.15.130 to        10.0.0.3 for prot 3
IPSEC(validate_proposal_request): proposal part #1,
  (key eng. msg.) dest= 202.188.15.130, src= 10.0.0.3,
    dest_proxy= 192.168.118.0/255.255.255.248/0/0 (type=4),
    src_proxy= 192.168.0.0/255.255.255.0/0/0 (type=4),
    protocol= ESP, transform= esp-3des esp-md5-hmac ,
    lifedur= 0s and 0kb,
    spi= 0x0(0), conn_id= 0, keysize= 0, flags= 0x4
IPSEC(key_engine): got a queue event...
IPSEC(initialize_sas): ,
  (key eng. msg.) dest= 10.0.0.3, src= 202.188.15.130,
    dest_proxy= 192.168.0.0/255.255.255.0/0/0 (type=4),
    src_proxy= 192.168.118.0/255.255.255.248/0/0 (type=4),
    protocol= ESP, transform= esp-3des esp-md5-hmac ,
    lifedur= 28800s and 4608000kb,
    spi= 0x9f20987c(2669713532), conn_id= 2, keysize= 0, flags= 0x4
0
 
blin2000Commented:
It could be MTU issue. We have seen many similar issues like this. This search result may help,

Can't access RDC over VPN
I would check the MTU first. Or check this link: vpn drop connection. The both offices can browse over the VPN without problem… Resolution: modify the MTU. ...
http://www.chicagotech.net/Q&A/vpn47.htm 
0
 
hoggieeAuthor Commented:
blin2000:

You are suggesting that I should lower the value of 'mtu dmz 1500' at the HQ PIX firewall, and also 'mtu inside 1500' at the branch office PIX firewall? Or lower the MTU value for all?

0
 
blin2000Commented:
it depends. I would try the branch office first.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now