[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco Pix 501 VPN Issue

Posted on 2006-04-24
10
Medium Priority
?
2,616 Views
Last Modified: 2013-11-16
Having a few issues trying to get Cisco VPN clients to connect to a local intranet once connected, the internal hosts work fine but the cisco vpn clients get the following message when they try to type the intranet URL in http://intranet.domain.local : -
 
Bad Gateway code=DNS_HOST_NOT_FOUND The host name was not found during the DNS lookup

Version of Cisco VPN clients: - 4.6.00.0045
Operating system: - XP sp2
Cisco vpn clients can ping everything okay, pickup emails fine just cant browse the local intranet ?

Tried iisresets (no good), but the internal hosts work fine ?!

The only reason i can think this problem started to occur is when i upgraded the PIX 501 from a 10 user license to an unlimited license and resetup the 3des key and then i tried to setup split tunneling

Any ideas would be most welcome !

nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ****** encrypted
passwd ******** encrypted
hostname pix
domain-name domain.local
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
access-list 101 permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 100 permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 100 permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list acl_out permit tcp any host xxx.xxx.xxx.xxx eq https
access-list acl_out permit tcp any host xxx.xxx.xxx.xxx eq smtp
access-list acl_out permit tcp any host xxx.xxx.xxx.xxx eq ssh
access-list 90 permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
interface ethernet0 10baset
interface ethernet1 10full
icmp permit any unreachable outside
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
ip address inside 192.168.0.250 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool glasgowpool 192.168.1.1-192.168.1.25
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
static (inside,outside) tcp interface https 192.168.0.100 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 192.168.0.100 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ssh 192.168.0.120 ssh netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set JKGLASSET esp-3des esp-md5-hmac
crypto dynamic-map dynmap 3 set transform-set JKGLASSET
crypto map glasgow 1 ipsec-isakmp
crypto map glasgow 1 match address 101
crypto map glasgow 1 set peer xxx.xxx.xxx.xxx
crypto map glasgow 1 set transform-set JKGLASSET
crypto map glasgow 2 ipsec-isakmp dynamic dynmap
crypto map glasgow interface outside
isakmp enable outside
isakmp key ******** address xxx.xxx.xxx.xxx netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 1000
vpngroup vpn3000 address-pool glasgowpool
vpngroup vpn3000 dns-server 192.168.0.100
vpngroup vpn3000 default-domain domain.local
vpngroup vpn3000 split-tunnel 90
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet timeout 5
ssh xxx.xxx.xxx.xxx 255.255.255.255 outside
ssh timeout 60
terminal width 80
0
Comment
Question by:jturkington
  • 5
  • 3
  • 2
10 Comments
 
LVL 19

Expert Comment

by:nodisco
ID: 16526361
hi there

What ip address is the Intranet site running on and are the internal users also using 192.168.0.100 for DNS resolution   the problem may be with split-tunnelling or a needed internal route if its not on the PIX inside subnet range.
0
 

Author Comment

by:jturkington
ID: 16526407
intranet : -  192.168.0.130

Internal users are using same dns server:  - 192.168.0.100

Problem was occuring before split tunneling was implemented, license upgrade may have messed it up ...

tried write erase and loaded config in again (no joy)

Cheers

JT
0
 
LVL 19

Assisted Solution

by:nodisco
nodisco earned 400 total points
ID: 16526512
1 I see you have an IPSec tunnel configured to a different network 192.168.2.0 - can you access the intranet site from a host on that network ok?

2 Is there anything on IIS that is restricting access to the intranet from certain subnet ranges - and is not including your client vpn pool?

3 do you get the same error if you try and open the intranet site by ip name also?

0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 1600 total points
ID: 16526531
>ip address inside 192.168.0.250 255.255.255.0
>ip local pool glasgowpool 192.168.1.1-192.168.1.25

These two IP subnets are two of the most widely used in the world, and are the default subnets for the vast majority of home consumer routers. If remote users buy a Linksys router for example, their home LAN is 192.168.1.x
If remote users use Microsoft's Internet Connection Sharing (ICS), they will have their home LAN as 192.168.0.x

You might want to try enabling split-dns
What version PIX OS?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1600 total points
ID: 16526543
>Version of Cisco VPN clients: - 4.6.00.0045
I think 4.6 is a buggy version that does not always play nice with the latest rounds of Microsoft updates for XP
Suggest updating to the latest 4.8.x
0
 

Author Comment

by:jturkington
ID: 16526547
1. 192.168.2.0 is a site to site VPN with another cisco pix 501 this works !!?!?!?!?!?
2. The 192.168.1.0 subnet range has been allowed access for the intranet website along with 192.168.0.0 and 192.168.2.0

3. Done a bit of testing removed split tunnel and i just get a page cannot be displayed message with the vpn clients now
   DNS error must be related to split tunnel

Cheers

JT
0
 

Author Comment

by:jturkington
ID: 16526590
Cisco PIX Firewall Version 6.2(2)
Cisco PIX Device Manager Version 2.0(2)
Failover:           Disabled
VPN-DES:            Enabled
VPN-3DES:           Enabled
Maximum Interfaces: 2
Cut-through Proxy:  Enabled
Guards:             Enabled
URL-filtering:      Enabled
Inside Hosts:       Unlimited
Throughput:         Limited
IKE peers:          5

JT
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16526687
> PIX Firewall Version 6.2(2)
Pretty old, latest is 6.3(5)

New question back to you:
http://intranet.domain.local
What ip should this resolve to? Is it a 192.168.0.x IP?

Try adding a hosts file entry on the client for the proper ip and see if that works.
If yes, then we can look at causes.
If no, at least we can't make things worse.

0
 

Author Comment

by:jturkington
ID: 16526715
ping resolves perfectly to 192.168.0.130 for either intranet or intranet.domain.local

hosts file didnt make a difference....


0
 

Author Comment

by:jturkington
ID: 16544140
Upgraded to 6.3(5) and client 4.8, had a little bit of luck with a few of the VPN clients (Ones that had dial up access)

But i think i found the problem........

isakmp nat-traversal

Most of the Cisco VPN clients that dont work are behind some sort of router/firewall that performs NAT when i tested the new setup on a laptop with a dialup account it worked fine !

So it looks like NAT was corrupting the packets in some form.

Thanks for your help lrmoore, you put me on the right road !

Cheers

JT
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month20 days, 6 hours left to enroll

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question