install

i installed apache on win 2K. how do i verify it is properly instaled. what config change do i need
perlperlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

m1tk4Commented:
Start it (Apache), then open:

http://localhost/

in your browser.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
perlperlAuthor Commented:
i getthis  message

You do not currently have a default document set for your users. Any users attempting to connect to this site are currently receiving an "Under Construction page".
0
perlperlAuthor Commented:
i think so it is looking for IIS on win 2000 server....however i have installed apache and it is running
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

perlperlAuthor Commented:
apache.exe is running still i get that message
0
m1tk4Commented:
stop IIS, restart Apache, retry. I
0
perlperlAuthor Commented:
this is what i noticed
when i do
http://hostname:portnumber

it list all the file sunder

C:\Program Files\Apache Group\Apache2\htdocs
i can click the images and file

what i want is i want to place all the files in cgi-bin and see it from url  http:hostname:/portnumber/cgi-bin/printenv.pl
0
perlperlAuthor Commented:
apache is properly installed since i can open http://hostname:portnumber

but i cannot view
http:hostname:/portnumber/cgi-bin/printenv.pl
0
m1tk4Commented:
It should be

http://hostname:portnumber/cgi-bin/printenv.pl

And to see the results you also need Perl to be installed.
0
perlperlAuthor Commented:
perl is already installed...and i tried http://hostname:portnumber/cgi-bin/printenv.pl

not working
0
m1tk4Commented:
Define "not working" (i.e. what error message are you getting and what's in the error logs).
0
perlperlAuthor Commented:
lemme uninstall apache first...
can i get complete steps to install and configure apache to run cgi pages
0
perlperlAuthor Commented:
how do i find server's full DNS name and what should be "Domain name" while installing apache
0
perlperlAuthor Commented:
when i try "http://hostname:portnumber/cgi-bin/printenv.pl" i get
Forbidden
You don't have permission to access /cgi-bin/printenv.pl on this server.

but i can pages like
http://hostname:8080/index.html.en
http://hostname:8080/apache_pb.gif
0
perlperlAuthor Commented:
this is mu sample file


ServerRoot "C:/Program Files/Apache Group/Apache2"
PidFile logs/httpd.pid
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15

<IfModule mpm_winnt.c>
ThreadsPerChild 250
MaxRequestsPerChild  0
</IfModule>
Listen 8080
LoadModule access_module modules/mod_access.so
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_module modules/mod_auth.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
LoadModule imap_module modules/mod_imap.so
LoadModule include_module modules/mod_include.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule userdir_module modules/mod_userdir.so
ServerName xxx.xxxx.xxx.com:8080
UseCanonicalName Off
DocumentRoot "C:/Program Files/Apache Group/Apache2/htdocs"

<Directory />
    Options FollowSymLinks +ExecCGI
    AllowOverride None
</Directory>
<Directory "C:/Program Files/Apache Group/Apache2/htdocs">

    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all

</Directory>
UserDir "My Documents/My Website"
DirectoryIndex index.cgi index.html index.htm
AccessFileName .htaccess

<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
</FilesMatch>
TypesConfig conf/mime.types
DefaultType text/plain

<IfModule mod_mime_magic.c>
    MIMEMagicFile conf/magic
</IfModule>

HostnameLookups Off

ErrorLog logs/error.log

Alias /icons/ "C:/Program Files/Apache Group/Apache2/icons/"

<Directory "C:/Program Files/Apache Group/Apache2/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
AliasMatch ^/manual(?:/(?:de|en|es|fr|ja|ko|ru))?(/.*)?$ "C:/Program Files/Apache Group/Apache2/manual$1"

<Directory "C:/Program Files/Apache Group/Apache2/manual">
    Options Indexes
    AllowOverride None
    Order allow,deny
    Allow from all

    <Files *.html>
        SetHandler type-map
    </Files>

    SetEnvIf Request_URI ^/manual/(de|en|es|fr|ja|ko|ru)/ prefer-language=$1
    RedirectMatch 301 ^/manual(?:/(de|en|es|fr|ja|ko|ru)){2,}(/.*)?$ /manual/$1$2
</Directory>
#ScriptAlias /cgi-bin/ "C:/Program Files/Apache Group/Apache2/cgi-bin/"
Alias /cgi-bin/ "C:/Program Files/Apache Group/Apache2/cgi-bin/"
<Directory "C:/Program Files/Apache Group/Apache2/cgi-bin">
      Options ExecCGI
      AddHandler cgi-script .cgi .pl

    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>

AddHandler cgi-script .cgi

AddType text/html .shtml
AddHandler server-parsed .shtml
0
perlperlAuthor Commented:
if i try
http://hostname:portnumber/cgi-bin/test.txt  it properly displays the contents

but it cannot display .cgi and .pl files
0
perlperlAuthor Commented:
http://hostname:portnumber/cgi-bin/test.html also works but not .cgi and .pl
0
perlperlAuthor Commented:
FYI, if i manually run the script from command prompt, it executes properly

but thru browser i get permission error
0
sleep_furiouslyCommented:
From the config you posted:

<Directory "C:/Program Files/Apache Group/Apache2/cgi-bin">
      Options ExecCGI
      AddHandler cgi-script .cgi .pl

    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>

I think the "Options None" is overriding the "Options ExecCGI".
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.