Win 2000 SBS disable shares when logged in

I have a Win 2000 SBS server that i have just reformatted.
When i login to it, i can access the network and see the clients but when i go to get a client to look for the server i can't see it on the network. Also i can't access the domain either. but i can ping the name and ip of the server.
Yet if i just boot the server up and don't login. the server can be accessed just like it should do.
It also does the same if i login as a different user.
It seems to be something that starts up when i login. I have looked in the startup folder and there is nothing, i can't see any thing unusual in the reg run services. they have only the win update line in them and NAV.

I have run adaware, virus scans, updates. I found info on this site about missing admin shares and tried following that.
There's no error's that link to this problem in event viewer either.

any idea's  ?
LVL 1
total123Asked:
Who is Participating?
 
SaineolaiCommented:
winupdate32.exe is associated with the W32/SdBot-BM virus.   The other file name looks suspicious also.
0
 
Robberbaron (robr)Commented:
do you logon to the client as a Domain account ?

try logon as a member of domain admins group. then try accessing the admin shares eg \\servername\c$

0
 
total123Author Commented:
Yeh we do logon as a domain account.
just tried the c$ with the server on the logon screen and it worked. it doen't work when you login to the server.
Which makes sense as it disables people being able to see the domain in network places
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
SaineolaiCommented:
After you login into the server as Domain Administrator, can you access any of the shares from the server console .i.e., \\servername\c$.  If you cannot can you check in the services mmc to see if any of the automatically started services are stopped.

Possibly some of the services are crashing during login.
0
 
dhoustonieCommented:
Have you applied any group policies?
Particularly associated to user accounts?

David
0
 
total123Author Commented:
I've just logged into the server and i can not see \\servername\c$.
looked in server mmc and there are no services stopped or crashed.

with group policies, i have set the users up the usual way in add users and giving some the admin template and others the power user template. I haven't changed any thing else in policies or groups.

hope this helps
0
 
SaineolaiCommented:
From a command prompt on the server can issue the command "net share" and see if any shares are listed.
0
 
total123Author Commented:
what i have noticed is in the registry i have under
hkey_local_machine\software\microsoft\windows\currentversion\run and runservice

there is a link :-
name -                                           data
microsoft update adbpro        -      msupdate33.exe
microsoft windows update 32 -      winupdate32.exe

when i delete the adbpro line from the reg it regens itself. yet the winupdate32.exe doesn't.
i'm assuming that the winupdate32.exe is part of normal ms update ?
i don't no what msupdate33.exe does or what adbpro is.
any ideas
0
 
total123Author Commented:
thankyou saineolai
it was a spybot virus
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.